Question about 2007 Mercury Monterey

1 Answer

Check engine light

My van has been cutting off and the check engine light on. Cam sensor was replaced and it is still cutting off. Do you have any advice?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Mercury Master
  • 21,873 Answers

What was the original trouble code ?

Posted on Feb 11, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 98 astro van starts cutting out while driving down the road. if i lay on the gas it stops until i get up to 58 mph then starts again. if i dont have enough road to gas it it will do it continue to cut...


do you have a check engine light on? I'm guessing you do and if you have the code read you will find a crank/cam sensor is probably bad. some parts stores will read a code for free

Apr 18, 2014 | Chevrolet Astro Cars & Trucks

1 Answer

I have a 2003 kia sedona van 3.5 liter that jumped time. I reset the timing put a new belt on it and it ran good for 35-45 min. Then it cut off, and wouldn't start back up. It has an OBD2 code for cam...


cam sensor fail can be crank sensor fail engine will run with cam sensor fail but crank it will not fire. also recheck the timing belt settings you fit the timing belt and run engine till warm then recheck the belt adjustment to make sure its in line and at recommended tightness.

Aug 07, 2017 | Cars & Trucks

1 Answer

Code p1391 showed up on the code reader when it was hooked up, chech engine light is on?


Hello my name is brad,a code p-1391 is a crank sensor code or the cam sensor..check wiring connetors at crank sensor or at cam position sensor,do you have a car or truck or mini van and what size engine.i hope this helped brad

Sep 19, 2011 | Chrysler Cirrus Cars & Trucks

1 Answer

The engine turns over but the motor will not start. The van was running fine when it was cut off. It doesn't seem to be getting gas.


It's very likely your fuel pump has failed. Have somebody thump on the fuel tank while you're cranking the engine and see if it starts. If it does, replace the fuel pump. Otherwise get your fuel pressure checked, and check for spark. If no spark, check to make sure the distributor is turning(if applicable) If a 3.3 motor with no spark, suspect the crank sensor or cam sensor. Crank sensor is much easier to replace if experimenting.

Sep 05, 2011 | 1990 Dodge Caravan

1 Answer

2008 Kia Rio-After I replaced the timing belt my check engine light came on. I was told that the cam shaft position sensor was bad and needed to be replaced. I replaced it and the check engine light came...


were the codes cleared after replacment if not try that
if they were test the wires for cam signal and check for damaged ---cuts---fraied---pinched

May 28, 2011 | 2008 Kia Rio

2 Answers

1999 Intrepid with a 2.7 engine dies after driving 15 miles. pull over and it starts right up and runs fine again


This Symptom (WITHOUT)> Check Engine Light on Is indicative of a FUEL PUMP INTERMITTEN Failure/FUES FILTER CLOGGING Problem, But (WITH Check Engine Light ILUMINATED)< The Vehicle Must Be Connected to A CODE/ Diagnostic Tool to Interpret What Code and Where the Problem IS Located. I am Sure this WILL Help LEAD you to Your Problem.

Oct 20, 2010 | 1996 Dodge Intrepid

1 Answer

Cam position sensor broke


ok easy fix. this is common on ALL ford w this style cam sensor,3.0 eats them for lunch. the sensor base has bushings like a real distributor, they get wore and fail. you can get new from ford, or reman at auto parts about 100 bucks. they come w the sensor installed but as with either, you need the allginment tool, looks like a little hockey puck, that only come from ford to set up or check engine light wont shut off. it will run without this but poorly. if you need more advice just post a comment to this and ill do my best to advise you

Sep 03, 2009 | 1998 Ford Explorer

1 Answer

Check engine light


  1. ENG NOT START LIGHT COMEING CHECK ENG IT IS FLASING. HOW CAN I SOLVE THE PROBLEM

Aug 19, 2008 | 2000 Suzuki Swift

Not finding what you are looking for?
2007 Mercury Monterey Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

fordexpert

Level 3 Expert

5537 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...