Question about 2004 BMW 3 Series

Open Question

My car stalled and will not start

It appears that fuel is not going to the motor, i checked all my fuses(no blown fuse), but i dont get power going to the fuel pump. using the chassy as ground i get voltage at the fuel pump relay and all the other fuses, but no voltage found using the relay's ground and fuse ground. what else could be the problem?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 113 Answers

SOURCE: BMW 740IL Wiper Issue

try checking for a short to power on ur 12 volt comming into motor also check for a good ground at the plug for ur wiper motor

Posted on Jun 17, 2008

  • 24 Answers

SOURCE: 7.5 amp fuse blows, car will not start.

hello , if when you replace the fuse the vehicle starts and this fuse is for the ews check for a oil level sensor shorted or the wires going to it defective, this is wired in the same loom as the ews and the short will cause the fuse to go and the ews will not have power /when it rains the water will aid to the problem

Posted on Nov 23, 2008

  • 333 Answers

SOURCE: bmw 540i fuel pump

You must check to see if you have power at the fuel pump relay which is probable in a fuse box under the hood.

Posted on Jan 21, 2009

  • 3 Answers

SOURCE: 1994 BMW 530i replaced the fuel pump the car will not start

i have the same problem right now. the relay is located under the big black box on passenger side of engine compartment. There are three relays in there. orange, blue and white. I dont know which is associated with the fuel pump though.

Posted on Mar 08, 2009

  • 219 Answers

SOURCE: 1993 bmw 525i. I changed the fuel pump relay,

hello vchinto, when you reinstalled the fuel pump, did you make sure the lines were reinstalled correctly. the lines may or may not have the to and from arrows on them and can accidentally be installed backwards. if the fuel hoses are correct, check for 12 volts across the blue/green wire and the brown wire at the fuel pump connector. with the engine cranking it should be appr. battery voltage.

Posted on Apr 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1992 Dodge Grand Caravan 3.3L stalled and wont start. No hum from fuel pump when key turned on, no fuel pressure at rail. I tryed starting fluid thru intake and no go. What could cause this?


is the fuel pump working now. sometimes the fuel relay can be the fault for no fuel. you need between 3-5 bar on fuel rail so just putting fuel in will not work. you will need a meter to check there is voltage getting to the pump the wires on pump remove them and connect to the meter and turn on ignition if volts then the pump is dead if there is no volts the relay is not working or the fuse has blown, , if fuse not blown then the relay is not working, or there is a damaged wire, even if the relay clicks it doesn't always mean its connecting.

Jan 29, 2017 | Dodge Cars & Trucks

3 Answers

1996 Geo Tracker engine shuts down while driving. restarts sometimes ,sometimes not. whats the problem


Check your switch first..then wiring going to fuse panel on both under the dash and under the hood.

Also check the oil level.. some cars will shut down if low on oil.

Sep 11, 2015 | Geo Cars & Trucks

2 Answers

How to check a ignition coil pack to see if its good,


the coil does not crank the engine , the starter does that, sorry.
(if you ever had to hand or foot crank and engine , youd under stand that. (like motor cycles or boat engines, or per 30s cars.)

in fact will crank all day with no spark parts on car..

x2, the scan tool does tell you why there is NO STARTS, CRANKS OK. The pcm can detect, one missfire in 10 cmp;ckp signals.
  • CRANK FOR 5 SECONDS
  • release, key
  • scan tool has DTC errors?, read the believe them.
no engine stated of 4 or more,

U checked everything but spark,
why, check spark at all cylinders, all most fire or the engine will not run or stall.
That test be first, if not starting (AFTER SCAN TEST)

IF NO spark fuses are next , not last.
lets do no start fails tests. (cranks perfectly 200 to 300 rpm)
  1. : check fuses
  2. key on, CEL lamp must glow, if not , ECU fuse blown.
  3. crank with scan tool , see P03xx DTC errors, see RPM dead.?
  4. check for spark? got spark x4 or times number of cylinders?
  5. got spark try test fuel now, runs for 3 seconds?
  6. yes, runs on test fuel now means lost fueling
  7. no, dont run on test fuel, means, 1 to 5 done wrong above or engine compression bad.
  8. bad fueling, huge number of tests. check fuel pressure now.
confused, try a shop and watch them, learn.

Jan 12, 2015 | 2005 Suzuki Forenza

1 Answer

Where is the 1997 Isuzu Trooper inertia fuel button located, cranks over will not start?


one more anony post, making help hard if you have 2 or more post.
see? why do that?
why guess? why not use a real book on topic
well if any engine stalls, the CEL glows.
the CEL glows for the stall self tests. it glows telling you
the ECU is ok and has 12vdc power.
get the schematic for your car.
and find out why power is lost the EFI system. this is not the nebulas inertia switch,
what does SEEM mean.??? using a voltmeter works, looking and guessing not. use a voltmeter to find where power is lost.
your not stumped,
you dont have a meter
and dont have the book
so log in the alldata.com

btw2: no engine size stated, and guess what.
the schematic for all parts are different. fuel and electric.
if you go on line
the ask,year, make ,model and ENGINE.
can fix any engine, until you know what is there. impossible.
(unless you use BASICS for OTTO Cycle engines)
lets do that. for fun
got spark? no
got CEL ,no
Got power to ECU , no.
so you use the voltmeter to see where power is lost in this power feed system. (its a tree construct)

now a random answer, 6 cylinder engine.
Fuse C8 or F3 blown.
engine, and ECM F3 powers the whole ECU.(PCM)
main relay output wires dead. red/blue wires. killing all spark and fuel.
fuse C10 kills he CEL lamp dead.
is uses a volt meter, (walfart for $10?)
and both sides of these fuses read 12vdc to ground.
if not fuse is blow or input to this box is bad.
the engine bay fuse box runs the whole cab box.
do the head lights work.
are there other things dead , not stated?

one of these fuses or relay is dead.
or the dash lamp fuse blew, yous said they were dead
you key on, the CEL glows power to the PCM is below right.
if the fuse is dead both sides you blew the eng.bay main fuse.


6f3ec41e-1b16-452c-9537-bf2af068a495.jpg

Aug 17, 2014 | 1997 Isuzu Trooper

1 Answer

Car stereo short circuit. Won't start.


Worse case, fried body ground. Which will feed fuel pump. And surrounding circuits. Check every point for a good ground to body. Then check fuse panel for blown fuses.

Jan 15, 2014 | Cars & Trucks

1 Answer

93 new yorker salon 3.3 was just sitting at idle car stalled so i wnet to start it up and it ran for like 5 seconds and stalled again now it just turns over i was not getting spark injector pulse or power...


You need to check all the fuses in the power distribution box near the battery. Look for a large maxi-fuse that has blown. If your car has fusible links rather than maxi-fuses, they should be checked also. The ecm will also have a fuse for power to it, not a large fuse, but it may be in the box by the battery, or it may also be in the fuse panel under the dash. Something has shut down major portions of your electrical system. It sounds like the ecm is not getting power, or possibly the ground for the ecm is lost. That ground is often located somewhere on top of the engine. Good luck.

Mar 27, 2012 | 1993 Chrysler New Yorker

1 Answer

Engine stalls while driving. Fuel deprivation?


I am having the exact same problem with my VW Touareg @60,000 miles. Two weeks ago and again today it sputters and stalls shortly after starting. I brought it into the shop and they could not reproduce the problem and said it was fine. Also, they had no ideas when I describes the problem. Anyone know what it going on? I am out of warranty.

May 31, 2009 | 2004 Volkswagen Touareg

1 Answer

No fuel getting to engine


Check to make sure you have power going to the fuses (with a test light) for these items, it sounds to me like you may have a blown fusible link or damaged wireing going to the fuse panel.

Feb 02, 2009 | 1996 Oldsmobile 88

Not finding what you are looking for?
2004 BMW 3 Series Logo

Related Topics:

10 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...