Question about 1996 Chevrolet Tahoe

1 Answer

Loss of power and shuttering when accelerating

Hard to start just changed fuel pump and fuel filter fuel pump done 6 months ago and changed fuel filter a month ago now its hard to start and shutters while accelerating and some times losses power under real hard acceleration almost like its going to die lots of power when cold and hesitate,s to accel on highway when going up hills

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Expert
  • 79 Answers

You sure filter is facing flow correctly?:I'd check that first,some cars/trucks have in-line filters.

Posted on Feb 10, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Molson02536
  • 3854 Answers

SOURCE: Starts fine, but then bogs out when accelerating,

Check the fuel pressure regulator and the EGR valve, I would check the fuel pressure regulator first and go from there. Good luck and keep me posted. Not sure what the pressure should be but thinking it's 62 to 65 PSI upon start up and should drop 5 PSI when engine running, check the vacuum line to the regulator.

Posted on Dec 09, 2009

  • 335 Answers

SOURCE: I Have a 2002 blazer that starts but motor dies, surges when accelerating

If this engine is a VORTEC then you may have a problem with the internal fuel system. Under the top plenum there is a fuel reg and poppet valves that inject fuel into the cylinders. Sometimes the tubes that run fuel from the reg to the valves can leak and cause your problem. This cannot be found with pressure check because this occurrs after the reg. PS fuel mileage will go down. Let me know if this helps.Moe

Posted on May 26, 2009

  • 5 Answers

SOURCE: 1992 Camaro Rs 3.1 Hesitates under acceleration.

REPLACE FUEL FILTER THEN FUEL PUMP

Posted on Jun 07, 2009

  • 12 Answers

SOURCE: hesitation off the start but then goes away, also in reverse

sometimes using a fuel additive might help. K44 i think is what it is called helps clean the injectors....hope this helps

Posted on Jul 31, 2009

  • 4 Answers

SOURCE: Loss of power on acceleration. Put new fuel

Check the catalytic converter, I have the same problem, replaced fuel filter, and crank position sensor, didn't help although the fuel filter was dirty. The car has no power, engine knocks horribly when trying to accelerate up a hill/on ramp. Starts, idles good, lousy power off a stop (should sqawk tires before traction control kicks-in)

Posted on Jul 30, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rough idle loss power


I think the hard shifting is due to a faulty transmission control selonoid. As for the code p0102, looks like the mech, only changed what the code refered to , and not your actuall problem. I suspect a loose or broken connector or vacuum hose leak. A simple vacuum leak can throw all sorts of codes. Usually with very troublesome problems that are hard to find, most times a good option is to take it to your gmc/chevy dealer and have their team have a crack at it.

Dec 14, 2013 | Pontiac Cars & Trucks

1 Answer

Power Loss During Acceleration 5.3 Litre


Check your fuel pressure it should be 60-66 psi with the key on and engine off.If its not within these specs then the fuel pump is faulty and needs to be replaced.If the fuel pressure is within the specs then remove the mass air flow sensor and clean the small wires inside of it using a non-chlronated brake cleaner then let it dry for 10 minutes and re-install it.

Feb 12, 2013 | 1999 Chevrolet Silverado 1500

1 Answer

I have a Citroen Diesel ZX19 Turbo. It is Very hard to start when cold and takes a two or three goes to start when hot.I have replaced Glow plugs with Bosch ones from a Citroen dealer only a month ago plus...


Did the poor starting coincide with the cambelt change ,as it sounds like you may have a camshaft/fuel pump timing issue.If the pump/camshaft/crankshaft are not locked in place when you change the belt they can easily move a tooth or two.If the problem didnt coincide with the belt change then it might be a fuel problem.

Jun 02, 2011 | Peugeot 405 Cars & Trucks

2 Answers

Ford F150 engine backfiring, running/idling rough


I Have a 1999 ford f150 4.6 that back fires and is just running really ruff when idling alot of nack fire a sord of like a pulse going on what is my problem?

Apr 16, 2010 | Ford F-150 Cars & Trucks

1 Answer

No fuel getting to engine. Possibe fuel pump. Replace fuel filter with aftermarket brand 6 months ago.


possibility that's it's the pump, the fuel pump relay, check the relay and pump for power/ground etc.
Although you changed the filter 6 months ago i wouldn't X that as a possibilty, i always try to change parts with Ac Delco or another OEM equivalent brand.
Could also be injectors, test the resistance at each one, however if none are giving gas then it's extremely rare that they all died at once.

Feb 07, 2010 | Plymouth Voyager Cars & Trucks

1 Answer

No power, hard starts


Have you replaced the fuel filter, spark plugs and wires? A plugged fuel filter will cause a fuel pump to go bad because it works harder to pump. It also may cause less pressure. Plugs, wires cap and rotor will cause lack of power and fail you on a load if they haven't been replaced for a while.

Jan 11, 2010 | 1996 Chevrolet Tahoe

1 Answer

Loss of power on acceleration. engine bucking.


check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Jun 26, 2009 | 1999 Ford Taurus

1 Answer

Engine starts but low power during acceleration


it look like a mass air flow sensor the sensor that goes in the air filter usual sentra symtom no power stall when realesing the gas pedal pierre p.s go to a wreaker scrap yard bye the piece it will work

Feb 14, 2009 | 1993 Nissan Sentra 4 Door

Not finding what you are looking for?
1996 Chevrolet Tahoe Logo

307 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...