Question about Cars & Trucks

1 Answer

Explorer 2004 Will not start. I replaced the elec throttle body and it ran for a week. It was running when it stoped. I do have fuel pis. And spark. I put ether in and it will not start. I replaced all the fuses and used a obd 2 the only code was the egr valve. I do have cylinder pis in all 6. The engine is a 4.0 sohc with elec t.b.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 16,658 Answers

Check the crank shaft sensor.

Posted on Feb 08, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 321 Answers

SOURCE: buick lesabre nightmare

Need to get a scan tool and look at the data stream while it is running for alot more info.Also any trouble codes.Sounds like initially,the engine isn't getting any fuel.I would have a pressure gauge connected to the fuel rail on the engine,so i could monitor the fuel pressure while all this is going on.Items to look at on the data stream would be timing,what timing is the PCM commanding for the engine.Also,have you checked for continuos power feed to the coils during this no start condition,and fire at the plugs while cranking.You could possibly still have spark,but maybe it is extremely weak?I have seen bad ignition switches cause weird problems before too.Many things power up through the ignition switch,just a thought.Have also seen bad PCM's cause strange problems..38 volts is a little on the low side for GM.Usually see those at,at least .50 and up,and rise steadily while pressing the throttle,up to just under 5.0 volts.Potentiometer with 5 volt supply.Vacuum leak can be checked with engine running at a steady idle speed,spray brake cleaner all around the intake manifold and listen for engine speed change.

Posted on Jul 31, 2008

  • 255 Answers

SOURCE: buick lesabre no start

Hi you have replaced allmost everything ,(try fuel pump relay)

Posted on Aug 18, 2008

tepfy
  • 319 Answers

SOURCE: egr code

REPLACE the EGR valve and gasket, stop being cheap. sometimes there are things that cant be fixed. It could have a micro crack in it or a bad spring. Just brake down and replace it. I have been there so many times. You smack your head into the wall for hours on something that you dance around for months. Let me know once you replace it.

Tepfy

Posted on Nov 07, 2008

motor1258
  • 6674 Answers

SOURCE: OBD code 0401 (1997 Toyota Camry 4 cyl)

There is a VSV (vacuum switching valve) , usually mounted on the back side of engine block, under the intake manifold, as well as the map sensor, that can also cause that code if one or the other is faulty. It takes some pretty detailed troubleshooting to confirm this in some cases, so if that's not in your line of work, you may have to have it properly diagnosed, or take a 50/50 shot at which one first.

Posted on Jan 24, 2009

468 Chevelle
  • 81 Answers

SOURCE: Service engine code indicates EGR valve.

You could have a restriction in the egr ports. remove the valve. Plug the holes, start engine. 1 hole will be blowing out exhaust, the other will have large vacuum.

Posted on Mar 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 1992 gmc Sonoma 4.3 vin z, I ran out of gas put gas it started just fine 3 times stoped filled tank, drive 1.2 miles it died , and won't start, replaced fuel pump , checked all fuses


Test for spark at the plugs and post back. Also, spray a little carb cleaner into throttle body and then try to start it to see if it is a fuel issue.

Apr 15, 2016 | GMC Cars & Trucks

1 Answer

My 2004 ford explorer was running fine it started missing lights went off and now willnot start or turnover


You need to find out what is missing Fuel or ignition. and repair the issue.. you do this by cranking it and seeing if there is any spark going to spark plugs.. if you have spark you will need to see if you have fuel pressure. easy way is to squirt a little fuel into throttle body and see if fires .. if it does then you are missing fuel.. Then you need to find out if it is a fuel pump relay, fuel pump, or possibly something as simple as a clogged fuel filter. When yyou turn the key to on yyou may be able to hear the fuel pump come on for 1-2 seconds to charge the system. The fuel pump is in the gas tank.. so listen and see if tiu can hear it.. some time the pump will run but not pump fuel.

Feb 22, 2015 | 2004 Ford Explorer

1 Answer

Grand am 3 4


Sounds like a faulty fuel pressure regulator, or possibly the MAF sensor.

Mar 28, 2014 | 2004 Pontiac Grand Am

2 Answers

MY 2004 Ford Ranger engine turns over but wont start.


Are you getting fire?have you checked your fuel filter and coil pack

Dec 08, 2012 | 2004 Ford Ranger

1 Answer

2004 trailblazer doesn't start on first try. It cranks and eventually starts but usually 3-6 tries. Once started it runs fine. I have no check engine light. We have replaced the spark plugs, b


For engine to run it has to have:
Fuel, air and spark.
So if it doesn't start, something's missing.
Is your fuel pressure OK? Is your spark present? Is ECM firing injectors?
Check all those basics and I'm sure you'll find what's wrong.

Jan 10, 2018 | 2004 Chevrolet TrailBlazer

1 Answer

Ford 2004 explorer replaced fuel pump and filter will crank but not start


Do you have fuel pressure?
Do you have Spark?
Do you have all the ducting in place,from air filter to throttle body, and no vacuum leaks?

May 03, 2010 | 2004 Ford Explorer

2 Answers

1987 S10 2.5L 4 cyl.


Check the spark either with an inductive timing light, or with an old spark plug in a wire you disconnect and lay on the engine.
It is probably the coil or ignition modules, which most parts places will check for free, if you bring it in.

Jul 25, 2009 | 1987 Chevrolet S-10 Pickup

1 Answer

1997 ford explorer cuts off while driving down road. It will not start. fuel pump is working. checked all fuses, they are good. switch relays. It still will not start. There were spark at the plugs. I...


If you confirmed spark is there, and you hear fuel pump working, I'd still try spraying WD-40 in throttle body intake for a couple of seconds, when it won't start, just to see if it kicks over, just in case pump is running but not up to pressure. If it fires for a second or 2 with WD-40, then you know lack of fuel is the problem.

Jun 11, 2009 | 2004 Ford Explorer

1 Answer

1996 Ford Explorer engine sputters


after you replaced the fuel pump did you replace the fuel filter also check out the EGR valve and all vacuum lines especially the one behind the throttle body

Feb 05, 2009 | 1996 Ford Explorer

3 Answers

Will not start


I change the fuel pressure regulator and fuel pump relay, now runs better.

Jul 20, 2008 | 1996 GMC Jimmy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

77544 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14398 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...