Question about Toyota Cars & Trucks

1 Answer

Cranks won't start

06 Scion XB. New battery, new fuel filter, new plugs, MAF/ATI cleaned. Fuel pump works (I can hear it buzz). All electrical gauges and lights work, so I don't think it's a battery/connectivity issue. Can smell gas when I open the airbox, so the fuel pump and injectors are working. Can someone point me in a helpful direction on this? I've been chasing gremlins for three days now, and I'm getting tired of it! Thanks!

Posted by on

  • 7 more comments 
  • Bob MacDonald
    Bob MacDonald Feb 07, 2014

    A co-worker has an '05 XB (Gen.1) and possesses a Matco OBDII scanner. Gonna try that after work to see if it can pull any codes. If it can't make a connection, would that mean my ECU is fried?

  • Lee Collier
    Lee Collier Feb 08, 2014

    The gasolene will fill cylinders as licqid, if engine does not turn over when cranked injecters should not be open. So no fuel smell ! When I say crank I mean to turn over the engine ( not start ) sorry.

  • Bob MacDonald
    Bob MacDonald Feb 09, 2014

    I've tested all four coil packs with a multimeter, all come back as "OK".

  • Bob MacDonald
    Bob MacDonald Feb 09, 2014

    I've also tried starting fluid spray, no change. Is it possibly the crank position sensor? It looks pretty easy to get to (behding the RF wheel). Ever heard of these things going bad?

  • Bob MacDonald
    Bob MacDonald Feb 09, 2014

    By the way, Lee... thank you! I absolutely appreciate your input!

  • Lee Collier
    Lee Collier Feb 10, 2014

    bOB, HAVE YOU HAD ENGINE CODES REAR ? If not do so, please. That will help with diagnosis. Lee Most auto parts will scan the codes for free

  • Bob MacDonald
    Bob MacDonald Feb 10, 2014

    I used two different OBD scanners, both came back with no codes (I'm assuming that's because I've disconnected the battery a hundred times the last 3-4 days). The dash CEL, VSC and TRAC lights were on about four months ago, but I did an oil change and tune up and they went away and didn't return.

  • Bob MacDonald
    Bob MacDonald Feb 10, 2014

    Crank position sensor and cam position sensor both have god ohms readings; cam position actuator doesn't, but the people I've talked to have told me that part won't prevent the engine from running. Now I have to test the voltage for the crank and cam position sensors tonight after work. God times!

  • Bob MacDonald
    Bob MacDonald Feb 10, 2014

    Good* times... ugh... old keyboard.

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Contributor
  • 52 Answers

Smelling gas like you are is a bad thing, engine must turn over to fire injector. sounds like flooding ( possible ECM/power computer bad ). Before condemning the computer pull all spark plugs, disable ignition coils, then try cranking to see if engine will turn over. Be carful if hydro locked gas will be pushed out the spark plug hole/s

Posted on Feb 07, 2014

Testimonial: "Hydro-locked? I don't think there's any water in the cylinders, unless you're using that term in a more general way and you're referring to the potential flooded gas as the hydro-locking fluid. I'll give that a try. If it does crank without the plugs/coils, what does that tell me? If it doesn't crank without the plugs/coils, what does that tell me? Sorry for the relatively stupid questions - I can change parts (brakes, sensors, fuel pump/filter, etc), but my diagnostic skills start and end with "it makes a bad sound"."

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
chispitas
  • 69 Answers

SOURCE: CAR CRANKS OVER BUT NO START I SMELL GAS UNDER HOOD

your pick up coil or parts inside the distributor have failed you may have to check and replace some parts or maybe your whole distributor. sorry.

Posted on Feb 26, 2009

miket756
  • 2702 Answers

SOURCE: My 2000 Oldsmobile Alero does not start. It cranks

check for a good spark first, if there is none look at ignition circuits its more likley this part,
it could also be the car alarm the immobiliser shutting of the ignition ""stops it getting nicked?"
try resetting the alarm if you take off pipe to carb and there is fule pumping out!!! fule filter is "ok" for starting up on!!! take care working with fule!

Posted on Oct 30, 2009

  • 4793 Answers

SOURCE: cranks but won't start like it has no gas

did you reset the alarm/immobiliser system every time the power was disconnected???

Posted on May 21, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2006 Scion xB won't crank/start...


thinc u gut some kinda internal engine issue--send it to magicmechanic online--hes an 8 time master on any engine--say 'help' on the subject--visit his tech library or listen to his radio show replay too

Feb 11, 2014 | 2006 Scion xB

1 Answer

Won't start


Mostly the only things that will stop an engine sensor-wise is the crank and cam sensors. Failure of other sensors will immediately cause the management computer to switch to the get-you-home programme, record the fault and switch on the engine light but will not prevent the engine starting and running.

Your description doesn't mention that you have physically checked the spark.

Another thing that prevents an engine starting is the anti-theft device. A friend happend to leave his keys on the microwave and couldn't start his car until it had been towed to the dealer.
Might be a good idea to check what the handbook says about that...

Mar 19, 2017 | 2006 Scion xB Wagon

2 Answers

I have a 98 Camaro I put a fuel pump in fuel filter an my car still won't start.Do thank the gas line clog up?


If you know for a fact the pump is getting power and ground, and nothing is coming out of the line before the filter, then yes the line could be clogged up.

Aug 03, 2013 | Cars & Trucks

1 Answer

2007 NISSAN QUEST It starts and then dies within 2-3 seconds.


hello good day, reverse your air filter, make the bottom to top,, if is not work change the high tension wires

Mar 07, 2013 | 2007 Nissan Quest 3.5 Minivan

1 Answer

Egine turns over, battery is good but the is no starting


could be starter possibly or ignition switch or key and tumbler or fuel pump there is so many possiblities, turn the key over and listen for the buzzing from the pump. if it has that then the fuel pump is working. you can hold the key in crank and see if it starts that would suggest key and tumbler or ignition switch.. if it is a standard you can try bomb starting it to see if it starts. if it does that means possibly starter

Jan 28, 2011 | 2005 Scion xB

1 Answer

My scion xb 2004 doesn't start!


it could be a billion things...might have to specify that is it doing...
if it doesn't start but cranks...then check the starter,battery,and the alternator...
it could also be the fuel pump isn't pumping fuel in to the engine...so you need to check that too...
Good Luck!

Oct 12, 2010 | 2004 Scion xB

2 Answers

Engine cranks but will not start scion 2005 xb 4 cylineder


MAKE SURE BATTERY VOLTAGE IS 12.5 VOLTS.IF NOT REPLACE BATTERY. IF YES MAKE SURE BATTERY CABLES TIGHT AND CLEAN.FREE FROM CORROSSION. CHECK TO MAKE SURE ALTERNATOR IS CHARGING BATTERY.WITH ENGINE RUNNING ALTERNATOR OUTPUT 13.5 - 14.5 VOLTS.IF BATTERY ALTERNATOR GOOD.MAKE SURE FUEL PUMP RUNNING.TURN IGNITION SWITCH TO RUN POSITION A FEW SECONDS.YOU SHOULD HEAR FUEL PUMP RUNNING IN TANK.IF NOT CHECK FUSE AND RELAY.BOTH GOOD FUEL PUMP IS BAD.IF PUMP IS GOOD.PROBLEM IS IN IGNITION SYSTEM.CHECK FOR SPARK.NO SPARK.HAVE BAD MODULE.ALSO USE A DIAGNOSTIC SCANNER TO CHECK FOR FAULTY CKP SENSOR AND CMP SENSOR. THEY WILL CAUSE NO START PROBLEMS.

Nov 01, 2009 | 2005 Scion xB

1 Answer

My Scion xB will not start. I think that it could be a fuel filter or pump, but I see that these are located in the fuel tank. Can this be an at home job? Or will it cost me $1000 to fix?


The first thing to do is to shoot a very small amount of starting fluid into the air filter box and crank the engine over if it tries to start then yes you have a fueling problem if it dose not try to start you may have lost the crank position sensor or the coil pack. Also check all the fuses as there are a couple that could also cause this problem.

Mar 17, 2009 | 2004 Scion xB

2 Answers

My 2004 Scion xB will not start.


you may want to check the fuel injector. Check by starting the car then pull out spark plug wires one at a time. if you find that the car does no try and stall after removing any of the wires then its the fuel injector

Mar 17, 2009 | 2004 Scion xB

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

125 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...