Question about 2003 Oldsmobile Alero

2 Answers

03 Oldsmobile alero vibration will running

I have an 03 Oldmobile Alero.I was driving back to work one day last week. And while at the light by my job. My car started to run very strange. It was feeling like it was going to cut off but it never did. So I replaced the coil pack, wires and spark plugs.It stills run like it's missing. And it is still running funny. If in drive, reverse and park it runs with a hard vibration. But when it neutral it runs fine. Can you please help I am getting very frustrated. Service engine soon light comes on.

Posted by on

  • Regina25 Aug 03, 2009

    I have found out the problem it's my rockerarm, The rockerarm had come a loose and that's why the code was giving me a misfire on cylinder 5. I would not have thought of that. But, know by me having it back the rockerarm jumped out again and know I got to have my head reworked. But at least I know what it is.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I just had my fuel pump replaced on my 2003 Oldsmobile Alero 2.2 4 door sedan and I've been having problems with my car starting. When it finally turns over and starts it drives fine. Now it's been shutting off in the middle of driving. When it does this it starts right back up. Diagnostics reported: Bank 1 Sensor 1 02 Sensor Fault and Air valve high idle fault. Any suggestions?

Posted on Jul 31, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 334 Answers

It would be a good i dear to have it scand.that would help you pin point the prolbem. look at your cv joint you may have one going bad. good luck

Posted on Jun 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car was running fine and out of nowhere it just shut off and it wont start back


The same thing happened to my 03 olds Alero, i pluged my scan tool in and found out that my fuel pump was bad, I changed the fuel pump, fuel filter, and also checked the fuel injectors and blew out the fuel lines, now it's running great.

Feb 27, 2015 | 2003 Oldsmobile Alero

1 Answer

Good day, fuel gauge from chevrolet alero 1999(oldmobile) is not working,pointer is standing in the right on 1200 hours


Please check if the rheostat within the fuel tank is working. You will have to disconect and shor the line to see if the guage is working. If so the rheosat must be faulty.
Check to see if anyline are opened in the dash board cluster

Jun 25, 2010 | 1999 Oldsmobile Alero

1 Answer

Were is the idole in 2004 oldmobile alero


could be a lot of things fuel pump or maf or map sensor chech the device that hesures the air folw if it is unhooded rehook it and see what happens. If you need more help post here for more informtion.

Oct 17, 2009 | 2004 Oldsmobile Alero

1 Answer

2003 olds alero igntion/starting problem


i own a 03 alero ... aleros have history of igniton switches going bad... replace it or take it to dealer then ull be charged arm and leg...

Jun 01, 2009 | 2003 Oldsmobile Alero

3 Answers

'03 Alero engine ust died while driving down the road. Help?


  • see if you can hear the fuel pump click over when you turn it to start position! this may be a fuel pump?

Mar 27, 2009 | 2003 Oldsmobile Alero

1 Answer

On my Oldsmobile Alero 2002, all the warning lights are on


You have probably clipped the data line for the computer. This is not a fix!! Just putting bandages where stitches belong!! Any questions just shoot back

Mar 24, 2009 | 2004 Oldsmobile Alero

1 Answer

2002 Alero shifting hard


I have a 1999 Oldsmobile Alero and my car was running rough and stalling. Also when the car was shifting, it was making a "thud" sound. My service engine light was on, so I took it to Autozone to run their diagnostic tool. It came back with code P0108 and they advised me to check my vacuum hoses as a possible solution. I looked and found that my air hose running from my throttle body to my map sensor was disconnected. I reconnected the hose and the engine ran normally and didn't make any "thud" sound when shifting. My car is back to normal. So check your hoses. If its still running rough, you may need to replace your map sensor.

Mar 13, 2009 | 2002 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

812 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...