Question about 1994 Ford Thunderbird

1 Answer

Sounds like my car has a miss

My car started rinning rough and sounded like it had a miss and check engine light came on so i changed spark plugs and reset light by removing battery cable but it still runs like it has a miss and check engine light came back on now what should i do any suggestions?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 161 Answers

If i remember right you have a coil pack? or distibutor? if coil pack it sounds like you have a bad coil pack. if you have a pair of insulated pliers pull each plug wire to where they are just sitting in coil start car and lift each wire one at a time see if one has no spark. change coil pack

Posted on Jun 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Spark 1.2. Why is the engine light on?


Sounds like you have a cylinder(s) that is not firing. Newer cars have a separate igniter (high voltage ignition coil) for each plug - check them all and I am sure you will find a culprit to replace.

Aug 10, 2015 | Chevrolet Chevy Cars & Trucks

2 Answers

Check engine light on engine acts as if missing new plugs wires and #5 spark pack missing again 6cyl 4x4 3.4 185000 miles


was it running this way before you changed the plugs? just a shot in the dark here possibly a defective spark plug, rare but not impossible. if it was running fine before changing them. Other wise I would take it to autozone and pull codes if it is P0350 #5 misfire we would use the process fuel, fire and compression. is there any engine coolant around any cylinders? Have you checked the coil packs? could be a bad coil pack. if no evidence of fluid around them proceeded to check for spark, fuel then compression. post back results or new post with more deductions. iis it no spark no fuel or bad compression.

Dec 25, 2014 | 1996 Toyota T100

1 Answer

I have a 2007 1500 suburban - check engine light came on and started missing - code showed cylinder 1 missing - i changed spark plugs and noticed that the #1 spark plug had a piece of the ceramic broken...


cylinder 1 getting too hot causing ceremic crack could have wrong heat range plug in which spark plug too hot.or need replace spark plug wires.one plug wire could be bad best replace all spark plug wires.

Sep 08, 2013 | Chevrolet C1500 Cars & Trucks

1 Answer

Car is missing check engine light is on


check your spark plug wires. it sounds like cracked spark plug wire that is arcing. the best way to check this is at night , start engine and look for sparks around the plug wires.

Aug 26, 2012 | 1999 Mercury Sable

1 Answer

I have a 1996 Oldsmobile cutlass supreme and it was running alittle rough but was running. It sounded like it was missing alittle bit. It stalled on me at a red light but started back up and ran good. The...


The first thing to check is the ignition timing then the spark plug gaps. There are specific settings/size for the above and must be correct for the car to run smoothly.

May 08, 2017 | 1996 Oldsmobile Cutlass Supreme Coupe

4 Answers

Check engine light came on...


sounds like you have a dead misfire on one of your cly.check plugs, plug wires/coils, and injectors.

Jun 11, 2009 | 2001 Acura 3.2CL

2 Answers

2000 ford expedition, misses during acceleration, rough acceleration, service engine light on


check pass side rear plug the coolant hose the runs to the heater core can leak coolant into the rear spark plug boot and cause a miss

Mar 10, 2009 | 2000 Ford Expedition

2 Answers

Very Rough running engine


I think the auto-lite plugs are probably your problem. yes it sounds like mis-firing. That's one of the few times the check engine light flashes. I'd suggest changing the plugs to a NGK plug, that's the ONLY plug we use in our Audi's and VW's (work at a VW/Audi shop). Try that, and it should take care of the rough running, if not, it will probably need coils too.

Jan 13, 2009 | 2004 Audi TT

Not finding what you are looking for?
1994 Ford Thunderbird Logo

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...