Question about 1997 Ford Expedition

4 Answers

I have a 97 ford expedition 5.4 liter 4x4 that will start but won't continue to run. i have changed out the pump and it still acts as though it is fuel starved. I had just changed the oil and ran it for 2 or 3 minutes to check for leaks. I came back 15 minutes later and now won't stay running. Suggestions?

Posted by on

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

Have you checked for vacuum leaks? thought mine was spark plugs and found broken vacuum hose attatchment behind throttle body to manifold was broken... that was my problem, maybe yours too? It's the hose just behind throttle body on passenger side- mine was a broken rubber elbow right at top of manifold- it's reachable without taking throttle body off...

Posted on Jul 13, 2009

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

I just replaced the engine in my 97 expedition. There is one vacuum hose that goes to the right valve cover. It is dead center in the back of the throttle body. If you don't know where it is you probably won't find it. I can send you some photos of the intake and throttle body removed that may help. There are also four more vacuum lines on the right side toward the rear. Two come forward to the air filter assembly. One goes to the right valve cover and I believe the last one goes to the master cylinder. I could be wrong, but I can check tonight. Contact me at Rwilliams@dewcorporation.com if you need any photos of the parts as they are removed.

Posted on Jun 16, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 78 Answers

I have fixed about ten of these fords 5.4 litters with the same problem.The common thing is that the vacum lines start falling apart mainly they are all 90 degree hose connections the main one is located behind the intake manifold way in the back in the middle.The rest are running along that same hose.You can go to the auto parts store and get these rubber fittings from the pvc section cause the dealer sells the whole thing in one piece over 160.00dllrs verses the 10 dllrs at the store good luck and let me know how it goes.

Posted on Jun 03, 2009

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Have someone hold their hand over the mass airflow senosor , if it stays running, clean sensor or buy new one.

Posted on Aug 18, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My ford expedition won't start i change the fuel


If it a diesel then you must be aware that when changing a filter and pump they must be full of fuel, otherwise it won't **** the fuel into the engine.

Jul 11, 2011 | 1997 Ford Expedition

1 Answer

1998 expedition, won"t start, cranks,


Fuel pressure test , is there spark ? Videos on youtube showing how to check .

Jul 20, 2017 | 1998 Ford Expedition

3 Answers

My 1998 ford expedition acts like it is not getting enough fuel. replaced the fuel filter and it solved the problem for a little while. Now its doing the same thing again.


You most likely have a fuel pump going out,the fuel filter replacement was a little late,it put strain on the fuel pump,and it has took it`s toll on the fuel pump,,I have seen it a lot,if this was helpful,at all,please rate,thank you,and have the fuel pump pressure checked.

Jul 18, 2010 | 1998 Ford Expedition

3 Answers

97 expedition - 4x4 does not engage


i have the same problem can't figured it out although when i turn the knob to AWD the light on dash just flashes. the 4x4 H and 4x4 L light on dash stays on.if u have found out anything please let me know or e mail me at bigd6923@yahoo.com Thanks Don

Jan 28, 2010 | 1997 Ford Expedition

1 Answer

I need to know how to rest the fuel pump on my 97 ford expedition xltit acts as if it wants to start but doesnt turn over


look down at the kick panel next to your left foot as u set in the drivers seat should be able to see it if not it might be behind it just push the red button well most are red

Oct 02, 2009 | 1997 Ford Expedition

1 Answer

1999 hard starting expedition, with 5.4 engine


fuel pump may be going. try this. turn key on, listen for fuel pump to run for 5 seconds. Turn key off, wait 15 seconds or until you hear relay click inside car. Turn key on again for 5 seconds and ff for 15 seconds. repeat once more. This will pressurize fuel system to 40 psi so injectors have full pressure. If it starts quickly now, you are getting bleed down through the check valve in the fuel pump or the fuel pressure regulator on the fuel rail.

Jun 30, 2009 | 1999 Ford Expedition

1 Answer

97 ford expedition 4x4


does the whinning noise decrease or go away when u decelarate? this is the key to a proper diagnosis. if it does, then your problem eather ring & pinion gears or related bearings (these are all in the center part of the diff.) if it does not change,the problem is in the wheel bearings, or rough tread on the tires. the former is expensive(4 or 5 hundred), the latter is not so bad(a hundred or so). u could try raising it up & supporting it under axel housing, have a friend run it up to about 40mph as u listen with a hose or stethescope to pinpoint the noise

Feb 15, 2009 | 1997 Ford Expedition

1 Answer

Car do not start fuel pump inop.2000 ford expedition 4.6 liter


fuel pump went out; my suggestion is to support vehicle and lower gas tank and change the fuel pump

Dec 27, 2008 | 2000 Ford Expedition

2 Answers

2000 ford expedition dash board guage


it could be that all you can do is just ask a dealer

Oct 29, 2008 | 2000 Ford Expedition

Not finding what you are looking for?
1997 Ford Expedition Logo

1,829 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5467 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...