Question about 1990 Nissan 300ZX

1 Answer

Front 2 cylinders missing. leak not sure if it block or waterpump

I have a 300zx N/A and my front 2 cylinders dont run . i changed one of the coil packs because it was fried but i dont think it made a diffrence. also i go the other cylinder to run before by pushing on the wires on the ignition connector but i havent been able to get that cylinder running. and i have a water leak but i dont know if its the block or the water pump. help please

Posted by on

  • 2 more comments 
  • ruben Jun 01, 2009

    Okay its not low on oil there is no leak with oil. im not sure if it ran hot because i just bought the car about a month ago although there are sighs of rust outside on top of the radiator by the cap. i did a radiator flush and then a radiator cleaner , after the cleaner i saw the leak it seems to be coming from one of the pulleys in the front of the engine.which believe it might be the water pump but im not sure.

    now the front 2 cylinders don't run i changed the coil pack that was ruined. when i turned the car on and allowed it to idle for awhile it was at 1100 RPM before i changed the coil it was at 700 or 500 rpms yet even when i remove the coilpack connector there is no change in the engine sound. the connectors are kind of old looking some are kind of broken and slip off easy. i recently ordered new connecters when they arrive i shall buy new spark plugs aswell.


  • Chuck McFadden May 11, 2010

    Did you check the spark plugs? These cars only like NGK plugs. Also have you done a copression check? It may have a blown head gasket which might explain the the water leak. Otherwise the water leak is most likly the water pump.

  • maz1965 May 11, 2010

    do you have a series 1 or series 2 PTU ?

  • Shane Crosby
    Shane Crosby May 11, 2010

    Ok, you have multiple problems... I need to ask you a couple of questions because I could write a book on what could be wrong.. Here goes, did your car run hot or did it run really low on oil? Or both? This can help me better diagnose your problem. Please respond. Thanks.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 291 Answers

THE TWO CYLINDERS THAT ARE DEAD..IF YOU PROBLEM WAS THE COIL THEN YOU WOULD HAVE A BUILD UP OF UNBURNT GAS IN THOSE CYLINDERS.. REMOVE BOTH PLUGS.. PLUG THE COIL WIRES TO THE PLUGS AND LAY ACROSS BLOCK ON GROUND HAVE SOME ONE ELSE START CAR LOOK FOR A STRONG SPARK... FIRST THOUGH WHEN YOU REMOVE PLUGS SEE IF THEY WET AND / OR DOES IT HAVE STRONG GAS ODOR...SUGGEST REPLACEING THOSE PLUGS.. IF STILL HAVE PROBLEMS THEN IT IS TIME FOR A COMPRESSION CHECK.. YOU CAN BORROW COMPRESION GUAGE FROM AUTO ZONE...AS FAR AS THE LEAK YOU ARE REALLY GOING TO HAVE TO GET DOWN ON ENGINE TO LOCATE THE EXACT AREA COMMING FROM... BUT WOULD NOT SURPRISE ME AT ALL FOR THE WATER PUMP TO BE CULPRIT

Posted on Sep 13, 2009

Testimonial: "thanks it turned out that the front 2 fuel injectors were not working swithiched them out runs good. it was the water pump. an it aint burnin the gas "

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Bought the vw and doeve it a couple days then 1st got p0302 p0301 then couple days later got p0302 and p0420???


Ok your 301,302 thats a misfire cylinder 1and cylinder 2 spark plug coil pack you should get away with that but the 420 that a cathalytic code me i would change the spark plug first try it after if its not missing that problem is good me i would clear the code and try it like that if it doesnt come back good for if not the convertor is a problem im gonna add a video on how to clean that cathalytic try it before changing it p.s if you got a 301 302 your car engine most shake 2 cylinder missing if it doesnt shake or miss try clearing the code first you dont no maybe work was done on it and the code werth clear the video is exactly the same code as your but its a bit extreme you could by seafoam and run it in the trottle body directly its gonna smoke but its gonna clean it

Apr 09, 2015 | Volkswagen Cars & Trucks

1 Answer

Why are cylinders 1 3 and 5 are miss firing 1997 toyota camry


you cannot change oxygen sensors from front to back as they are 2 completely different units doing completely different jobs
the problem is water in the electronics and you use a dewatering fluid ( wd-40 or like ) to disperse the water not starter fluid

Apr 02, 2017 | 1997 Toyota Camry

1 Answer

Missing intermittenly, shows problem with #2 cylinder. Could it be the coil and can you purchase separate coils.


Theses coils are separate, but handle 2 cylinders at a time. So in your vehicle you should have 3 coils.Random misfire may be caused by the following: due 4 tune-up, faulty coil, faulty spark plug, faulty plug wire, faulty cam or crank sensor, poor cylinder compression, intake/head gasket leaks. Before replacing parts, make sure that #2 cylinder is diagnosed for the misfire. Otherwise you'll be changing out good parts, and spending more $$$!!

Oct 05, 2010 | 2002 Buick Century

2 Answers

I have a 1997 jeep grand cherkee 4.0 with miss fire after water p


you will need to check the codes and see exactly what cylinder is misfiring, this maybe caused due to a vacuum leak or bad wires or if it has a coil then a bad coil boot,this may not have anything to do with the waterpump job, or might,if you could pinpoint which cylinder it was, then this would help pin point the problem,check around for vacuum leaks, or any connections left loose ,start with that,

May 10, 2010 | 1997 Jeep Grand Cherokee

1 Answer

Nissan 300zx 5th cylinder died


do you have coil over plug or one coil? if you have spark plug wires, swap one with the cylinder in question. swap an injector.

Mar 01, 2010 | 1990 Nissan 300ZX

1 Answer

HI I JUST BOUGHT A 1990 300ZX2X2 AND TODAY IT STARTED RUNING ROUG


try to start the car and unplug the coil packs one at a time. listen for changes in the way the car runs. it sounds like you have a dead cylinder or two. be aware of VERY small changes in the sound as i had mine running on 2 of six cylinders and it still ran. if you notice that you have a dead cylinder check the coil packs for corrosion on the connectors if they are fine. investigate the ptu (on the passenger side timing belt cover there are 2 versions the old version is known for failing and knocking out a few cylinders http://www.mdsmarthome.com/z/Z%20Tech/Z%20Tech%20PDF's/PTU%20Repair.pdf

rough idle could be caused by vacuum leaks and or incorrect timing should be 15 degrees before tdc

Dec 13, 2009 | 1990 Nissan 300ZX

2 Answers

I have a miss fire


Recheck the firing order; 1-6-5-4-3-2

On the distributor passenger side radiator to fire wall. 2-4-6-coil
On the distributor drivers side radiator to fire wall. 3-1-5

Cylinder passenger side radiator to fire wall. 2-4-6
Cylinder drivers side radiator to fire wall. 1-3-5

Good luck and also check the distributor cap again for proper seating.

Nov 13, 2009 | 1998 Chevrolet Blazer

3 Answers

Missing front 2 cylinders,and a water leak not sure if its block or water pump. 300zx n/a


change the distributor cap,rotar arm also, and ht leads and spark plugs also, the tick could be because it basically is empty on oil...

Jun 01, 2009 | 1990 Nissan 300ZX

1 Answer

Missing 2 cylinders, no heat, oil leak. 300zx HELP ME PLEASE


If you have no heat at all and its smoking white out the tail pipes then you have a blown headgasket. That is why you aren't running on 2 cylinders.

Check you coolant level to see if you have a blown head gasket. The tick is from not having enough oil in the engine. Oil always leaks from these but not too often its the rear main, just depends.

Does it smoke white out the tail pipes?

Apr 21, 2009 | 1994 Nissan 300ZX

1 Answer

1996 Jeep cherokee, leaking coolant when cold/ hot ok.


waterpump houseing/shaft seal is on the way out hence the water/coolant, running along the block. when hot the seal does so, when cold and depressurising seal doesnt.

Jan 25, 2009 | 1999 Jeep Cherokee 4WD

Not finding what you are looking for?
1990 Nissan 300ZX Logo

219 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...