Question about 1998 Lincoln Town Car

1 Answer

Intermittent batt. light

1998 licoln town car battery light comes on in morning.car starts fine, light goes off in few nminutes then comes on again after driving alittle.light goes off at stop lights and after car warms up light stays off all day untill restart next day.problem started out once a week for a couple weeks then went to once a day for a week then skipped a couple days with no light comming on.Battery good.Alternator charging at 13.5voltsáll wires good.Could problem be with the voltage regulator located on the back of alternator? went to junk yards and could not find alterator with this grey plastic volt.reg.not missing.figure this might be cause since all are removed at junkyards?

Posted by on

  • Dan Mertz
    Dan Mertz May 31, 2009

    my bad....voltage was 14.5-14.45 @ STARTUP.I also noticed before starting the batt. voltage was 11.89??? when light comes on the output from alternator is still 14.5 but the battery also reads 14.35...isnt that too high at batt?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,596 Answers

Optomum Alt Charge is 14.5 so yours is Low And Junkyard Electrical Parts I NEVER Recomend I Would Replace Alt w/ Reg. NEW

Posted on May 31, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I just replaced battery and alternater but the battery died hile driving and once i jump the car it ill run for thirty seconds then die.


you've had the misfortune of getting a bad rebuilt alternator-sorry-they should give you another one -I hope its not hard to replace-Denny

Nov 05, 2013 | 2004 Chevrolet Impala

1 Answer

Driving and electric equipment starting dropping out(windows etc.) then vehicle dies going down the street. Lights start flashing inside and something clicking under dash. 10 minutes later dead. Jumped...


new batt if it is over 3 yrs old-needs to always be at 12.6 v--its not holding charge well--have it load tested--probly only gettn a surface charge onit-it will fool u

Sep 22, 2013 | 1999 Ford Expedition

1 Answer

Intermittent battery light/airbag light/car died but now starts fine


diodes in alternator are leaking (back feed), more when hot. needs alternator or fan belt loose..

Dec 15, 2012 | 2004 Pontiac Sunfire

1 Answer

Wife went to store and she calls me telling me truck wont start its just clicking so i go over and it or i thought it was a bad connection negative was loose i tightened it up and after a jump it started...


probably the starter is going bad. it hits a worn spot on the inside so it can't engage to turn over but most of the time it is not at the warn spot so it engages fine. make sure the ground is tight and not corroded and the battery post and clamps are not dirty, sometimes a bad ground connection or corroded batt. posts can cause intermittent failure. if it fails again, try the old fashion test by crawling under and tapping the starter itself with a hammer or similarobject. it usually will start and if it does, the starter is going bad.

Feb 13, 2010 | 1998 Dodge Dakota

2 Answers

Why is my battery light is coming on.


Loose or intermittent connection at the battery, alternator, or other wire associated with the starting/charging system.

Dec 27, 2009 | 2006 Ford Focus

2 Answers

Battery light comes on but alternator and battery work fine after


THE RED LIGHT SHOWS WHEN ITS NOT CHARGING I WOULD GET THE VOLTAGE CHECKED SHOULD BE PUSHING 13 TO 13.5 VOLTS WHEN CAHRGING

Apr 08, 2009 | 1998 Lincoln Town Car

1 Answer

Batt or alt?


The battery won't just quit so suddenly, you'll know when it's almost dead, so it could be the alternator. If you can get the car started, check the voltage on the battery while the car is running, if it's below 12.8 - 13 volts, then the alternator isn't charging and it may need replacement, or repair. Good luck!

Mar 12, 2009 | 2003 Volkswagen Golf

1 Answer

CHECK ENGINE LIGHT ON BUT RUNNING FINE


f the light is on steady it is prob one of the emission sysytem's like 02 sensor.. as long as light is not blinking ok to drive till fixed..

Clear light by: taking batt cable off for about 3 min and prees your foot on break while cable is off.. then put cable back on.. light will go off for a while but as soon as it sees the problem again it will come on

Jan 19, 2009 | 1996 Ford F150 Regular Cab

1 Answer

Brake lights


Check the wires and connector at the brake pedal switch. These wies have a tendency to break, This will cause no brake lights amd not allow the shift interlock to function

Dec 28, 2008 | 1998 Lincoln Town Car

1 Answer

Car starts then stalls immediately


take the alternator off and have it tested at the auto parts store, this is more than likely your problem....

if it is good, then you need ot check your fuel injectors....

Nov 26, 2008 | 2008 Lincoln Town Car

Not finding what you are looking for?

Open Questions:

0 Answers

98 Lincoln TC,Cold starts fine ,runs good until warm, then shuts off. No codes,Cranks ok, have spark, PATS ok. No fuel pressure, cant hear fuel pump prime,New Fuel relay. jumped fuel pump - works. I do not hear fuel pump prime up, do not have fuel gauge, but pressing on valve in fuel rail- no pressurized fuel. Fuel regulator seems ok, not leaking / vacuum line dry as a bone. If I let it set for 15 min , it will start up again, but for a few minutes then dies out. If I let it set overnight it starts up perfectly and runs until operating temp is reached then stalls/stumbles, and shuts down. Vacuum is good while cranking, even with no start, Checked Inertia switch in trunk, it is not tripped. I have seen Ford TSB summaries' that mention issues like this , but I am not able to see to description. A point to add, the MAF sensor was cleaned, then I decided to replace it and did not make a difference. I do not have any stored codes, and the PATS is working fine, typical 2 second flash from and once key is inserted a 3 second steady light, then disappears. I have seen the TSB mentioning C103 Connector, it looks fine, I swapped out fuel pump relay with ac relay, still no difference.mention of wires around battery, do not know where to start. in dash service engine light and odometer is normal, seen other posts the say they only have lines, but mine is ok. the start of all of this , I washed engine with regular garden hose, ( not using pressure washer).also in the mean time, rear window defroster stopped working as well, can not say for same reason, but a mention.My problem started after washing engine. this is one of four Panther platform vehicles I owned with exact 4.6l w code engine, which I rinced down before. The only sensor I can think of is Oil pressure , or a corroded wire

Feb 27, 2017 | 1998 Lincoln Town Car

See all 1998 Lincoln Town Car Questions

1998 Lincoln Town Car Logo

428 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...