Question about 1996 Mazda 626

1 Answer

Tempature gauge still goes to h

I changed water pump,ect sensor, and thermostat on my 1996 mazda 626 lx but still my temp gauge still goes to h any helpful tips thanks in advadvance

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

, ckeck the upper hose to see if it is hot , than ckeck the bottom hose , is it cool , the temp sould be about the same .if it is super hot on top and cold at the bottom hose , the raditor may be blocked, and the coolant is not flowing. you can try to flush the radiator . look to see if there metal shaving in the coolant . if there is the radiator is breaking down. this happen to me , my car would over heat change radiator car is a,ok easy fix . radiator barn .com

Posted on Aug 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where can i find the fuse for the cooling fan for a 2000 mazda 626


There should be two fuses for the cooling fan relay in the main box near the battery.
You could have air pockets in the cooling system which would affect the temp sensor.

Mar 02, 2013 | 2000 Mazda 626

1 Answer

Water tempature gauge shows hot when car is cool ;and hasn't been driven


It sounds like the temp sender may be bad. This is the sensor that sends a signal to the gauge on the dash (as opposed to the engine coolant temperature (ECT) sensor that goes to the ECU instead.) It is located on the bottom front of the thermostat housing (which you will find if you follow the large hose from the top right of the radiator.)

Before replacing, make sure the connection is clean and secure, then check the wiring for any obvious failures.

Jan 13, 2013 | 2002 Ford ZX2

1 Answer

My mazda 626 is pouring coolant out of the overflow hose. Not overheating. Not sure if temp gauge is working.


Ask a local mechanic to diagnose for you as this could be a thermostat problem but it could also be a head gasket but another problem could be the water pump impeller the plastic impeller comes adrift from the metal drive shaft

Feb 27, 2012 | 2002 Mazda 626

1 Answer

Put in a new water pump and thermas stat and the gage still goes to hot


Do you have access to a non contact laser temp gauge?
If so shoot the thermostat housing and see if the gauge is correct.

If the gauge is off from the laser then replace the engine coolant temp sensor,
If the gauge is correct then double check the thermostat installation,is it in backwards? or maybe you got a bad thermostat.

did you flush the entire system when you replaced water pump?

Jun 02, 2010 | 1996 Dodge Ram

1 Answer

I have a 1996 Mazda 626 2.0 Automatic. It runs


of course the top is hot water goes into the rad from the top and out of the bottom into the engine, the fact that the belt broke makes me wonder about the integrity of the water pump, the impeller might be slipping, could still be the rad , does the heat go from the top to the bottom???

May 11, 2010 | 1998 Mazda 626

2 Answers

Tempature gauge goes to high with full coolant.


if no codes a few choices to problem could be fan not working properly/thermostat stuck closed or broke/water pump failure/radiator clogged-outside blocked/bad sensor(usually pops a code)these are the most common good luck

Oct 23, 2009 | 1999 Dodge Caravan

1 Answer

2001 Mazda 626 ran hot this morn in 10 degree weather


Have the water pump checked it might be going out or not working,also change the thermostat while having this done.

Feb 04, 2009 | 2001 Mazda 626

Not finding what you are looking for?
1996 Mazda 626 Logo

Related Topics:

371 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8560 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...