Question about 2003 Pontiac Grand Prix

2 Answers

POWER LOSS, FEELS LIKE IT BOGS DOWN, SHIFTS HARD

WHEN I FIRST START TO GO ON OVERNIGHT COLD START IT RUNS DECENT. BUT WHEN I DRIVE FOR ABOUT 5 MINUTES AND TRY TO ACCELERATE OFF STOP SIGN ALMOST HAVE TO PUT FOOT TO FLOOR TO GET UP TO 35 MPH. FEELS LIKE IT BOGS DOWN AND SHIFTS ERRATICALLY. ALSO HAS HARD TIME GOING UP HILLS AND STRUGGLES TO GET TO 55 MPH. AFTER I FINALLY GET TO 55 MPH ITS SMOOTH.

Posted by on

  • frnkz26 Jun 01, 2009

    WOULD THE MASS AIR FLOW OR FILTER CAUSE TO FEEL LIKE A TRANNY PROBLEM

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 187 Answers

Well start with the basics here is the battery fully charged? how are the cattery cable connections clean and tight? do any of the electrical accessories work like the head lamps brake lights etc.. do the accessories that are ig nition switch related work when the key is on like the radio and blower motor? you may have more the n one issue here one that was making it run poorly and one that is preventing it from starting. is there a security lamp on the dash flashing? it may have a theft system issue.

you can take it to one of the auto parts stores like auto zone they will at least scan the car to tell you what the code is for free. At least you will have an I dea what your looking for. Good luck :)

Posted on Jun 02, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Pontiac Master
  • 75,822 Answers

This sounds like you either have a clogged fuel filter or a defective Mass Airflow sensor, the fuel filter is located in the fuel line under the car, here is a discription of location, While looking at your Driver Side the Fuel Filter is located just to the left of the rear tire and just under the driver side back seat. The MAF sensor is located in the air intake hose of the engine. Replace the fuel filter 1st

Posted on Jun 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What could cause intermittent engine stalling?


A bad MAP or MAF sensor could cause this type problem .

Mar 16, 2017 | 2007 Volkswagen Transporter 1.9

1 Answer

Chevy 1500 shifts


Sounds like contaminatioin in the transmission fluid causing problems in nthe valve body of the transmission.Do a transmission fluid and filter change and have the transmission flushed.If that doesn`t work you will have to drop the pan and remove the valve body and inspect it for scoring and inspect the valve body seal.

Jan 23, 2014 | Cars & Trucks

1 Answer

97 grand cherokee tsi shifting problem


Sound lik e aaproblem with Torque Converter, check engine light come on there? I suggest scanned the PCM in order to know fault codes stored there. We have the repair manual, send us details for additional questions.

Jul 02, 2012 | Jeep Grand Cherokee Cars & Trucks

1 Answer

Runs well in winter, but not summer


I would like to know the fuel pressure reading, is this truck 6 or 8 cylinders?

Jun 20, 2012 | 1988 Ford F 150

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

The diagnostic connector on my 1990 Geo Prizm is dirty. Does this effect anything. It is hard to start when cold or has been sitting for a few hours. When it does start it runs rough for a few minutes...


if it contines to run fine dont mess with however if it starts acting out again sound like possibly loss of fuel pressure have it check next with gauge on fuel system allow it to sit overnight and see what gauge reads in am BEFORE trying to start engine let me know if you need help

Mar 07, 2011 | Geo Prizm Cars & Trucks

1 Answer

Loss of power


You should have your cat. checked make sure there is no restrictions in your exhaust system.

Apr 11, 2009 | 1999 Chevrolet Tahoe

1 Answer

Accelaration loss of power


I'd have a fuel pressure test done to be sure, it isn't fuel related again. Takes 5 or 10 minutes so cost should be minimal. The other thing that comes to mind is a plugged exhaust. (catalytic converter) Quite possible on a 10yr.old vehicle.

Apr 11, 2009 | 2004 Chevrolet Tahoe

2 Answers

Hard up and down-shifting into 2nd gear - manual transmission


I have seen this happen in numerous cars, I have a mazda that does that, my buddy has an 04 suzuki aerio that does that etc etc etc.... There really ins't a "fix" for that as it really is just what late model manual trannys do, all you can do is just let your car warm up. If you are really concerned you can throw a new tranny on there but once it gets broken in it will start doing that too. Sorry! 

Feb 25, 2009 | 1999 Suzuki Vitara

1 Answer

'99 chevy Silverado Z71,5.3 engine.....will not rev when hot.....


try replacing your EGR Valve, or your Oxygen Sensor

Feb 10, 2009 | 2001 Chevrolet S-10

Not finding what you are looking for?
2003 Pontiac Grand Prix Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8195 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...