Question about 2004 Oldsmobile Alero

1 Answer

The Air flows through only the defrost and feet vents

I own a 2004 Oldsmobile Alero and the air will only flow through the feet vents and the air vents. Even when i turn the knob to a different location. When the knob is on the defrost picture it dash shows the air as circulating from outside, but when changed to face vents it changes to circulating from inside but does not come through the face vents still only comes throught the feet and defrost.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 129 Answers

Inside the ventilation system there is gates that open and close to direct the air flow. These are operated on vacuum on most vehicles. The hose for that perticular gate may have disconnected somehow or has a hole in it. I suggest you take the heater controls out and see if there is a plug with a series of colored hoses on it. it so you'll have to trace each of them to see which one is the problem. Now you may be able to get some help from you local dealers mechanic who just may know the color code for that gate. (which would be a bonus) Good Luck

Posted on May 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Vents won't blow hot or cold air. Comes from defrost and feet when you put fan on.


It's the vent actuator, it moves the baffle that changes the direction of the air flow.
Here is a video of a broken vacuum hose that creates the same problem.

It could also be a failed actuator.

Sep 19, 2016 | 1997 GMC Safari

1 Answer

Low air flow to feet when heat is on ?


Sounds to me that you might have a leak in the line. Those heaters are all Vacume actuated.

Feb 18, 2014 | 2000 Oldsmobile Intrigue

1 Answer

2004 alero. can't get vent control knob to change


most likely the blend door actuator if u dont have a vacuum leak at the climate control

Jul 07, 2011 | 2004 Oldsmobile Alero

1 Answer

Air blows only on windshield even when placed on vents or feet


you may have abad slector door acuator.which is alittle motor bolted on the heater box.It move a door in box to direct air flow to right location.hope this helps.

Sep 27, 2009 | 2000 Dodge Durango

1 Answer

Replaced battery in 2004 chevy trailblazer 4x4 8cl., then air conditioner doesnt blow out the face vents only the defrost and feet. any ideas?


Typically, you have a vacuum issue, air flow system is designed to FAIL in the defrost mode, so no vacuum, doors are spring loaded to blow out defrost ports.

Sep 25, 2009 | 2004 Chevrolet TrailBlazer

1 Answer

No air flow from middle level vents


no actuator is electric motor maybe bad or switch control or jammed door!!! :)

Jul 02, 2009 | 2004 Chevrolet TrailBlazer

1 Answer

Air condition vents do not open in the middle.


sounds like a blend door problem need to see if all vac. line are hooked up under dash

Jun 25, 2009 | 2004 Infiniti QX56

1 Answer

No air flow from defrost vent on my van.


Could be a vaccum line leaking not changing the vent flap to defrost

Jan 10, 2009 | 2001 Oldsmobile Silhouette

1 Answer

2004 Ford Crown Victoria no air flow through main air vents


Chances are the electronic/digital HVAC control unit is bad. This same problem happened to me and I had to replace the entire unit. The dealer wanted to charge $800 for just the part! After I freaked out on them, they found a used one for less than half. Sorry, but there's no easy fix here.

Jun 26, 2008 | 2004 Ford Crown Victoria

Not finding what you are looking for?
2004 Oldsmobile Alero Logo

652 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...