Question about 1993 Chevrolet Astro

3 Answers

92 astro runs rough

My 92 astro runs good when firt started then starts missing and sputtering when it warms up.when u hit the gas hard when driving it starts surging between running smooth and sputtering

Posted by on

Ad

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 125 Answers

This could be quite a few things, I would start with checking temperature sensor/o2 sensor and fuel pressure.

Posted on Oct 20, 2014

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If u have the 4.3L v6, throttle body injected, then its may likely the o2 sensor, I'm having the same issue with my 93 astro.

Posted on Aug 24, 2012

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 3,433 Answers

Have mass airflow sensor cked.

Posted on May 28, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1991 F350 w/460 cu starts but runs rough until warm.


sounds like auto matic choke problem try a manual choke

Jan 02, 2014 | Cars & Trucks

1 Answer

1999 chevy sputters after start


dirt put a fuel system cleaner in the fuel tank.

Dec 22, 2013 | 2000 Chevrolet Astro

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

1992 Chevy S10 2.5L-4 cylinder. just started today outta no were. it idles really rough and pops then when i step on the gas it sputters and pops also smokes a little. help please..


My 1990 S10 pick-up had a similar problem too. It would start up fine (while the engine was cold) then once the engine warmed up it would idle very rough, sputter, and even stall out. My grandpa and I found what was wrong finally. The fuel distributor had been cracked, so when the engine warmed up it would miss (giving either too much or not enough fuel). So I recommend that you check that. Hope this helps.

Jan 02, 2011 | Chevrolet S 10 Cars & Trucks

1 Answer

1994 dodge ram van b250. when warm, starts easily. when cold, will crank but not start. eventually, fuel pump kicks in and primes lines, starts rough, sputters, dies, then finally starts rough and runs...


Sounds like the fuel pump is going out. Its inside the tank. But first see if the fuel pump is clooged. take it off and see if its plugged. Check fuel pressure if you can. should be 45-55 psi

Oct 13, 2009 | Dodge Ram B250 Cars & Trucks

1 Answer

Running rough and buzzing at throttle body injectors


Sounds like the engine has a vacuum leak at the throttle body area.

Jul 18, 2009 | 1990 Chevrolet Astro Extended

1 Answer

95 elantra runs but sputters and backfires. runs ok on the highwa


This isn't answer but a couple of things to check or do. First has fuel filter been replaced? Start car and put it in gear. HOLD Brake and Give it gas while still holding brake hard!!!! Doess it buck or miss fire? You said it ran bad to highway. Explain Please !!! will answer after you reply.

Feb 03, 2009 | 1995 Hyundai Elantra

Not finding what you are looking for?
1993 Chevrolet Astro Logo

384 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...