Question about 1983 Chevrolet Blazer

1 Answer

After car is fully warmed up, get an intermittent hollow sound

Also some loss in power, hesitation on acceleration. Until complete warmup car responds great. About the only thing I haven't done is replace the carburetor which was rebuilt a couple of years ago by previous owner. I suspect perhaps a faulty power valve.

Posted by on

  • hudsonterror May 26, 2009

    Engine runs 50+ lbs oil pressure. Do you mean thinner than 5W30?

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 41 Answers

Try using thinner oil

Posted on May 25, 2009

  • dean bridges
    dean bridges May 26, 2009

    ok thats is quite thin enough oil you might try puting a block heater on it at night

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hours of reading blogs; none show my symptoms: SAAB 95, 2005 Arc. Hiccup/hesitation/stumble when's engine warm to hot, any speed.


Are you talking about a go-cart, or a motorcycle, or a tractor-trailer 18 wheeler? Then OF COURSE, you must IDENTIFY the MAKE, the MODEL, and the YEAR of whatever vehicle you are asking about, if you want any REAL help!

May 16, 2017 | Cars & Trucks

1 Answer

What, other than plugs, wires , cap and rotor would be causing loss of power on acceleration, but not all the time,, intermittently.


There is a vacuum advance attached to the distributor. Inside the vacuum advance is a rubber diaphragm that can crack from age an no longer work. Sometimes the vacuum hose that attaches to it may not be getting proper vacuum. This device adjusts your timing when you accelerate. Improper function could cause the problems you describe. Also, a vacuum leak in any of your vacuum system could cause the problem your describing. Too much air intake on take off from a faulty vacuum system could throw off your air fuel mixture on acceleration causing hesitation until the air fuel mixture can catch up which is when the power comes back. Hope this helps.

Oct 29, 2014 | Cars & Trucks

1 Answer

Engine ticks over but no acceleration



ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Feb 04, 2013 | 2007 Kia Magentis 2.0

3 Answers

The car will run fine for about 10 minutes then it will stop accelerating???


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | 1999 Mercury Cougar

1 Answer

Hesitates to accelerate and power loss


Did you check the fuel pressure before and after replacing the pump ?
Is the check engine light on ?

Jun 28, 2012 | 1996 Chevrolet Camaro

1 Answer

2002 Subaru Forester P0136 see P2270 P2271 intermittent idling fluctuation and acceleration hesitation


Is the wiring good going to the O2 sensors? Maybe just look the car over and see if you have any bad grounds. They can do weird things. Could be a bad ICU.

Jan 22, 2012 | 2002 Subaru Forester

1 Answer

Intermittent poor acceleration, loss of power. Has


How is your charging system? Sounds to me like it's not charging your battery, so it runs until the battery cannot support the ignition load.

Apr 24, 2017 | 1992 Buick Park Avenue

1 Answer

Intermittent hesitation at steady speed.


It could be the spark plugs, plug wires, distributor cap, rotor in the cap, or an O2 sensor. does the check engine light come on?

Feb 08, 2010 | 1992 Honda Accord

2 Answers

Intermittent power loss after accelerating hard


Sounds like a fuel delivery problem! Try filter first (cheapest), then the pump
Hope this helps, Henry

Oct 17, 2008 | Nissan 240SX Cars & Trucks

1 Answer

1992 civic hatch acceleration problem


it might just be your timing i had the same problem with my 94 hatch did have any power on first or second just had a friend adjust the timing and werks just fine.

Oct 02, 2008 | 1993 Honda Civic 4 Door

Not finding what you are looking for?
Cars & Trucks Logo

196 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...