Question about 1997 Chevrolet Blazer

1 Answer

97 s10 blazer cuts out and loses power while driving.

Fuel pump has been replaced so i'm wanting to know if it could be the crankshaft sensor.i changed the spark plugs,wires, cap & rotor, the ignition switch, fuel pump, fuel filter on my 6cyl 4x4 1997 blazer and i am having a problem starting it. and when it starts it backfires when you stomp on the gas. gradually it runs fine. it has no pick up at all. it's an EDI system so i know firing order isn't the problem. What can it be already?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,472 Answers

Have you checked to see if it is throwing any codes? You can bring it to any autozone and they can check the engine codes. It could be crankshaft sensor could be TPS sensor, or a couple other sensors. Having the engine codes being thrown should narrow it down. Once you get that let me know and I can assist you further.
Thank you,
Lee

Posted on May 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 s10 blazer cranks no start . when I was trying to test the crank sensor signal wire I found 10 volts present with ignition on not cranking. the ground wire has 12.5 with the key off and 12.21 volts...


Will a scan tool communicate with it or on the screen does it say NO COMM ! That's how you test a PCM/ECM . If no comm ,check power an ground's ,that's it .
Why were you messing with the crank sensor ? If the fuel pump primes for two seconds there is nothing wrong with it . When cranking the engine the PCM/ECM will only energize the fuel pump if it see's an input from the crank sensor ! You will not see 12 volts on the crank sensor signal return wire ! Crankshaft Position (CKP) Sensor
The CKP sensor is a three wire sensor based on the magneto resistive principle. A magneto resistive sensor uses two magnetic pickups between a permanent magnet. As an element such as a reluctor wheel passes the magnets the resulting change in the magnetic field is used by the sensor electronics to produce a digital output pulse. The PCM supplies a 12-volt, low reference, and signal circuit to the CKP sensor. The sensor returns a digital ON/OFF pulse 3 times per crankshaft revolution for the V6 engine, 4 times for the V8 engine. The CKP sensor reads the crankshaft mounted reluctor wheel to identify pairs of cylinders at top dead center (TDC).

May 20, 2017 | 2003 Chevrolet Blazer

2 Answers

1998 Chevrolet S10 truck Is Not getting gas. We Have Replaced the Fuel pump and the crankshaft Sensor and had the ignition Sensor tested which test good.Would like to Know what else to do to try to fix it.


So is the pump running or not? fuse good? relay good? Fuel pressure is???you may need to have a repair shop check it, you dont want to waste anymore time and money guessing.

Mar 12, 2010 | 1998 Chevrolet S-10 Pickup

2 Answers

1993 s10 4.3 starts fine, while idling it dies. sometimes i have a hard time restarting. the blazer died a couple of times while driving.fuel pump is good, tuned up, remanuf. injectors 1 yr ago,engine lite...


only half way there if you have a tbi check the crank sensor/ cam sensor that is the first line of business on that truck if the crankshaft sensor fails the truck stops dead when you wait a few minutes the sensor re energizes and the truck will work again for a bit antiknock can cause similer problems but not while the truck is running

Feb 24, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

Tahoe 97 Fuel problems


Crank sensor has to be bad,or the ignition module.Remove the ignition module and have it checked at the parts store.If it checks bad,replace it,if it checks good replace the cranksensor.The cam sensor,cranksesor,and the control module control injector pulse,and coil spark.I would point more to the ignition module.But I have known the crankshaft sensor to do this also.I hope this was helpful,if so,let us know,thanks,and good luck.

Oct 06, 2009 | 1997 Chevrolet Tahoe

1 Answer

I HAVE A 97 4.3 2WHEEL DRIVE S10 TRUCK. STARTS WHEN IT WANTS


check the coolant sensor, check for possible fuel filter clogged.

Jul 25, 2009 | 1997 Chevrolet S-10 Pickup

2 Answers

I have a 1993 s10 blazer 4.3l 6cyl cpi. this truck is hard to start unless you put fuel in the intake by hand. i have replace the fuel pump, engine temp sensor, fuel filter, spark plungs and wires. when i...


you might want to replace the fuel pressure regulator, though it sounds like there is a restriction in the system or H2o in the fuel. from another angle, you did change the cap and rotor? hope this helps.

Jul 11, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

1999 chevy blazer wont start


THE FUEL PUMP IS BAD.

if your losing fuel pressure after the pump runs the drain back valve in the pump has failed.

and i doubt that you are seeing enough fuel pressure to run a vortec engine.

low fuel pressure equals a non running vortec

Apr 11, 2009 | 1999 Chevrolet Blazer

1 Answer

'97 Jeep Grand Cherokee Ltd 4.0 liter; Will start but cuts off.


have u replaced the crankshaft position sensor? do u have any computer trouble codes? Kragen or Autozone will run the test for free.

Mar 12, 2009 | 1997 Jeep Grand Cherokee

2 Answers

97 s10 blazer cuts out and loses power while driving.


Had the same problem with by 1998 S10 a couple years ago. Changed fuel filter?? didn't work. Changed the fuel pump?? didn't work. Changed the fuel pressure regulator?? didn't work.

I was about to the end of my rope when I put a timing light on it and it showed firing on cylinders more then once a cycle. Turns out my distributor cap was bad and spark was jumping between contacts. When a spark is spread out over more then one cylinder, it doesn't fire correctly and that is causing it to bog out. Simple and a lot cheaper then all the other fixes I tried. Crank sensor was my next option though.

Feb 01, 2009 | 1997 Chevrolet Blazer

Not finding what you are looking for?
1997 Chevrolet Blazer Logo

Related Topics:

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...