Question about 1991 Subaru Legacy

2 Answers

Engine seems to run good then goes downhill

Engine fires up straight away and runs fine, however, after a short drive it loses power rapidly and idles really rough to the point where it seems as though the motor might jump out from the engine bay. Have tried everything I can fuel system, coils, spark plugs. Is it in the turbo or maybe head gaskets? Also rattles while running to the point that its embarassing. Have tried running a multi grade oil but still hasnt fixed the issue. Are the issues maybe related? Car is a 1992 2ltr turbo 4wd legacy. Please help

Posted by on

  • alanzilla May 24, 2009

    Thanks have checked and did replace the fuel pump. Cheers anyway

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check the TIMING, i had the same issue now it just wont start at all, and everything says timing...

Posted on Apr 11, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,004 Answers

Have a look at the fuel pump it looses pressure when hot which means it is due to be replaced.

rate this please

Posted on May 24, 2009

  • Onifade Adewunmi
    Onifade Adewunmi May 24, 2009

    Please you need to rate my solution.



    Murphybanton.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, Car will start fine and runs perfect, however after a long run (1/2 hour or more) wont start straight away wait 10 mins and away it goes, turns over fine just doesn't fire


Loss of spark ? CK coil or coil pack or ignit relay. Any CK engine lts? coolants sensor or temp sending unit.? Is it running hot?

Sep 04, 2015 | 2003 Hyundai Santa Fe

1 Answer

Engine Malfunction Light...drives at reduced speed...best 40kmph


Oh you can drive it, but drive it to the shop and have the EGR(Exhaust Gas Recirculation)valve replaced. That is what's causing your lack of power. It has to work in conjunction with all other emission control systems and once it' goes bad the engine will have no power but seams to work fine otherwise. Change the EGR valve.

Dec 11, 2013 | 2009 BMW X5 3.0d

1 Answer

2000 es300, sometimes surges - last time it seem to lose power could only drive about 20 miles per hour


Check for failed EGR Valve or system component

If the valve has a vacuum hose going to it ,disconnect,
plug hose & test drive to evaluate bad valve & high vacuum
signal as you suggested

Sep 30, 2012 | 2000 Lexus ES 300

2 Answers

1999 Toyota Camry runs good idling, but put in drive it loses power and sputters


may look good but that means nothing if electrode in any spark plug go's op[en circuit when warm it will spluter as it will be mis fireing on that cylimber try a new set of plugs then check leads then distributor or electro ignition

Aug 14, 2012 | 1999 Toyota Camry

1 Answer

Car hesitates and sputters


It seems like you have a vacuum leak in a hose some where. Check under the hood for any rubber hoses that are dry-rotted, cracks, or sharp bends in any of them.

Aug 21, 2009 | 2004 Dodge Neon

1 Answer

Main engine control fuse blows out


One thing missing when running at idle is road vibration. Try a wiggle test on wiring to see if there is a short to ground anywhere. Only thing I really hate when doing this is that I have had problems like this disappear after doing test and not re-appear for a year or two, because the wires got moved enough to keep the bad wire off of where it had grounded.

Jun 07, 2009 | 1995 Jeep Grand Cherokee

1 Answer

No power, idling rough


Replace the catalytic converter and EGR valve

Jun 03, 2009 | 1991 Subaru Legacy

1 Answer

Car stumbles,hesitates,loses power on Hwy, randomly


Did you check earth connection of electric system?

May 10, 2009 | 1995 Oldsmobile Eighty Eight

1 Answer

1990 gmc k2500 new 5.7engine & turbo 400 ,power lose & noise.


sounds as if you may be looking in the wrong spot. If different gearing is drastically changing the symptoms you may want to check the trans. or torque converter. sudden pop with engine rpm increase and lack of power sounds like possible band breakage in transmission or impellor breakage in torque converter.

Oct 20, 2008 | 1990 GMC K2500

Not finding what you are looking for?
1991 Subaru Legacy Logo

256 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...