Question about 2000 Chevrolet Cavalier

1 Answer

Starting is good but when u drive it..no power

Yes stating is good but when drive it its no power..only 120 km/h the speed

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 206 Answers

Sounds like the fuel pump hook it up to a pressure tester

Posted on May 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

Tip

How to use your car, so that it can last longer.


Drive gently and avoid high speeds.<br /><br />Your vehicle does not need an elaborate break-in. But following a few simple tips for the first 1,000 km (600 miles) can add to the future economy and long life of our vehicle.<br /><br />Avoid full throttle acceleration when starting and driving.<br /><br />Avoid racing the engine.<br /><br />Try to avoid hard stops during the first 300 km (200 miles).<br /><br />Do not drive slowly with the manual transmission in a high gear<br /><br />Do not drive for a long time at any single speed, either fast or slow.<br /><br />Do now tow a trailer during the first 800 km (500 miles).<br /><br />Good luck.<br />

on Feb 14, 2011 | Toyota Pickup Cars & Trucks

1 Answer

Which was the performance of ford anglia 1966


their are 16 models for the anglia in 1966 using the higher hp /manual set up --Anglia 105E-123E Saloon model for Europe North America , 2-door sedan with manual 4-speed and 1198 cm3 / 35 40kW (47 54 hp / 48 54 PS);--------- Acceleration:0-30 km/h (s):2.20-40 km/h (s):3.50-50 km/h (s):4.60-60 km/h (s):6.60-70 km/h (s):8.50-80 km/h (s):10.90-90 km/h (s):140-100 km/h (s):18.50-110 km/h (s)24.40-120 km/h (s):34.7----------Drag times:0- 1/4mile (s):20.4speed at 1/4mile:103 km/h / 64 mph0- 1km (s):38.9------- Top speed: 132 km/h / 82 mph http://www.automobile-catalog.com/auta_perf1.php

Sep 25, 2016 | 1966 Ford Anglia

1 Answer

Acceleration problems


Is the transmission fluid topped up?

Nov 09, 2013 | Ford Cars & Trucks

1 Answer

The RPM of my engine remains at 4000 while my speed is 120 km/hr


I guess that you have a manual transmission. If that is the case you have a clutch on the way out. Slow slippage that gets worse as the plate gets hotter. If an automatic it is possible that the overdrive is not holding due to low pressure in the box. Have a pressure test done on the box--- have the fault codes read. From experience 120 kph is around 3200rpm for most cars and the 800 rpm difference indicates that the o/dive is not working as it should.

Apr 02, 2013 | 2000 Toyota Camry

1 Answer

Toyota Auris 2008 - what might be causing an intermittent metallic sound when I am driving?


Hahahaha
Good old dealer eh
They fitted the most profitable and easiest parts first!!!!
Take you car to a small local indepent garage who will have the time to road test and check your car with you

Apr 24, 2017 | Toyota Corolla Cars & Trucks

1 Answer

Mitsubishi Pajero (Montero) 2005 transmission light. After driving for approximately 20 km (~12.5 miles) at a steady speed of 120 km/h (~65 miles/hour) the red light of the transmission starts flashing. ...


Could be either or, or it could be neither. Is the "red light" a transmission temperature warning light? If so, the fluid is over heating and the heat sensor is turning the light on...Check fluid level and the condition of your fluid...if it's off colored and smells burnt, you better have it flushed, refilled and a new filter installed. Heat will kill a transmission faster than anything.
Check the transmission cooler, most montero's had a cooler installed on the front of the vehicle by the radiator...the cooling fins need to be clean, no bugs or debris so air flows through it. Have your vehicle scanned also, if you had a transmission code the computers memory will probably still have it stored, this will be helpful with further diagnosis.

Jul 16, 2011 | Mitsubishi Montero Cars & Trucks

1 Answer

Slow speed 2.7 toyota prado 2004 mo0del


May be low fuel pressure, or, much less likely, a bad fuel filter. Check your air filter, maybe even replace it. Check vacuum lines for leaks. Try a good fuel injection cleaner like Lucas brand. Maybe a gas line dryer (for water mixed with gas). You might have to test or have tested, your fuel injectors. Could be the throttle position sensor. MAP sensor. Choke may be sticking part way closed.

Aug 26, 2009 | 2004 Toyota Land Cruiser

1 Answer

1986 toyota landcruiser - auto box - quick chance setup kit for valve plate


Fitting an overdrive auto or a 5speed manual transmission will give a little more top end ......or..... fit larger tyres. V8 should have enough torque to cope well at lower speeds.

Jul 16, 2008 | 1986 Toyota Land Cruiser

Not finding what you are looking for?
2000 Chevrolet Cavalier Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...