Question about 1999 Hyundai Accent

1 Answer

When i start car it sound like its about to shut off

When start car it sound like it's about to shut off (like the fuel not getting to the engine). I've changed the plugs, air filter, added injector cleaner, cleaned the carbarator. What could be the problem? It's a 1999 Hyundai Accent

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Maybe distributer/timing issue.

Posted on May 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 90oldssilhouette starts runs fine shut in off then it won't start i put the gas pedal all the way down then it starts


this sounds like the engine is getting too much fuel as when you push the gas pedal all the way to the floor you are putting the system in clear flood mode shutting off the injectors so as too not allow any more fuel and then it starts. its like what you would do if it was a carburetor and the engine was flooded.

Sep 15, 2014 | 1990 Oldsmobile Silhouette

2 Answers

1999 dodge darango runs till gets hot then dies and wont start till cools off then starts.


  • need to check fuel system when its dead,using the pressure port on the fuel rail.if it has pressure you may have a bad crank sensor

Aug 22, 2013 | Cars & Trucks

2 Answers

1996 honda accord starts up fine runs 10 15 minutes engine shuts down wait 5 ,10 minutes starts back up shuts off short time after


sounds like there could be a problem somewhere along the fuel line either between the pump and that engine or between the filter and the engine i have a car that would do the same thing turned out to be the fuel filter was full of **** ran like a dream after i changed that.

Jan 10, 2012 | 1996 Honda Accord

2 Answers

New fuel pump new regulater .fuel pump runs but will not prime up and shut off


sounds like you hooked the hoses up wrong at the pump unit or you have a bad fuel filter...replace the filter first..then check those hoses and clamps.

Feb 07, 2011 | 1995 Ford Explorer

2 Answers

I check all relay and don't receive direct electricity to the fuel pump and no start the car


You will never have direct electricity to fuel pump only when running then once you shut off ignition that shuts engine off fuel pump to automatically shuts off.I would change the fuel pump sit in car turn key Th start position do not crank engine if you do not hear a grrr,,,grunt sound i would say fuel pump not functioning therefore fuel pump malfunction replace.

Dec 19, 2010 | 1995 Mitsubishi Montero

1 Answer

I have 2003 ford expedition,when engine is cold my expedition is hard to started... what should i do..


Sounds like you have a fuel pressure issue. These trucks are bad about bleeding all the fuel pressure off when the engine is shut of but will run fine when started. the only good way to check this is to install a fuel pressure gauge on the shrader valve on the fuel rail. Once you get it isntalled start the engine and let it run for a minute or so,shut the engine off and it should hold pressure,if it bleeds off quickly it means the check valve on the pump is leaking and it will need a fuel pump.

Sep 21, 2010 | 2003 Ford Expedition

1 Answer

Car running fine , shut off,went to start again and it stays on low low ide, if i then hit gas pedal it will shut off. help


sounds to me like a fuel pressure problem. Getting enough fuel to idle but dies when you give it gas. Might be a plugged fuel filter. Id check that first. That will tell you wether or not the engine is getting fuel.

Aug 21, 2010 | 1995 Oldsmobile Aurora

Not finding what you are looking for?
1999 Hyundai Accent Logo

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8572 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...