Question about 1995 Chrysler LeBaron

2 Answers

95 Chrysler LeBaron Electrical Problem

I bought a 95 LeBaron last fall. The previous owner told me that the radio didn't retain the pre-sets. After a while I realized that the door lights and door locks did not work when the ignition was in the off position. Last week my mechanic fixed all three problems and said the wiring was messed up because someone tried to install an alarm system and didn't correctly connect all the accessaries to the right fuses.

The very next day I realized that while the radio, door lights and door locks worked great the Power Top, Horn and Power Seat (which all previously worked perfectly) were no longer functioning. After driving the car for 30 minutes I hit a bump and the Top, Horn, & Power Seat worked until ten minutes later I hit another bump and they haven't worked since. My mechanic can't find the problem with the Horn, Power Top & Power Seat. So now that the weather is great & I have
a beautiful LeBaron convertible with a top that has no power.

Does any have an idea as to what the problem could be or where to look? Please Help.
Thanks ~ Frank

Posted by on

  • chiarello3 May 24, 2009







    Posted at Sat May 23, 2009 6:27 pm

    By Frankie LeBaron, New to the forum

    Give Feedback | Votes: 0






    I took a close look at the fuse box this afternoon and saw that the 3 accessaries that are not getting any power are on the same 30 amp fuse. The fuse is good but I can't imagine it being a coincidence that all the issues are on the same circuit. What should i do next ~ Frank Posted at Sat May 23, 2009 6:27 pm By Frankie LeBaron, New to the forum Give Feedback | Votes: 0 I took a close look at the fuse box this afternoon and saw that the 3 accessaries that are not getting any power are on the same 30 amp fuse. The fuse is good but I can't imagine it being a coincidence that all the issues are on the same circuit. What should i do next ~ Frank

  • Richard Scordino May 11, 2010

    sounds like time to play wiggle the wires

×

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 137 Answers

You need to look at wiring diagram and find point where power top horn and power seat have common feed, seems likely that its one wire, power or ground, that has an intermittent connection. standard practice is to cut a new piece of wire, gotta go buy some, same length or little longer, same gauge as piece that is suspect then strip insulation from wire that you think might be bad and overlay new piece. don't cut the old wire till you know it is bad.

Posted on May 23, 2009

  • ben May 25, 2009

    good detective work, all three on same fuse, probably all three on same power feed. there is probably a plug block somewhere that has a not so great connection. if you can stand on your head and see what wire comes out of the fuse box from that fuse, and then follow it, might come into a big wire loom, that black plastic stuff they wind around a bunch of wires at the factory, unwind it carefully so you can put it back when you are done. see how far you can follow that wire, might go up under dash or something, anyway, that's the wire you want to track down. it has to go to horn button and top control, maybe you can find where those come together.

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,669 Answers

I have found that on this model a lot of weird electrical problems are caused from connectors pushing out of the fuse box when you push in the fuses. Pull out the fuses for these items, make sure the terminals that the fuse is pushed in to aren't pushed out the back of the box.

Posted on May 23, 2009

  • Clint Smock
    Clint Smock May 24, 2009

    Did you check to see if the terminals are pushed out the back on that fuse. Remove the fuse and see if both metal terminals are in the right spot.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

95 LEBARON won't start, its dead not the battery


If the battery and the starter are good then you need to check the ground to the motor,or clean the battery cable ends with a knife to get off the black **** that builds up on them over time.

Nov 01, 2009 | 1995 Chrysler LeBaron

2 Answers

Where can i find a diagram to install serpentine


Most parts stores can print this out for you for free.

Sep 10, 2009 | 1991 Chrysler LeBaron

1 Answer

My 1991 LeBaron convertible top just died (no warning) about an inch from locking in place. My mechanic said there was juice getting to the motor so said I needed to replace the motor. I have since been...


Most electrical problem occur without warning unless there is a built in trouble sensor. Mechanical problems on the other hand do give you some warning most of the time.

Jul 09, 2009 | 1991 Chrysler LeBaron

1 Answer

Serpentine belt slipped off due to anti-freeze.


Probably wet electrical components. Use an air hose to blow everything off , and let it dry good before you try it. Or, the mass air flow sensor could be dead.

May 04, 2009 | 1995 Chrysler LeBaron

1 Answer

1995 chrysler lebaron


Here's what mine says- for a 95 Chysler LeBaron GTC Convertible. I didn't see anything about a fuel pump, but maybe it's connected to something else? I dunno. Good luck. Here's the info at least.
1 HTR-AC 30A, 2 POWER WINDOWS 30A C/B, 3 PWR SEAT, LKS, TOP 30 A C/B, 4-BLANK, 5 BACK-UP LAMPS 20A, 6 TURN SIGNAL 20A, 7 REAR WIPER 20A, 8 ILLUM LAMPS 5A, 9 INTERIOR LAMPS 10A, 11 CIGAR LIGHTER 20A, 12 RS AMO 20A, 13 INTERIOR LAMPS 10A. 14 BOD COMP MESS CTR 5A, 15 SPEED CONTROL 2A, 16 GAUGES AIRBAGS 5A, 17 STOP LAMPS 18 HEAD LAMP RT-LOW 10A, 19 HEATED MIRRORS 5A, 20 AIRBAGS 5A, 21 STOP LAMOS 20A, 22 HORN 20A, 23 RT-TAIL LAMP-EUR 5A, 24 LT-TAIL LAMP EUR 5A, 25 HEAD LAMP LT-HI 10A, 26 HEAD LAMP RT-HI 10A, 27 RADIO 104, 28 FRONT WIPER 20A

Mar 29, 2009 | 1995 Chrysler LeBaron

1 Answer

1993 Chrysler lebaron converible rear window drivers side


Just bought a '95 with the same setup, and same problems on both rear windows.

There are 2 cables on each window, one for lifting the window, and one for lowering it.
The cable that broke is more than likely the lift cable.
I had to replace all but one of the 4 cables on mine. Once one comes undone, they tend to wind around each other, and everything else, and become knotted and frayed.

From your description, the cable didn't break. It was the plastic side peice of the cable retainer on the track. This is a deliberate design flaw on these.
Don't go to a dealer for a new cable or retainer.
The correct fix is to go to a hardware store like Lowes or Home Depot, and get a length of 1/16 wire rope and matching ferruls. Loop the wire rope completely around the retainer on the track and attach it back to it's self. It will never break again.

Nov 29, 2008 | 1993 Chrysler Lebaron

1 Answer

Car stereo


go to a chrysler dealership and they should print you one out for free i did for my chrysler lebaron

Sep 19, 2008 | 1995 Chrysler LeBaron

1 Answer

1992 Chrysler LeBaron 3.0 L. V6 Engine runs beautifully but after 16-20 miles highway driving engine stalls as if flooded, or as if fuel is cut-off. After sitting for a few minutes, will start and run...


the owner probably rerouted the fuel line because like my 92 chrysler lebaron v6 3.0 the fuel lines keep seeming to come off and the clamps always break. I have replaced the clamps 5 times in a month and replaced filters 2 times in 2 months. The only thing i could think of is that your fuel is being cut off possibly because there is no filter to clean all the junk out. Try putting a fuel filter on and see if that will work

Aug 02, 2008 | 1995 Chrysler LeBaron

Not finding what you are looking for?
1995 Chrysler LeBaron Logo

909 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8560 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...