Question about 1994 Chevrolet K1500

1 Answer

Check engine light coming on and going off

My check engine light comes on after about 10 miles and will go off sometimes after about another 10. sometimes it does not come on at all. other times it wont go off until i shut off the engine but will stay off after that.

Posted by on

  • mcheek1973 May 23, 2009

    I have heard this before and this is probably it. Do you know where I can find a diagram of my engine so I can see where it is and if I am able to fix this myself?



    thanks a lot fo the help too.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

  • Expert
  • 95 Answers

Probably an Oxygen sensor is slowly going out, or something small like thatm had to be emmissons/ elcetrical though....Assson as it comes on go to Advancedauto they will do a diagnosis for free most times, if you have the ob1, or ob2 system, which you do! Also check the gas cap, i know it sounds crazy but a loose gas cap can send off the CE-light, and do other crazy things...Hope this fix's-ya !!

Posted on May 23, 2009

  • Mysticole_20 May 23, 2009

    the oxygen ensors are located on the exhaust, usually under the ex-manifold, onthing that should be on the exausht with wires to it...you might want to take it to advanced auto/ auto zone for free diagnosis, like i mentioned earlier to save you some cash..but the maf sensor might be bad aswell...it is located on the air induction system, usually a samll black or gray sqaure shaped device with few wires to it... both of these are ez to find and fix

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine,vsa and triangle light comes on when driving a few miles


Check vtec solenoid gasket/screen.If dirty replace gasket/screen.

Aug 01, 2014 | 2005 Honda CRV 2.2

1 Answer

When my 1990 subaru legacy is cold it runs good then after 10 miles it starts skipping engine light comes on and a strong ordor of gas can be smelled. it does not run hot but when it starts to cut bac


Could be a faulty O2 sensor. The sensor would not take action until the engine warmed up. Have you checked for trouble codes in the engine computer ?

Jul 28, 2014 | 1990 Subaru Legacy

1 Answer

My 1994 Jeep Wrangler: Upon starting the Jeep, the check engine light has been coming on. Sometimes it is on upon starting the engine and sometimes it will not come on until a few miles or so down the...


Try replacing Co2 sensor, most people don't realized that unit need replacing every 50-75k miles also. if that does not work, take it to the dealer and have them plug it into the computer, that will allow for them to narrow it down. with service engine light on, it will effect some of your gas mileage and the performances. The dealer charge somewhere around 50 bucks to diagnose using their computer, however 50 bucks will appilied toward the repair bill if they do the work.

Nov 24, 2010 | 1994 Jeep Wrangler

1 Answer

2000 Grand AM GT Shuts off while driving


What you should do is check for spark when the vehicle stalls.If you have no spark then you probably have a bad ignition module.The other thing is You didn`t mention if the check engine light is coming on.If it is then have the codes read.Even if it is not you should still check the codes.Sometimes the computer will have a code and the light will not come on.This could give you a clue as to what could be causing the engine to stall.You might also want to check your fuel pressure just to make sure it is good.The pressure should be 52 - 59 psi.Hope this helps.Good luck.

Dec 20, 2009 | 2000 Pontiac Grand Am GT

1 Answer

My engine light comes on after 10-20 miles and


could be the vehicle speed sensor on the transmission. this can cause all of the above symtoms. check the plug on the sensor make sure it is not loose. If it is not loose you may have to buy a new sensor. If you dont knw where the part is located you can get a printout at autozone.,

Nov 02, 2009 | 1995 Honda Civic

1 Answer

Oil leaks in my 2002 Hyundai Accent and Check engine light is on. 103,000 miles . Was told the Check engine light sometimes comes on just because a car goes over 100,000 miles, True?


Some cars do this as an indication they need to go to a garage to be serviced. You should have the car checked for the cause of the oil leaks.

Oct 30, 2009 | 2002 Hyundai Accent

1 Answer

2002 Sebring -Odometer Lights Flicker then bing battery indicator


have the engine wire harness checked maybe a communication problem between modules.

Mar 27, 2009 | 2002 Chrysler Sebring

1 Answer

Oil pressure light comes on after driving on highway for 10 miles


Sounds like your sending unit sensor - if it was your pump going out, your engine would be history by now. Rule of thumb, if your oil check light ever comes on, it's usually too late to remedy the problem. You have a major issue, but since you've obviousely drove it quite a bit since then and it still hasn't seized up, I'm guessing you're ok...for now. Since you took it to a shop and they said you're ok, I'm assuming they checked your level and visually checked for leaks and found nothing. Either, you've got somethijng partially blocking your pick-up tube for the pump which is in your oil pan, or a electrical issue with the sensor. I would start by having someone check the sensor out and go from there...good luck.

Dec 29, 2008 | 2002 Jeep Liberty

Not finding what you are looking for?
Cars & Trucks Logo

117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...