Question about 1998 Pontiac Sunfire

1 Answer

Antitheft light and all the others turn on and rpm and cooling gauge stop working

Antitheft light comes on then all the others oil battery seatbelt arbags and coolant but the car keeps running fine,but the rpm gauge,and temp gauge stop working,and the driving lights wont turn off when I put it in park.But they will turn off when I shut the engine off.And it doesnt always act up,some times it it acts up after driveing for awhile.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Try putting water in it

Posted on Jun 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

High temp low oil pressure light comes on after driving for a few minutes, then off when engine at driving rpm. At stop light (idle or low rpm) light comes back on. Normal driving it goes out.


You need to find out why you have low oil pressure. It is normal that as engine rpm's increase, the oil pressure will rise- the oil pump is moving oil faster. Even though your light goes out, you could still have critically low oil pressure. There should be sufficient pressure at idle to keep the light off. The light will come on when your oil pressure is almost nil- I believe for some it's as low as 8 psi. Normally, oil pressure at idle is specified anywhere from 15 to 40 psi. You would have to check specifications for your Expedition. To verify oil pressure, hook up a mechanical gauge at the oil pressure sending unit on the engine block. Check with a local shop.

The causes run from easy, simple to budget busting ruin. Low oil level, wrong grade oil, real old oil, oil leaks, internal oil leaks, worn oil pump, worn crankshaft bearings. It was pretty common on older very high mileage cars to have a fluttering oil light at stops and idle. It was time for a rebuild, or time to look for another car.

Jul 06, 2015 | 2003 Ford Expedition

1 Answer

Oil light comes on when i put the clutch in and come to a stop


check the oil level in the sump. Ensure that the idle RPM is at 750rpm or above up to 1000rpm. Check for the correct grade of oil in the engine for you atmospheric temperature.

Feb 21, 2014 | 1994 Mitsubishi 3000GT

1 Answer

I have 99 oldsmobile Alero. When I turn it on the oil , battery , seatbelt light turn on. But when I turn the engine on the gauges don't work. But when the weathers hot outside the gauges turn on. Any...


SOUND LIKE SHORT IN GAUGES. HEAT WILL CAUSE SHORT TO WORK.HEAT FROM THE SUN WILL CAUSE PLASTIC EXPAND WHEN PLASTIC SHRINK BACK IT WILL CRACK.IF CLUSTER GAUGE HAS A CRACK IN THE CIRCUIT BOARD HEAT WILL CAUSE PARTS EXPAND ENOUGH TO WORK AGAIN.

Aug 22, 2011 | 1999 Oldsmobile Alero

2 Answers

I have a 1999 Pontiac Sunfire with a 2.2L motor. It runs great considering how old it is. Last week I started it up and several of my dash lights stayed on. They are: The oil light, the battery...


Sounds to be the dash itself. there is a chip in there and it sounds like it shorted out. You have to replace the panel. Junk yard would be best and cheapest.

Jan 21, 2011 | 1999 Pontiac Sunfire

2 Answers

One by one my gauges(rpm,gas,speedometer,oil) stopped working. Is there a sensor that needs replaced? a fuse? dash? Help?


please keep me posted as well, ALL my gauges are doing the same. First the gas, filled it one day and it fell all the way and light turned on, then my themostat, freaked me out, thought i was overheating,...NO just the guage, NOW my spedometer is stuck on 120, and my RPM's are acting crazy. i have read tons with this same problem, WHY WONT the manufacturer DO SOMTHING??

Aug 25, 2010 | 2004 Isuzu Ascender

1 Answer

Gauges don't work-before went out abs light would come on


it might be a fuse under the hood or fuse panel or connection to the gauges them selves

Dec 16, 2008 | 1995 Dodge Dakota

Not finding what you are looking for?
1998 Pontiac Sunfire Logo

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...