Question about 1993 Nissan 300ZX

1 Answer

Starts ,runs & turns off won't run with supplying fuel

86 300zx starts,Runs if primed and once primed fuel has run out turn off,seem yo me that my injectors are not working. I traced the wiring from injectors to comp. also relaced f/p,computer,injectors,relays according to the manuel i am getting the voltage to the components but it still seems as the injrctors don't pulsate what to do ?????????

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

I would change the fuel pressure regulator and fuel filter.

Posted on May 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

New fuel pump new regulater .fuel pump runs but will not prime up and shut off


sounds like you hooked the hoses up wrong at the pump unit or you have a bad fuel filter...replace the filter first..then check those hoses and clamps.

Feb 07, 2011 | 1995 Ford Explorer

4 Answers

Im working on a 95 s10 blazer.It has the 4.3 engine.It will only start if it is sprayed with starting fluid.the fuel pump,fuel filter,and pressure regulator have all been replaced.Seems like the system...


It sounds like the fuel pump is not working. Perhaps the install was not completed correctly. Things to check, fuel pump relay, wiring, voltage to the pump.
The priming happens as soon as you put the key in and turn it to "acc" (you may hear a humming sound). Then once you turn it to "start" the injectors and spark plugs start firing.
Another possibility is that the fuel filter was installed backwards.

Apr 22, 2010 | 1995 Chevrolet S-10 CA Edition

2 Answers

Shouldn't there be fuel pressure with the key turned to the run position? I only get fuel pressure when the starter is engaged and turning the engine over.


no you will not have fuel pressure untill the engine is running

fuel pressure is not required to start the engine...only to keep it running

when you turn the key on the computer send a signal to turn the fuel pump on for a second and prime the engine...once it starts the fuel pump relay kicks the fuel pump on then you have pressure.

Feb 06, 2010 | 1993 Toyota Corolla

1 Answer

93 ZJ 4.0L has intermittent fuel-pressure drop when starting


You have a good theory but haven't finished testing so you can verify it...check actual fuel delivery when in no-start...also probe the pump wire on the pump side of the harness and see if you are in fact not getting power to the pump all the time. (also in no-start). Don't test after it gets started, or testing will tell you what you already know...It runs fine once started...tests will then tell you it's fine (you know it's not) Problem itself could be anything from a bad connection somewhere to a balky pump.

Jul 06, 2009 | Jeep Grand Cherokee Cars & Trucks

1 Answer

Primed starts then turns off won't run


Do you have fuel pump pressure?

May 22, 2009 | 1993 Nissan 300ZX

3 Answers

89 regal won,t start but after 5 or 10 min. runs great


sounds like your fuel pump is going out. One thought might be that the fuel filter is causing enough resistance to over heat the pump. I would check the fule pressure to determine a free flow of fuel.

May 01, 2009 | 1990 Buick Reatta

4 Answers

Engine wont start without priming with gas first, then runs well


i have the same problem on a 98 jimmy 4.3 4x4.
i replaced the fule pump and have good pressure.
new wiers & coil (good spark) no MIL & no codes.
will only start when primed. it will run & drive all day
with no problems.
but once it has been turned off (warm or cold) i will
have to prime it once again to start it.
i have another engine that was in it before it spun a bearing.
it ran fine so i know all parts are good.
i swaped the mass air flow and throttle body but i still have
to prime it everytime to start it. am i forgetting something?
should i swap out the intake with the injectors?
any help would be sweet. thanks.

Apr 28, 2009 | 2000 Chevrolet Blazer

Not finding what you are looking for?
1993 Nissan 300ZX Logo

Related Topics:

201 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...