Question about 1998 Buick Century

2 Answers

Water shooting ut the sie of motor

The car wont hold water in the motor. When I pour water in the radiator it shoots out from where my pullies and belts are so in return the car runs hot

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Buick Master
  • 3,854 Answers

Sorry for the bad news but it sounds like with your description. The water pump on your Century has gone to it's life cycle. There are water weep holes built in the water pump and when the bearing in the pump is warn. The radiator antifreeze will start to leak from the weep holes to indicate that it's time for a new water pump.
Good luck and hope this helps.

Posted on May 22, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

It sound as if you have a bad water pump and try this website to see if they have your car listed its www.autozone.com if they do you be able to get pictures and diagrams showing you how to repair your car and check on a price at the same time hope this help you Michigan Man.

Posted on May 22, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

After blowing a heater hose and replacing thermostate my mpv now after 15 minutes of running shoots boiling hot water out the top of radiator ?


make sure no air is in the cooling system
heater on
run motor
fill radiator
wait till water flows no bubbles

if lots of bubbles or water spouts
blown head gasket

26341430-vhqiskbi4rfao14lbzesqfqu-3-0.jpg
26341430-vhqiskbi4rfao14lbzesqfqu-3-2.jpg

Nov 05, 2016 | Cars & Trucks

1 Answer

The water is not hot at all but the radiator is shooting the water out of the cap, and sending the water to the resivore and makes the resivore over flow.


Sounds like you may have a bad radiator. It may be clogged and the coolant is not able to go through it causing it to come out the cap and reserve tank.

Jul 29, 2014 | 1995 Oldsmobile Cutlass Supreme

1 Answer

Water is shooting up in front of the motor


Autozone has a free loner tool called a pressure checker with your engine off ,make sure it has not rune for 8 hours remove the radiator cap(make sure radiator is full) install tester. Pump it up no more than 13 pounds of pressure. you will be able to tell where water is leaking from. If this was helpfull please leave me good feedback

Feb 23, 2013 | 1996 Ford Taurus

1 Answer

93 geo tracker will turn over but wont start unless you pour gas in intake then will continue to run until you kill it. will not start back unless you pour more gas in intake.


Sounds like something is letting the fuel pressure bleed off after the motor is turned off. Can you monitor the pressure? (Requires adapters and gauge.) Trouble shooting will be a little different between the 8 valve or 16 valve motors. (The fuel injecton systems are different.) You might want to go to a Suzuki Forum. (Your Tracker is a rebadged Suzuki.)

Dec 17, 2012 | 1993 Geo Tracker

2 Answers

Water shoots out of the radiator when car is running. Unable to add water/coolant because of this. What is causing this to happen?


Wiil if water just shot out by just running thenyou have a bad radiator
If the water shot out asyou ran the car some thenyou my have a bad water pump and the timing i think not if it was you motor mynot run right...

Oct 19, 2012 | 1999 Chrysler Sebring

1 Answer

My rodeo started shooting steam out i filled it with coolant and during my 1 mile trip home water was pouring out from underneath,i poped hood,cap was on but steam was coming from below engine,help


Hi there,

Hopefully there is a hole in one of the hoses (least expensive).

No matter what, you need to find the source of the leak. A flashlight will be useful.

When the engine is cool, pour water in the radiator. You shouldn't need to run the engine.

When it starts dripping, look for the leak on:
  • The radiator
  • Large hoses leading to and from the radiator
  • Heater hoses (smaller leading to firewall)
  • Water pump (on the engine)
Once you find it, the severity and type of problem will dictated whether to fix or replace the damaged part.

Mike

Mar 24, 2011 | 1996 Isuzu Rodeo

1 Answer

When i start the motor with the radiator cap off the water comes out like someone turned on a pump. i am not getting water to flow it just pumped out the top of the radiator.


WHAT YOU HAVE IS A BAD HEAD GASKET. WHEN THE GASKET BLOWS OUT WHAT YOU GET IS THE COMPESION FROM THE MOTOR GETTING INTO THE COOLING SYSTEM AND THAT IS WHAT MAKES THE WATER SHOOT OUT

Oct 13, 2010 | 1992 Ford Taurus

1 Answer

Fluid wont shoot out


Have someone hold their foot down hard after pumping the brake pedal.
Open bleeder screw and fluid should shoot out. If it does not remove and clean tip.
If you are not bleeding your brakes.
What are you needing fluid to shoot out of?
Do you have a year make & model?

May 17, 2010 | Cars & Trucks

1 Answer

Torn Serpentine Belt. Bad belt driver


You say belt driver? The belt runs on a series of pullys, there should be a pic./diagram on the radiator support that shows the routing of the belt. simply take the belt off and check each pully( they will either drive the belt or be idlers/tension pullys)to see which one has any "side to side" motion. If it is on a "driver" you are looking at replacing that part(water pump,power steering pump. etc.), as the real problem will be a bad bearing in that unit.

Oct 12, 2009 | 1997 Buick Century

1 Answer

2006 Mustang not holding any water...


maybe a cracked block have you checked the radiator

Jun 18, 2009 | 2006 Ford Mustang

Not finding what you are looking for?
1998 Buick Century Logo

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...