Question about 1994 Geo Prizm

1 Answer

The car while driving will just ramdomly starting cutting out and then finally take off normally usually it's when the vechile is under a load such as going up a hill or under rapid excelleration such as merging on a interstate. Tried replacing plugs, plug wires, fuel cleaners etc. with no luck

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Sounds like it might be your fuel filter. Change it.

Posted on May 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 rranger 2.3 cuts out and almost cuts off at low rpm's and it idles hight


I have to ask the basics, how long since a tune-up, any applicable trouble codes?
Cleaning the throttle body and idle air control may help?
One thought is to unplug maf sensor, start vehicle, if idle is now normal, you found the problem. Could be wiring circuit--connector or maf sensor.
There might be a vacuum leak causing a problem? If fuel trim is high at idle, but, returns to normal under load, it's usually a vacuum leak.

Nov 29, 2016 | Ford Ranger Cars & Trucks

1 Answer

H1 DIESEL 2010MODEL TURBO BLEW


Blown headgasket or stuck valve. Will never run right until #2 problem is resolved.

Jul 30, 2016 | Cars & Trucks

1 Answer

Loss of power


I can think of two possibilities.
1) The air mass meter could be defective, or covered in dirt, and not providing the right fuel mix under a load heavier than normal driving.
2) The monolith in the Cat may be breaking up and blocking the exhaust system, which would again be more noticeable under load.
Both possibilities are usually accompanied by reduced acceleration and a drop in performance but when the problem starts these things may not be detectable.

Mar 25, 2014 | 1990 Mercedes-Benz Mercedes Benz C Class

1 Answer

Powersteering completley drained out


Split in a hose, pump damage, cooling radiator leaking etc etc etc. Have a look.

Jan 05, 2018 | 2001 Pontiac Aztek

1 Answer

My '02 745 BMW will not accelerate under normal engine load. Which makes me have to accelerate gently and drive slowly because my car will cut back on rpms and hesitate real bad. While the car is in park...


You have a injection problem, whether it's a sensor or fuel feed . I wouln't drive the car untill you have issue addressed as you coul;d cause real expensive damage. The PCM will have to be scanned to find out the cause.

Feb 08, 2011 | 2002 BMW 7 Series

1 Answer

Clutch


It does sound like a clutch, but deserves to be more thouroughly checked out, Does the clutch pedal feel normal? is there a little free-travel at the top of the pedal stroke? do you see oil dripping under the car?
Clutches usually go out slowly, they start to slip under heavey load first, then gradually slip even under light loads in low gears. If an axle was loose, it could have spun in it's hub, with the hood open ans an observerstanding beside the car looking down at the axles, slowly let the clutch out (engine running, in reverse gear, ) being careful not to hit your assistant, if the axles turn- one of them, but the wheel doesn't this is your problem. If the axles don't turn with the clutch out, and engine still revs, well it's time for a clutch or transmission, Good luck, hoe this helps

Apr 27, 2010 | 2000 Subaru Outback

1 Answer

Car cuts off while I am driving...


Yes...this is a sensor problem and will get worse before it gets better. The crankshaft position sensor on the CTS is famous for this. It's located in the engine block under and slightly ahead of the oil filter and is a bugger to get to.
Good luck...i hope this helps.

May 04, 2009 | 2003 Cadillac CTS

1 Answer

1987 CHEVY CORVETTE CUTS OFF SOMETIMES WHILE DRIVING


Could be just about anything, but given that I had the same symptoms that turned out to the fuel pump, I would check that if you haven't already. Mine would run fine for a while, particularly when it was cold, and tested fine at the shop, but after a while under load, it turned out the pressure would suddenly drop to about 15 pounds. A real pain to diagnose, since when it was in the shop it wasn't under load, so it tested OK.

Jan 28, 2009 | 1987 Chevrolet Corvette

Not finding what you are looking for?
1994 Geo Prizm Logo

Related Topics:

145 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

yadayada
yadayada

Level 3 Expert

78919 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Mike Gilbreath

Level 1 Expert

50 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...