Question about Lexus Cars & Trucks

Open Question

Defrost light flashing. No heat A/C blower Im freezing in Ohio

Heat And A/c are not working. No blower either, Ive tried disconnecting the battery, no luck. I tried two new relays for the heat ac circuit, no luck. Any help would be great. Im freezing in the north. thank you, Tim!

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: My AC/Heat fan is not working

my 06 h3 just had same problem, the motor control resistor pack was bad, located under glove box, mounted inside ac duct, large connector and two screws will remove it.
mine had burnt spot on connector,cleaned connector terminals and installed new pack, works fine now. I found your problem while looking for another elec problem i'm having.

Posted on Nov 20, 2008

Ad
  • 1 Answer

SOURCE: Front defrost not working 2004 Pacifica

I did not have defroster or venting to the feet. All I had was vent. I brought it to the shop they replaced the mode door actuator which flips the doors inside to make it flow to the defrost or vent etc; This cost me $210.00. They had to take the dash apart plus disengage the air bag under the steering wheel to get to the actuator.

Posted on Jan 03, 2009

  • 65 Answers

SOURCE: No air flow from defrost vent on my van.

Could be a vaccum line leaking not changing the vent flap to defrost

Posted on Jan 10, 2009

  • 2 Answers

SOURCE: new climate control unit but when on blower not working for heat or ac

I'm assuming the problem is the blower motor isn't coming on or working. 1st, check the fuse. 2nd, remove the glove box or pull the 2 tabs that act like stops when it's open ( the glove box will open out further) and you'll see the power plug connector for the blower unit. Turn on the blower through the climate control (heat, A/C, or whatever) and wiggle the connector to see if the blower turns on. If starts working, then an easy solution is pull the connector off and gently press the prongs together or inward. Then carefully reconnect with damaging the prongs. This worked for 96 Mark VIII due to the fact the prongs were not "seating" correctly in the female connector. It's been about 2 years since I did this and the connection is still good. If wiggling the plug doesn't work, pull the plug, turn on the climate control (heat, A/C), and check for voltage to the plug. That's about all I can help with.

Posted on May 28, 2009

  • 5 Answers

SOURCE: blower for AC/heat not working on Saab 9-3 ARC

that happened to me there is a i guess u can call it a fan cooler it keeps the fan from overheating and if that blows on a hot day it can mess up your blower moter but if its not workin at all you most likely allready did that for this job the blower moter is located behind the glove box if you not half dumb its a job u can do yourself and save a looooot of money on labor

Posted on Jul 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Kia Sedona 2012 minivan front heat and ac does not work while the rare heat, ac and defrost works


Are the controls lighting up? dose the blower motor work? If the controls don't light up you may have a control head locked up you can do a reset by unplugging the IOD fuse for 2 mins and then plugging it back in. If the all the lights work in the control head and the blower isn't working try turning the front blower on high and then tapping the motor itself if it works after hitting the motor you will need to buy a new blower motor.

Oct 20, 2014 | Kia Sedona Cars & Trucks

1 Answer

Heater blows no heat


  1. check to see if you have voltage to your blower motor with key on and blower motor switch selected to a speed setting
  2. if you have voltage, then your blower motor is faulty
  3. no voltage means that you have a blown fuse, bad relay, bad fan switch, or bad blower motor resistor.

Dec 10, 2013 | Cadillac Eldorado Cars & Trucks

1 Answer

Heat defrost nothing is working and burnt smell 1990 chevy caprice


if you mean no air is blowing,i'd say your blower motors cooked or heater panel blower switch/or blower resistor may have melted

Nov 22, 2013 | 1990 Chevrolet Caprice

1 Answer

1996 Ford Thunderbird LX - AC/Heating A few months back I had my AC recharged (At the time my heating still worked) and it worked fine for awhile, but about a month after that I would turn the defrost...


I'm afraid you have the deluxe system,my friend. It has 2 electronic circuit boards that may be going bad. Very expensive unless you can find used or aftermarket.
I hope it's just the blower motor, but I had the other thing happen and I had to wire around it,losing my AUTO temp and blower control. don-ohio

Mar 26, 2017 | 1996 Ford Thunderbird LX

1 Answer

My issue is with a 2001 Pontiac Grand Prix. The entire heating / ac / rear defrost unit has stopped working. In addition the day time running lights have also stopped working. Today in the middle of my...


about your heat i can help you i would say that for your heat the problem is the blower motor and maybe the resistor to so change those two parts and for your light im sorry i can help you good luck

Jan 06, 2011 | 2002 Pontiac Grand Prix

1 Answer

I have a 97 SIERRA. HEAT WORKS FINE ON DRIVERS


If you have climate controls that are "slide type" knobs...likely that the cable that controls the diverter panel in the blower box is broken....

Feb 27, 2009 | 2000 GMC Jimmy

1 Answer

Low voltage, turn signal, back up lights, rear defrost, and heat


replace the positive battery cable, trust me on this one have done dozens of 91 and 92's.

Jan 15, 2009 | 1992 Ford Explorer

2 Answers

Cant get heat to the inside


Have you checked to see if small vacuum line on firewall under the hood is a-ok ( no breaks or cuts) it's usually on passenger side and goes through the firewall to inside.
Also I think when the heater core goes out you have no defrost either so when it is cold and wet outside your windshield will fog up.Also did you check your fuses.

Nov 22, 2008 | 2001 Chevrolet Tracker

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

21 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexus Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

905 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Lexus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...