Question about 2003 Ford Taurus

1 Answer

New spark plugs. Runs like ****. Ran fine before

Just put new plugs in 2003 taurus. Immediatly afterwards car runs like ****. Bogs down when you step on the gas. Can get up to speed but very slowly. Checked to see if I dislodged a vacuum line, couldnt really tell. Feels like vacuum leak. can anyone help?

Posted by on

  • 1 more comment 
  •  Ben S.
    Ben S. May 28, 2009

    carbon deposits covered tip on hardest to reach plug. Caused plug to crack causing arch from jacket to head. thanks for all the suggestions guys, much appreciated.

  • Greg Bernett
    Greg Bernett May 11, 2010

    Awesome!!!! Great info for others!!!!

  • Greg Bernett
    Greg Bernett May 11, 2010

    Did you disconnect all the plug wires at the same time?



    Also, what type of plug did you install?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

Check to see if one wire one is bad or not making contact

Posted on May 22, 2009

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Recently changed spark plugs on 2003 kia spectra. Afterwards it started to sputter at low rpms. I changed fuel filter and it still sputters. When moving and over 1000 rpm it runs fine. What do I do?


get urself a can of carb cleaner...brake cleaner...whatevers clever
with the car running spray it over vac maf sensor...until you hear the engine bog down. now you found ur vac leak or anything else and leaking.

Feb 07, 2015 | 2003 Kia Spectra

1 Answer

1.3 1998 ford fiesta runs fine on tick over but missfires when under accelaration


usually a secondary ignition problem(coil pack, spark plug cables).

Apr 13, 2013 | Cars & Trucks

1 Answer

96 ford taurus ran fine yesterday go on 25 mile trip half way through trip engine runs ruff. Like miss firing just changed plugs about two weeks ago it idles ruff but runs doesnt stall at all. baffeled


sounds like spark plugs or spark plug cables are bad and it is in fact misfiring this happened to me in my car and my spark plug cables were bad

Aug 29, 2009 | 1996 Ford Taurus

1 Answer

Car runs fine for about 5 min then bogs backfires


have you had the catalytic converter checked?

May 13, 2009 | 1992 Buick LeSabre

1 Answer

2003 Kia Spectra Loss of power during exceleration


Hi,
The air cleaner mighty be clogged causing insufficient air supply. That is why it runs fine on idle because less air is needed and when the engine demands for more air, there isn't enough.

Jan 31, 2009 | 2003 Kia Spectra

1 Answer

98 taurus started ran a bit then died now wont start


If that is your only transportation you need to call other repair shops. Find out about towing fees and what diagnostic fees they have.

Before there were diagnostic scanners, there were Mechanics. Scanners come in all types and some will suggest possible solutions and others are tools which Mechanics use to find problems.

For instance, you are told you have fuel pressure. You are told they installed new spark-plugs. You were not told if the spark-plugs are getting electricity to fire. You were not told if the fuel injectors are getting electricity to allow gas to reach the cylinders. You can have fuel pressure but the fuel injectors must open to put gas into the engine.

A noid tester or plain testing light will show if the injectors are opening. A spray of starting fluid will also indicate if the engine is not getting fuel despite fuel pressure. It will try to run with starting fluid if it has spark.

When you find out whether it runs, if not, then check for spark if the starting fluid does not make a difference.

It is questionable whether new spark plugs were needed if installing them had no effect. Check other service places.

Aug 09, 2017 | 1998 Ford Taurus

Not finding what you are looking for?
2003 Ford Taurus Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...