Question about 1987 Nissan 300ZX

1 Answer

Distributor wont spark

The car cranked fine and then all at once it cut off and wouldn't start. I changed the ignition coil, distibutor, cap. rotor button, crank angle sensor, plugs, fuel pressure sensor, ignition module, & fuses but still no spark coming from distibutor. At a loss for what to do! 300zx

Posted by on

  • ghostriderch May 27, 2009

    So far none of these suggestions have worked so there has to be something that I have missed. I guess I'll keep at it though. Something will work soon I know it will. Thanks for the tips and I will keep you posted on this thing

  • Anonymous Mar 12, 2014

    I tried changing the spark plug detection sensor but it didn't work ,

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,605 Answers

Check the fuseble link.
you can measure it, and make sure the contact are clean and secured.
the other thing is the check the ignition switch, make sure you have 12v going to the switch.
check thermo switch on top of the block.

Posted on May 21, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine died while driving, no spark, replaced coil, now starts, idles, runs well at low rpm, but misfires when accelerating. No check engine costs thrown. What should I check next.


Change your ignition module. The distributor is a weak point of the Honda, I will always change out the whole thing than just try the coil.

Jun 05, 2015 | 1996 Honda Civic

1 Answer

No. spark will not start


check see if coil getting power.if no check ignition fuse if yes getting power at ignition coil.either ignition coil is bad or thick film module on distibutor faulty.ignition timing way off or you have worn distributor cap and rotor. worn spark plugs and wires.

Jul 10, 2013 | 1991 Ford F250

3 Answers

94 Acura Integra wont Start


jump timing loosen distributor and plus or minus turn and retighten

Mar 09, 2013 | 1994 Acura Integra

1 Answer

My 1985 Skyhawk won't start. Cranks well but no start


BAD COIL OR IGNITION MODULE INSIDE DISTRIBUTOR RUN OHM TESTS TO VERIFY

Dec 08, 2012 | 1985 Buick Skyhawk

3 Answers

No spark


First does the rotor turn when cranking engine?? possible timing chain is out or stripped gear..are you sure it has no spark??did you verify this with a high output spark tester ? did you spray starting fluid in the tbi unit ?

Mar 23, 2012 | 2000 Chevrolet Astro

2 Answers

96 jeep grand cherokee no start. Has no spark, replaced coil, still has no spark. fuses and relays in power distribution all good, also fuses in cab all good. no codes in ecm. plug at coil has...


the crankshaft position sensor located between flywheel and trans is where the power source for the coil comes from. I suggest you need change that

Sep 09, 2010 | 1997 Jeep Grand Cherokee

1 Answer

My 1990 sierra has a miss in it when i accelarate. I replaced plugs and wires but not the fuel filter or fuel pump.I also smell fuel outside between the bed and cab on the drivers side


Check out the distributor cap and rotor arm, - and make sure the plugs ar gapped properly - should be 1mm on 1.6 1.8, and 0.75mm on the 2 liter.
Check the oil level urgently, if it has been misfiring for some time you will have acuumulated all that unburnt petrol in the oil sump!!! (you can test this by getting a bit of oil from the dipstick and putting a drop on your fingers, rub together and sniff the oil, if it stinks of petrol change it -you need to change the oil filter too since it wil be full of petrol tainted oil also.
Once you are sure you have good oil and either it was ok after testing it from the distick "golden, clean oil" or you replaced the contaminated oil and filter you can move on to sorting out this misfire.
- You didn't mention if you checked or replaced the HT coil - Check for strong sparking from the main HT lead from the coil itslelf, Pull the lead from the centre of the distibutor cap - have someone crank the engine while there is a "spare" sparkplug in the main ht lead (ground the plug to the engine, holding the rubber insulation of the cable with pliers - Use a normal HT lead if the main coil lead wont reach a suitable grounding point with the sparkplug) - check for solid bright blue spark, it should be regular timed, and strong EVERY time - any missing or weak sparks indicate electrical problem either - the coil is failing - or the battery is weak - or the distributor is faulty. - a faulty distributor would be expensive to replace and more so to repair, a reconditioned distributor costs around £120.
for now I assume the coil checked out fine and gave a strong steady uniform set of sparks. ----------------------- With a fully functioning coil, you're left with the distributor cap and rotor arm - the distributor cap comes off with 2 screws at the left and right sides of the cap between the HT Connectors - unscrew them - (note the original orientation of the distributor cap before you pull it off to aid refitting) you can now pull away the cap from the rest of the distributor.
INSIDE the CAP there are four "poles" round the outside, and a spring mounted contact in the center - make sure the poles are clean and shiny with only light markings at most, if they are blackened, whitened ro rounded and pitted then replace the cap - ford dealers or local part shop, most shops will stock both the rotor arm and distributor cap for around £15-30 - phone around for the best deal.
Still on the distributor is the rotor arm, this pulls off - it has to be pulled dead straight off the distributor shaft - once you have the rotor arm off you can inspect the metal contact on the top for general dirtiness and decay, it "should" be shiny brass/copper in colour. if it looks pretty bad, pitted or blackened/burned- - get a new rotor arm from ford dealers or from local part shop (not expensive)
Once you are sure of a clean or new rotor arm and distributor cap you can try the engine again - hopefully the misfire is gone.
If it is still there....
we are here

DISTRIBUTOR CAP - FINE ROTOR ARM - FINE OIL + FILTER NOT OVER LEVEL + CLEAN, NO PETROL IN IT HT COIL - GOOD STRONG REGULAR SPARK. -----

If it still misfires with all these things in perfect order then you are left with: Clogged Fuel Line/Filter or Failing Fuel Pump or Ignition TIMING - ( 10-12 degrees BTDC) have igition timing checked and set if not correct. OR... Faulty Distributor - pretty much worst case scenario. Tell me how you get on - Often it is the distributor cap and rotor arm - If not I hope its the fuel filter!
Good luck,

Jan 22, 2010 | 1990 GMC Sierra

1 Answer

Van will not start I have fuel pressure and when cranking it builds oil pressure where do i go from here


Check for spark at the spark plugs. If no spark, remove distributor cap and inspect the inside of the cap and the rotor for obvious signs of wear or damage. Check for spark at the coil wire by removing the coil wire from the center of the distibutor cap, and, holding the end of it close to the engine block, have someone crank the engine. There should be a very strong spark. If there was spark at the coil but not at the plugs, replace the distributor cap and rotor. If there is no spark at the coil, you either have no power or ground at the coil, or the coil is bad. With the ignition ON, there should be 12v at the red wire for the ignition coil. if not, check the fuses. Check for the pulsing ground signal of the ignition coil at the other wire ( I think a white wire) using a test light clipped to battery + while the engine is being cranked. If there is no light, the problem is likely the ignition module or pick-up coil, which is located in the distributor. Make sure that the wiring and connections are in good shape for these items before condemning them.
Pick-up coil should have about 1500 ω of resistance.
Good Luck

Sep 30, 2009 | 2003 GMC Safari

1 Answer

There is no spark. replaced distributor (coil) cap and rotor


You may have to check loose cables or wiring. Inspect the ignition coil, it should be in series with the distributor.

Aug 20, 2009 | 2001 Nissan Altima

1 Answer

No spark from ignition module on hot start


95 JEEP WRANGLER 4 CYL

No spark. I have changed out the distributor cap, rotor, wiring from coil to cap, and coil was replaced. I checked the distibutor by turning ignition key and observing the rotor turn. What else can I check. I did not observe a module.

Jun 19, 2009 | 1995 Jeep Wrangler

Not finding what you are looking for?
Cars & Trucks Logo

485 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...