Question about 1992 Buick LeSabre

1 Answer

The radio and heater have no power. everything else seems fine

The car was fine, heard a pop. and the heat and radio went out everything else is working, everything is electric

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Expert
  • 90 Answers

Could be fuse under dash check all fuses in the fuse block.

Posted on Jan 02, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

While I was running my a/c and radio I heard a pop noise and my radio went off and now there is power to radio. Fuses are checked and look OK. My question is what else could it be 2010 jetta tdi


Radio died. Capacitors in the radio can make a popping noise. Usually once. If heard threw the speakers it could be one of many electronic parts in it.

Aug 20, 2016 | Cars & Trucks

1 Answer

Radio and heater/fan not working


check fuse or breaker...see owner's manual for location

Jan 20, 2014 | 1995 Toyota Avalon

1 Answer

A spark came from interior fuse/relay panel. After that nothing seem to be working on the interior fuse/relay panel. I check all of the fuses, and all seem to be in working order.. What else could be


First you need to remove whatever you added to the fuse panel, then check the mega fuse in the underhood fuse panel, you may have blown that. Below is a picture of its location. If it is OK, you will need to have a professional diagnose your electrical system.

1_2_2013_8_31_10_pm.jpg

Dec 31, 2012 | 2004 Chevrolet TrailBlazer

1 Answer

My 1998 Deville lost all power to the A/C and Heater


Could be a fuse or the ac control module. I would check the fuse first.

Sep 25, 2012 | 1998 Cadillac DeVille

2 Answers

1999 Crown turned ignition switch to start - heard pop - no electrical power


If nothing works including the lights, something happened between the battery and the fuse box.
There are some fuseable links between the battery and the starter solenoid or between the solenoid and the fuse box.
I'd start with the battery cables and look for those fuseable link wires.

Jul 09, 2012 | 1999 Ford Crown Victoria

1 Answer

I just went outside to crank my car to leave but when i turned the ignition over my car wouldnt start. The lights,radio and everything else is working fine except for some crazy things that popped up on my...


It sounds like the car is still in gear make sure it is set all the way to park, this will give you the same problems. If this does not help repost.

Mar 30, 2011 | 1999 Pontiac Grand Prix

2 Answers

No heat from heater.water level is full thermostat is working & there isn't an airlock. AC works fine control switch seems to be OK. Can tell slight difference when switching from cool to heat, only...


Seems like you have checked everything. Now you can basically pinpoint the heatcore as the problem. They do go bad. No heat in car, this would be your problem

Dec 13, 2009 | 2001 Chevrolet Blazer

1 Answer

Dash lights


From the dashboard. 2 days prior to this my Airbag light fuse went out, I replaced it and now it works fine again. I am not sure if they have anything to do with eachother.

Oct 14, 2008 | 2005 Jeep Liberty

1 Answer

Radio cracking/no sound


I disconnected the amp and ran jumper wires between the two harnesses basically creating an amp bypass everything now works fine.

Jul 14, 2008 | 2002 Chevrolet Monte Carlo

Not finding what you are looking for?
1992 Buick LeSabre Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...