Question about 1997 Mercury Villager

1 Answer

The car won't accelerate and the engine backfires.

I have a 1997 mercury villiager that won't accelerate and the engine backfires. I had the alternator, spark plugs, the coolant temperture sensor, the oxgen sensors, the distributor cap changed and now i'm having this problem.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercury Master
  • 2,007 Answers

If you haven't changed spark plug wires, do so. If you have, then check your timing / timing chain and check for vacuum leaks, or your egr. Good luck! let me know how it goes.

Posted on May 21, 2009

  • gerry bissi Oct 26, 2011

    clean the short heater wires inside the MAF sensor on the air intake tube. Use spray MAF sensor cleaner or carb cleaner. Do not touch the wires.
    join villager quest yahoo owner group for more help.

    gerry

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why my 5.7 backfires and misses at acceleration


it look like spark plug defect or leak at spark plug wires
misfire Under load if you don't have any engine code malfunction

hope it helps

Oct 10, 2014 | 1997 Chevrolet Tahoe

1 Answer

Can't find crank sensor on 94 mercury villiager


The van uses a distributor, and the crank sensor is inside the distributor.

Jul 03, 2013 | Cars & Trucks

1 Answer

Engine stalls on acceleration and at times will not start


engine surges stall on acceleration could have faulty tps sensor.could have bad spark plugs or wires.could have clogged fuel injectors or clogged fuel filter check fuel pressure fuel pump could be failing.

Jan 03, 2013 | 1997 Mercury Grand Marquis

1 Answer

Engine light on, vehicle usually won't start. engine light code is o2 sensor


The oxygen sensor won't stop it from cranking or starting

Check for spark or injector pulse when cranking

Check fuel pressure at the motor shrader valve with a gauge
KOEO

Dec 08, 2012 | 2000 Mercury Mountaineer

1 Answer

My 1997 mercury cougarxr7 will not accelerate when i give it gas


Well it could be the throttle position sensor or a vac leak, but I would check the fuel pressure. A faulty sensor should turn the check engine light on.

Aug 25, 2012 | 1994 Mercury Cougar

1 Answer

Where is the coolant temperture sensor located on a 2002 mercury grand marquis, as Im getting OBD codes PO1299 and PO340


po340 is a camshaft position sensor code depending on what engine is in your vehicle sensors are located in different places you'll probably need a service manuel

Jul 30, 2012 | 2002 Mercury Grand Marquis

1 Answer

My 1997 ford thunderbird stalls, idles rough, backfires, and has trouble accelerating


it could be as simple as your spark plugs, they may need to be checked for proper gaping and also check to make sure plugs are installed properly, could also be your timing might be off, could also be the throttle position sensor, these could all be effecting the fuel to air ratio, I would start with the easiest problem 1st......hope this was of some use to you.....

Jul 08, 2012 | 1997 Ford Thunderbird LX

1 Answer

Low end backfire and slow acceleration


its drawing too much air in to the intake bypassing the injectors/air flow sensor check the inlet manifold gasket and all the seals like injector seals or gaskets etc

Jan 22, 2018 | 1997 Ford Explorer AWD

1 Answer

I have a 1997 Jeep Cherokee Sport 4.0 I6 with about 155k miles that is having intermittent issues. I just recently had to replace my muffler because of the car backfiring. This problem doesn't happen...


Have it checked with a computer diagnostics. It sounds like it could be a bad sensor, quite possibly your oxygen sensor. A bad sensor could cause the computer to think your engine needs more fuel.

May 27, 2011 | 1997 Jeep Cherokee

2 Answers

Why does my 1993 mercury grand marquis backfire and cut out when I accelerate?


Try changing the fuel filter. Sounds like fuel restriction or exhaust restriction. It's also possible the timing chain could be loose especially if an high mileage engine. Fuel filter first & go from there. Good luck!

Feb 20, 2011 | 1993 Mercury Grand Marquis

Not finding what you are looking for?
1997 Mercury Villager Logo

312 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

fordexpert

Level 3 Expert

5687 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...