Question about 1996 Dodge Ram

1 Answer

Transmission i have a 96 dodge ram 1500 with a 5.9. it was running fine after a reinstall adn now it will try to start off inb 3rd or will lag when shifting from 1st to the rest fluids are good and new filter. any suggestions

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 115 Answers

Check for codes, it sounds like the govenor pressure sensor maybe your problem.

Posted on May 25, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1997 dodge ram 1500 4x4 abs light on runs fine idles good but put it into gear wont go past 35 mph engine running smooth even at 35 mph


Bernard's Blog: Dodge Transmission Output Speed Sensor

bernardsblog.blogspot.com/.../dodge-transmission-output-speed-sensor.h...
Sep 8, 2009 - My 99 Dodge 2500 Ram won't accelerate..transmission is NOT slipping,.... It has been running fine and the check engine light even cleared itself yesterday.... So it wouldn't go into first gear and then 3 minutes later my check engine ... I have a1997 Dodge Ram 1500 with a 5.9L instead of the stock 5.2L. It ...

Dodge Ram Idle and Stalling Problems - Car Forums at Edmunds.com

forums.edmunds.com > Dodge > Dodge Ram Pickup 1500

Aug 17, 2011 - 30 posts - ‎25 authors
Learn more about Dodge Ram Pickup 1500 at the Edmunds.com ... The crank sensorwas put on however it started stalling again. ... The truck starts fine, but will only runat 2000's RPM and only then if .... Then as I start driving about 1/3 of a mile go dead again, I knockout of gear, crank back up immediately.

WILL NOT GO OVER 30MPH WITH PEDLE TO METAL ...

repairpal.com > Questions > Dodge > Charger > 2006 Dodge Charger
I WAS DRIVING FINE AND THE CAR ACTED LIKE IT GOT STUCK IN ... Then the transmission didn't want to change into 2nd gear. .... Whenever i start up my car theabs and esp light turn on and when i try driving it doesnt go over 30 mph even .... in neutral but not it just wont go up hills and i think it has something to do with

Jan 07, 2016 | Dodge Cars & Trucks

1 Answer

1996 dodge ram 1500 4x4 low voltige to transmission


If you only have 5 volts you may have a bad battery or alternator. Or maybe a B+ (battery positive) wire short to ground. Check voltage engine running at the battery then alternator +. If your voltage is that low your TCM won't work.

Jul 28, 2012 | 1996 Dodge Ram 1500 Club Cab

1 Answer

96 Ram 1500, 5.9 litre. code PO138 sensor circuit


it will be the o2 sensor after the cat.. check the connections. the first bank should be the right side of the engine while sitting in the car. look at that side of the exhaust.

Jul 20, 2010 | 1996 Dodge Ram 1500 Club Cab

1 Answer

My transmission is not shifing right


With truck running check transmission fluid level add if low

Jul 10, 2009 | 1999 Dodge Ram

2 Answers

Transmission swap


94,95 are the same 96-99 are the same. the 94-95 models have a 4 pin connector as the 96-99 have a round 12 pin connector. Hope this helps

Jan 30, 2009 | 1997 Dodge Ram 1500 Club Cab

9 Answers

1996 Dodge Ram Transmission shifting problem


I had the same problem with my 96 Ram 1500. I thought I was going to have to pull it out and get it rebuilt or just replace it. That was at 134,000Km it's now got 210,000 and shifting like a dream. What I did to solve the problem was this, as follows:
1. No lucas transmission Fix makes things worse.
2. Get your self a new transmission filter and gasket
3. Grab Gunk transmission medic 12oz
4. Grab 7 Liters of Valvoline ATF+4 transmission fluid (Made for chrysler transmissions)
5. Drop the trans pan and drain all the oil, clean pan and magnet
6. start truck for 5 seconds and the pump will pour out another 1 liter
7. re-install filter, gasket and pan, then add your Valvoline ATF+4
8. Add, the valvoline, transmission medic and make sure you have the right level of fluid

That solved my transmission problems, instantly it was shifting better, I no longer had to let off the gas to make it shift. Now if you have large pieces of metal on the magnet, and it's totally covered in filings, you might want to consider rebuilding the trans. My magnet had usual clutch.         

Anyhow good luck, let me know if it did the trick for you.
Justin

May 16, 2008 | 1996 Dodge Ram

Not finding what you are looking for?
Cars & Trucks Logo

205 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8202 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...