Question about 2003 Dodge Ram Maxi

1 Answer

Engine running rough

Filled up with 1/2 tank of gas to top off the tank for a trip. Ran great for about 30 miles, then it started running rough and finally stalled. Got it started but it idles rough and hesitates at acceleration. Did a diagnostic code and I get a P132 reading

Posted by on

  • smithson_ter May 20, 2009

    where is the fuel filter on the engine? and it was a P0132 code

  • smithson_ter May 20, 2009

    and its a 2003 dodge ram 1500..5.7 hemi. does thsi still apply?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 81 Answers

It sounds like maybe yu have a fuel filter that getting plugged up.
To check this, see if you can remove it from the engine, then very carefully blow thru it in the direction the fuel travels, if clean you should be able to blow thru it easily, if not then replace.
The P132 is (E132) .................. Knock Sensor Circuitry Failure .... The knock sensor is what prevent engine ping from low octane. ...
It could also be you just got some bad gas.
You also might try topping off the tank with gas from another place and bring the octane level up if that is the problem.
Hope this helps
Good luck

Posted on May 20, 2009

  • Keith Petersen May 20, 2009

    It's on the drivers side upstream, had that same code on the same truck today at work. There's an access panel in the drivers side iiner fender well, The hardest part is getting the connector unplugged from the top of the tranny, My customers truck had 2 broken wires at that connector, the sensor was okay, Pretty common for wiring issues up there, be sure the 02 sensor fuse(s) aren't blown as well. Good luck and keep us postted
    The above is for a 2003 Dodge Dakoda, not sure if this applies to your rig or not, but this is for the code PO132, this code is a response to a bad censor on the vehicle.

    As far as the fuel filter, look for a steel tube line that runs somewhere on the top of the engine to the carburator or fuel injection system, once you find the correct tube or fuel line just backtrack until you find the filter. Now some vehicles have the fuel pump and filter in the fuel tank, if thats the case your not going to be able to find it. Most of the newer vehicles have them in the fuel tank and its pretty uncommon for them to plug up, the fuel pump usally goes first.

    I'm thinking that your censor is bad or has a broken wire as decribe above.

    I hope that this has been of some help for you.

    Good luck

  • Keith Petersen May 20, 2009

    I think that its probably very similar on your vehicle.

    I hope this was of some help.

    Good Luck

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ran out of gas in 2003 Mitsubishi galant . Filled tank with gas & added fuel injector cleaner. Car is jumping & jerking like it was when it ran out of gas. Still runs rough even after using 1/4 tank of...


Change your fuel filter. Running the tank empty will pull any sediment that has accumulated in the bottom of the tank into the fuel system. There is a good chance your filter is clogged and not letting enough fuel to the engine.

Aug 23, 2014 | Cars & Trucks

1 Answer

Rough idle in park


Do you have a check engine light on? Is the engine misfiring?

Jan 13, 2014 | 2011 Mazda CX-9

2 Answers

I have a 1999 suburban with 5.7 approx 186 k it sat for a year due to selector problem in the column and had it replaced with a used unit. after getting it where it would start, it started running very...


Should have drained the tank. Not only was it old gas but it may have had some condensation in it.
Now that you have a Check Engine light, hook up a code reader and see what code(s) are there. Then you can get back here and I'll see what I can do to lead you in the right direction.

Sep 01, 2011 | 1999 Chevrolet Silverado 1500

1 Answer

I have a 1998 Dodge Caravan. I got a "tune up" approx. 2 weeks ago with new spark plugs, fuel filter & air filter. It did fine driving around town & on a 130 mile trip. I filled up with...


Sounds like you got a tank of bad gas. That would easily cause your issues. Start by draining as much as you can, put a can of Seafoam in there, add a few gallons of fresh gas, drive to the gas station and tank up, and run that tank down until your gas light comes on before adding more. You may end up needing a fuel filter or plugs again, but with minimal run time on the bad gas, you'll probably be fine.

Jul 29, 2011 | Dodge Caravan Cars & Trucks

1 Answer

Recently during a cold weather spell we traveled about 50 miles to my dads and during that trip my Jeep was running rough when setting the cruise and running about 70 mph on the eway. We added dry gas and...


Well the on/off method sometimes is not Correct.I would suggest you to take it to an auto part store and have them scan it for you for free and they will tell you the exact code with the OBD2 then you can start from there.Good luck

Dec 15, 2010 | 2002 Jeep Grand Cherokee

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

1 Answer

Black smoke when i start engine, very rough idle.


sounds like possible a sensor went bad or is loosly connected. O2 sensor??? Also check the air filter. Sounds like whatever it is, is making the truck run rich----that would be the black smoke.


Hope this helps

Aug 08, 2009 | 1999 Ford Super Duty F 450

1 Answer

Engine runing rough


This code is most likely not related to the problem, it sounds like you may have picked up some contaminated gasoline, maybe has water in it or other like dirt.

May 20, 2009 | 2003 Dodge Ram Maxi

1 Answer

Rough running 86 4runner after e85 put in!


very likely the fuel injectors are damaged, replace them, the fuel pressure regulator and all rubber fuel lines, also pull the gas tank and replace the short rubber hose at the electric fuel pump, I know this is expensive but even a few miles of running would have wrecked havoc on the rubber components, that rubber debris will flow through the fuel system and will plug the injector's, E85 melts it and skin for that matter.

May 05, 2009 | 1986 Toyota 4Runner

Not finding what you are looking for?
2003 Dodge Ram Maxi Logo

423 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...