Question about 1999 Mercury Cougar

1 Answer

Replaced altenator twice and its still bad - 1999 Mercury Cougar

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Mercury Expert
  • 412 Answers

Check the battery cables and engine to chassis cable for voltage drops. You have either a cheap crappy rebuilt alternator or a problem with connections causing the alternator to go bad. Make sure the battery is tested properly.

Posted on Jan 01, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery not charging showing on the display for the second time after I changed the battery once and the altenator twice. What could the problem be?


Take a good look at the alternator plug. The tabs on the inside should all look the same. Also a lot of corrosion can cause no contact. Replace the plug if necessary.

Feb 07, 2015 | 1999 Cadillac DeVille

1 Answer

Replaced alt twice in two weeks


I had the same issue a month ago. i'm not a mechanic. i took it to the local garage, and they replaced the alternator. when we picked it up, hte light came back on. he said it was the control module and asked us to go the dealer. the dealer replaced the alternator with an OEM altenator and it has worked since. was the first replacement bad or is the OEM different. not sure...but it has worked since

Sep 03, 2012 | 2002 Buick Rendezvous

2 Answers

My battery light lit up on dash of my 2008. Mitsh. lancer gls cvt....what does that mean?


Altenator is not charging the system. It could be the altenator, regulator (built into the altenator), A loose wire (bad connection). There is a plug on the altenator that signals this light when a problem occurs. start the car and wiggle it or unplug it and plug it back in, this will tell you if you have a bad connection. To check the altenator you need a voltage tester.

Jun 10, 2011 | 2006 Mitsubishi Galant

1 Answer

My charge systems light came on twice and stayed on car drives fine. Not sure what could be happening?


Sounds like the altenator is going b ad or is already bad have your charging system checked.

Feb 15, 2011 | 1997 Oldsmobile Aurora

2 Answers

Just got new battery but the batt. light is on.I also got the alternator tested and it was good


Check all connections and especially the ground connections...there should be two ground locations one at the engine block and one at the body

Jan 23, 2011 | 2001 Chevrolet Venture

2 Answers

2003 Jetta GLS (not TDI) alternator replaced twice in 2 weeks. WTH?


If the problem was in the alternator, the battery would have been discharged and you would not have been able to restart the car (unless jumped, but not have run for more than a few minutes before shutting down again) So, my answer: No.

Jun 02, 2009 | 2003 Volkswagen Jetta TDI

1 Answer

Voltage drop


had some help here ,everything is pointing to the altenator .Sorry to say after you have changed it twice but i think you have been unlucky and replaced the unit with one with the same fault ---was it a new one or scrapyard ?? start engine and then hold rpm at 1500/2000rpm and disconnect battery if engine continues to run then altenator is charging ,now turn everything electrical on and see if engine continues to run ,if it does then altenator is ok ¿¿¿¿sort of ??.Right now stop engine .Leave overnight and see if it starts (battery disconnected) if engine starts ok then it could be one of two faults,firstly a diode is faulty in the altenator ??or a DISCHARGE like a boot light on ??big amp in the boot for music left on? anything stupid in fact .Quick one here is if after following my advice then not sure ,disconnect altenator and leave battery connected ,if it then goes flat then it something on in the car with a drain of more than 21watts .Divide volts into watts gives you the amperage being drawn.If it starts then its the diode pack in the altenator.Best of british with it .

May 30, 2009 | 1994 Ford Thunderbird

1 Answer

My honda prelude stalled an now the stater is makins a funny nois and the moter wont turn over wat do i do


sounds like you have a dead battery and possible a bad altenator have the battery checked out and replace if bad. If not recharge and if the car starts have the charging system checked out you may have a bad altenator or voltage regulator probably built in the altenator. Possibly the starter but not likely since it stalled while running.

May 19, 2009 | 1991 Honda Prelude

1 Answer

Battery or altenator


with the engine idling, check the voltage at the battery terminals. if its between 13 and 14.6 volts the alternator is probably ok. If its below 13V you need a new alternator. above 15V same thing.
Why did u think it needed repair? is your battery not holding a charge?

Jan 07, 2009 | 2005 Dodge Caravan

1 Answer

Car shutting off while driving


have you checked fluid levels. sometimes when they get way low, the check engine light will come on and the engine will go into self protect mode. when you replaced mass air flow senser did you clear the codes in the ecm(engine control module)? if the codes were not cleared the computer still thinks you have a problem and will try and compensate for it which would cause the rough running. one other reason might be that you have a loose ground and or positive battery cable. one quick check you can do is with the car running remove the positive battery cable if the car dies the regulater inside your altenator is bad and because the regulater is intergrated wioth the altenator you will have to replace the altenator completely.... rate this solution......thanks

Aug 31, 2008 | 2002 Pontiac Grand Prix

Not finding what you are looking for?
1999 Mercury Cougar Logo

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

fordexpert

Level 3 Expert

5546 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...