Question about Isuzu Rodeo

1 Answer

Cant accelerate past 4,000 rpms

It starts acting like im running out of fuel, starts missing till i let off the pedal (about half way)In neutral i can rev it to around 7,000. If u try to pass anybody or get on the fwy it slows down . Below 3,000 rpms it seems to run fine . Im sure its something im over looking .

Posted by on

  • 1 more comment 
  • Paul
    Paul Dec 31, 2013

    well i know its not the catalytic convertor , i removed it when i got the truck. (thought it was part of my original issues) when temps get a little warmer i'll change fuel filter again & go from there. Thanks

  • irad Dec 31, 2013

    How many miles on the fuel filter? If not much them it could be the MAP.

  • Paul
    Paul Jan 02, 2014

    Changed the MAP , still has the same issue

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 161 Answers

Intake leak of bad mass airflow sensor. You can clean a MAF.

Posted on Dec 31, 2013

  • 10 more comments 
  • Paul
    Paul Dec 31, 2013

    So you mean my map sensor could be bad ? It dont have a MAF

  • irad Dec 31, 2013

    What year car? 1996-2004 have a MAF. And there is a typo of should be or

  • Paul
    Paul Dec 31, 2013

    sorry its a 94 Rodeo 3.2 v6 4x4 auto.

  • irad Dec 31, 2013

    You are right, a 94 has a map. I never sucessfully cleaned a map. When I tried I ended up replacing it. Check for intake leak. Check if fuel filter is clogged. Could also be a clogged catalytic convertor. I'd check these possibilities before I start replacing parts.

  • Paul
    Paul Dec 31, 2013

    well i know its not the catalytic convertor , i removed it when i got the truck. (thought it was part of my original issues) when temps get a little warmer i'll change fuel filter again & go from there. Thanks

  • irad Jan 02, 2014

    How many miles ago did you change the fuel filter?

  • Paul
    Paul Jan 02, 2014

    id say maybe 2,000 miles ago. thinking maybe i got some bad gas

  • irad Jan 02, 2014

    I would not change the fuel filter. Check your fuel pressure regulator to see if it holds vacuum. Maybe it is not allowing enough fuel into the injector rail. The other thing to try is put a can of Berryman's B12 cleaner in your gas tank. It cost about 3.25 at Walmart.

  • Paul
    Paul Jan 03, 2014

    well come to find out i had some bad fuel lines . The rubber hoses felt like gummy bears . lol

  • irad Jan 03, 2014

    When you change the fuel line let me know if that fixed the problem

  • Paul
    Paul Jan 03, 2014

    i changed a section yesterday . Had truck out last night . Running great ! Ty u for the help

  • Paul
    Paul Jan 03, 2014

    soon i'll be replacing all the rubber hoses. !

×

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 17 Answers

SOURCE: 1991 F-250. feul injected 460 w/c6 tranny. acts

Hello. katienjoe. the fuel line from the filter to the fuel rail has a restrictor in the line its at the fitting at the rail. the opening messures 3/16 of a inch. so loaded it doesn't pull above 50 mph. you can change the line I did on mine the hot rod shops can supply what you need.

Posted on Sep 17, 2009

junkman1249
  • 552 Answers

SOURCE: My '05 Buick Rendezvous runs smooth and starts

maybe your catylitic convertor is cloggin up

Posted on Oct 22, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Grinding noise at high rpm


Have you had fuel pressure tested, as well as exhaust for possible plugged catalytic converter?

May 20, 2014 | 2004 Kia Sedona

1 Answer

Misses when accelerating


sounds like the lambda sensor or crank sensor. does it work fine from cold?

Mar 11, 2014 | Nissan Pickup Cars & Trucks

1 Answer

95 T-bird LX, V-8 hesitates after a soft stop, some turns, after small climb and after a bump or crossing tracks; try to accelerate the rpms whip up past 3-4 car is not moving, what's up with that


sounds like low idle control sensor ! when car acting up could sstop by parts house get them to plug computer in and see if any codes have been stored even though the engine light not on at this time

Sep 03, 2012 | 1995 Ford Thunderbird

1 Answer

2004 Ford F250,6.0 Deisel .When starting cold,won't turn above1500 RPM,without choking out black smoke,hacks and coughs till back to idle then idles fine ,not drivable till idles for half an hour,will not...


Ford 2004 6.0, Driving down road seams like when it starts warming up it starts Missing or accelerating,jerking,as long as you keep the acceleration it seems to work as soon as you level it out it starts missing,even dies at stoping sometimes...Changed fuel filter, put fuel additive in tank still missing,HELP

Jan 02, 2010 | 2004 Ford F250

1 Answer

Car stalls when stopped, cuts out when accelerating to HWY spds.


You could have a bad or intermittent fuel pump. Not a cheap thing to have.

An OBD 2 scanner can read fuel pressure on the drive to see if your fuel pressure drops off at odd times to confirm. It can also tell if there are transcient vacuum leaks at idle which the engines idle air control cant compensate for.

Do the plugs, wires and cap too.

Dec 12, 2009 | Chevrolet Malibu Cars & Trucks

1 Answer

Idling lower than 1,000 rpms. at high speeds,


Had a firebird act similar to that had a bad coil pack replaced it the spark plugs and wires and ran fine.

Oct 13, 2009 | 2005 Volkswagen New Beetle Convertible

1 Answer

1991 F-250. feul injected 460 w/c6 tranny. acts like it is missing when engine runs at 3000rpms. accelerates just fine and runs wonderfully below 2900 rpms. just when i try to plane out around 70 mph the...


Hello. katienjoe. the fuel line from the filter to the fuel rail has a restrictor in the line its at the fitting at the rail. the opening messures 3/16 of a inch. so loaded it doesn't pull above 50 mph. you can change the line I did on mine the hot rod shops can supply what you need.

Sep 14, 2009 | 1991 Ford F250

1 Answer

Miss fire and lean codes


i have lost my mobile

Apr 17, 2009 | 2004 Audi A4

2 Answers

1996 3.8 Camero stalls


check your fuel pump. or fuel filter it needs one or the other thanks hope that helps you out I am sure it will

Jun 23, 2008 | 1996 Chevrolet Camaro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Steve Hurc
Steve Hurc

Level 3 Expert

450 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...