Question about 1987 Chevrolet S-10 Pickup

1 Answer

Our Chevy 1989 S-10 seems to run good until we put it in gear, and try to drive. For awhile it was doing fine as long as we put a little pressure on the gearshift so it was at the top most part of drive. Now even that doesn't seem to work anymore. It seems as though it is draining everything to try & go. The lights & everything dims & the gas gauge reads full even if it isn't. If the gas gauge reads the right amount I know the gear is in the right place & the truck will go.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 2,007 Answers

I think the firstr thing you should do is check for loose ground wires, and wires that are being pinched. Check your battery cables for tightness on both ends. It seems like something is shorting out when your engine tips when you put it in gear. Check all the wires that are anywhere near the transmission. Good luck.

Posted on May 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I can shift into drive but it won't engage


sounds like a broken shift cable. (the connection between the shifter and the gearbox) common symptoms are the shifter move easier than normal.and does not move to any gears (not even park or neutral).

Nov 23, 2013 | 2004 Chevrolet TrailBlazer

1 Answer

97' olsdmobile lss shuts off while driving. not


I know its a pain but i would drive it with the fuel pressure gauge on it and see what fuel pressure is at when it stalls also scan it for dtcs and if none found suspect crank sensor

Dec 10, 2012 | Cars & Trucks

1 Answer

1991 chevy c1500 stalling


Usually a problem with a dirty throttle body or a faulty idle air control valve. The computer controls idle speed by regulating how much air enters the intake thru the valve.

Oct 13, 2012 | 1991 Chevrolet C1500

1 Answer

Low fuel pressure 99 cherokee classic


either fuel pump but change fuel filter first and see if it helps

May 13, 2012 | Cars & Trucks

1 Answer

My 95 buick park avenue runs good when driving 55 but when going up a slight incline or giving a little more gas it starts to run jerky or missfire until you give it enough gas for the trans to downshift...


Could be in need of a tune up or you could have a bad coil pack. Start it up at night with the hood open and see if you see anything arching from the coil packs or any plug wires. Also could be a fuel pressure problem but slightly more unlikely you can use or put a deposit down and take home and use a fuel pressure gauge at Autozone or O'Reilly's, and they can look up the psi of fuel pressure you should have.

May 16, 2011 | 1995 Buick Park Avenue

1 Answer

Constantly shifts from 2nd to 3rd gear


sounds like you need to eithor add fluid or have the filter changed
try checking the fluid if burnt it needs a rebuild if just dirty probably needs a filter and fluid change

Aug 03, 2009 | 1999 Dodge Ram

1 Answer

Running rough and wants to die


Have the fuel pressure at the fuel rail checked. If you just want to throw parts at it: Fuel filter by the tank first. Fuel pressure regulator next. Order of ascending expense and likely hood. Does the fuel pump hum louder lately? The fuel pump may be on it's way out. It's not getting enough fuel to do anything but idle. Why that is takes some investigation. Somebody like Auto Zone may check your fuel pressure. If the fuel pressure is good, bad spark plug wires are the next guess. Lift the hood and run the engine in the dark (take the light bulb under the hood out if it still works to do this) If you see little lightening bolts traveling over the engine you need new plug wires. If the fuel pressure is good, the wires are good, change the spark plugs. Good Luck!

Jun 08, 2009 | 1995 Chevrolet Tahoe

1 Answer

O2 sensor problem, running rich. Please help


was the code for rich or lean? may try cleaning mass air flow sensor. it is in the air intake tube and has a flat wire connector. take out of tube and take four torx bolts out and clean with mass air flow cleaner or brake cleaner and put back in when dry. or it could be a bad wire on the o2 harness. look for chaffing or broken wires in harness by o2. also could be the exhaust system has a slight blockage. could also be some other things but try these first.

May 07, 2009 | Chevrolet Silverado 2500 Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...