Question about 2001 Audi A4

2 Answers

2001 audi a4 CEL came on

Hello i have a problem with my 2001 audi a4 1.8t quattro ...my engine check light came on flashing and the car run really rough and engine shaking like 1 of the cylinder is misfiring,,,the strange part is sometime it stays on steady and the car runs fine...very strange i had 3 coils change but 1 i havent change yet. could that last coil i havent change causing this problem ,,,i borrow obd2 from friend had code reading a misfire on cylinder #4 ,o2 sensor,ignition module and thermostat sensor ....so which of this is causing the misfire or CEL coming on.. i do not want to go to the dealer to fix .dealer will clean me dry...please i need some advised on what i should do.

Posted by on

  • 5 more comments 
  • badben360 May 20, 2009

    ok i replace all the spark plug and the final coil,,,the engine light was still on ,,but after a start the light turn off ..is that normal..and one more thing when i was stop at a light my rpm jump up and down alittle but when i drive the car is fine .

  • badben360 May 20, 2009

    Ok the light came back on again.....seems like it comes on whn the car is hot ....but something is really weired when im driving feels like theres no power then after a feel press on the gas petal it goes ..and the lights go on when i am stop and it goes off when im driving ...

  • badben360 May 21, 2009

    will the ignition module have anything to do with this problem?

  • badben360 May 21, 2009

    i just had the code check again it was reading P0300,P0301,P0303,P0304,,,,very strange i just change coil #4 and all the spark plugs ..maybe i should try changing the wires ...oh ya i also put in a bottle slick 50 fuel system formula yesterday.

  • badben360 May 21, 2009

    ya it was originally #4 every cylinder except #2 ...ya when i press the gas petal it hesitate alittle then it moves. ya when coming to stop the car has rough idling and the light flashes..and when driving still alittle rough but the light will shut off

  • badben360 May 21, 2009

    gets better just when the CEL comes on it runs rough..when the light stays on solid the car runs fine ..most of the time the CEL comes on when the car is in use for half hour ..or when car is hot ..i'm gonna try changing the wires tommorow

  • badben360 May 21, 2009

    i will thanks for ur help do u think i have a vacuum line leak.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 410 Answers

I would start with the cylinder 4 spark plug and make sure it look good and is firing correctly.  After that I would look either at the final coil, ignition module and then o2 sensor.  These problems are so hard to diagnose and are trial and error so much of the time.

Posted on May 19, 2009

  • 3 more comments 
  • Keith Heavilin
    Keith Heavilin May 20, 2009

    I'm glad that the engine light has turned off.  I really don't know that much about Audi's specifically and whether or not they will turn off their own CEL.  So that is a little odd to me.  I guess as long as it doesn't come back on you should be good.  As far as the RPM jump...I would try putting a bottle of Greased Lightening fuel injector cleaner in there to clean some stuff out.  You can purchase this at Napa or O'Reilley Auto Parts.  Thanks for an honest rating and for using FixYa!

  • Keith Heavilin
    Keith Heavilin May 21, 2009

    I don't think it is related to the ignition module.  Is there any chance that you had the CEL checked again to see if it is the same code?  I'm interested to see if it is the same one or not.  I'll do some research on this and get back with you tomorrow.  Sorry that didn't get it taken care of for you.

  • Keith Heavilin
    Keith Heavilin May 21, 2009

    Yeah, I would definitely check the wires.  That is weird that it's showing errors on every cylinder!  It was originally just #4 right?  I just wanted to clarify what you said earlier, you are saying that it feels like the car doesn't have any power but when you punch the gas it takes off right?  And you also said that the light comes on while you are stopped and off when you are driving down the road?

  • Keith Heavilin
    Keith Heavilin May 21, 2009

    Man you have got a tough one on your hands don't you?  The rough idle make me think that it would be your IAC sensor (idle air control sensor) which is easy to fix because it sits up in a easy location on the throttle body and is only held on by a couple of screws.  But the fact that you say it is still a little rough when you push the gas makes me question that.  Does it eventually get better when you are driving or is it a little rough the whole time?

  • Keith Heavilin
    Keith Heavilin May 21, 2009

    Sounds good.  Let me know if things don't get better for you after you have done that.  Good luck!

×

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I would say it's definately a vacuum leak. That can cause crazy codes to come up because other components on the car will operate improperly due to the leak.

Posted on May 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 audi a4 quattro, Got gas went approx. 3 miles then smelled gas inside the care and it started a very violent stutter and would die at idle for about 4 miles, then would smooth out and run fine, 3rd...


does the check engine light come on or flash when the running issue starts? sounds like you have an ignition coil dropping out intermittenly.

Aug 05, 2011 | 2005 Audi A4

2 Answers

Oil pressure light went on on my 2000 audi a4 1,8t. What should i do?


could be sender or pump. do not run the engine until you're sure you have a good pump. Does it blink on and off--coming on mainly at idle? This would be normal for an old engine. If it stays on and the pump is bad, you will ruin your engine. You can try replacing the sending uniot, as that is cheap compared to the pump, but don't run it long to check new sender. If new sender stays red, shut down and replace pump.

Sep 03, 2010 | 2000 Audi A4

1 Answer

463a engine control unit disabled Audi a4 1.9 td


463A definitely not VAG codes they are from one of the cheap code readers.
Audi A4 Quattro - fault code 463a: engine control unit disabled.
This could be a dirty sensor or bad connection somewhere.
The immobilizer light flashes when you insert the key?
Imobiliser pick up loop in the steering column sounds dodgy, take the cowling off & check its connected ok. Just clipped it back in.

Jul 22, 2010 | 2002 Audi A4

1 Answer

Check engine light (CEL) problem


Yes the CEL should have turned on. Just turn the key to the run position and the light should turn on.If it doesn't, the bulb may be burned out. Also, if the coil failed and was driven for awhile, it may cause the cat converter to fail after awhile of driving. So, please keep that in mind.

Jan 07, 2010 | 2002 Audi A4

1 Answer

Flashing check engine light on 2003 audi A4


you should stop driven the vehicle and get it repaired, The engine light flashing mean the emission problem is doing damage to your convertors.

Sep 25, 2009 | 2003 Audi A4 Cabriolet

2 Answers

2001 audi a4 1.8 random misfire


do a compression test then do a combustion pressure test if all good computer is questionable

May 25, 2009 | 2001 Audi A4

2 Answers

I want a user manaul for my audi a4 1.8l quattro


Here is a manual, but you have to purchase it:

http://shopping.msn.com/prices/audi-a4-service-manual-1-8l-turbo-2-8l-including-avant-and-quattro/itemid2373553/?itemtext=itemname:audi-a4-service-manual-1-8l-turbo-2-8l-including-avant-and-quattro

Apr 14, 2009 | 2001 Audi A4

2 Answers

Electrical problem Audi A4


ELECTRONIC STABILITY PROGRAM ( ESP) LIGHT FLASHES TO INDICATE UNSTABLE DRIVING CONDITIONS....WHICH WILL ALSO COME ON IF YOUR ENGINE IS MISFIRES.. CHECK THE COILS AND SPARK PLUGS FIRST THEN GO FOR FUEL..INJECTORS...FUEL FILTER CHOKED..HOPE I WAS OF SOME HELP TO YOU..

Feb 03, 2009 | 2001 Audi A4

Not finding what you are looking for?
2001 Audi A4 Logo

1,071 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audi Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14378 Answers

Are you an Audi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...