Question about Mercedes-Benz 190-Class

1 Answer

Automatic transmission problem on my 190e reverse is working ,on D when idleing it goes forward very slowly when you step on gas pedal it reaches high rews with no response still rolling very slowly?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercedes-Benz Master
  • 3,103 Answers

Try getting the transmission filter changed..

Posted on Dec 29, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: 1993 190e 2.6 transmission problem

I have a 93 MB 2.6 190E . went to junkyard, got same tranny, spent 500 bucks to replace. Drives fine. No metal shavings on mine either but changed tranny, ok.

Posted on Oct 17, 2008

dddsouve
  • 64 Answers

SOURCE: transmission problem 1993 190e 2.6 mercedes

Hi!
Base on the information gaven it seems that your forward clutch pack is worn,thats the reason you have seen that metal shaving in the transmission pan.So get your transmission repair.

Posted on Nov 28, 2008

  • 47 Answers

SOURCE: 1996 nissan no reverse or neutral

Unfortunately the only thing to do in this case is to open the gearbox and see the real status of the cylinders, it's very possible the cylinders do not make contact anymore.

Posted on Jan 12, 2009

  • 1619 Answers

SOURCE: Delay reaction of cold start and idle

Sounds like your cold start valve has an issue go to www.benzworld.org or peachparts.com for some good info on it.

Posted on Jul 12, 2009

  • 4 Answers

SOURCE: Automatic Transmission goes into all forward

check fluid if it is a dark color and stinks transmissions probably needs rebuilt sounds like low reverse or direct clutch is bad trna will still go into loe by using forward clutch if low reverse is bad shoul be having problems with 3rd or direct in forward if forward clutch is bad

Posted on Nov 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 hyundai elantra goes in2 reverse but won't go backwards all other gears r perfect


Most automatic transmissions have a separate belt for reverse and all forward gears, The reverse belt is commonly lighter duty that the forward belt (some Chryslers were affected so much it was advised to not shift into reverse until the engine had warmed up and the automatic choke idled down) Thus your car would be in "reverse" but with no motion getting to the gears.

Jun 04, 2016 | 2001 Hyundai Elantra

3 Answers

Why would a vehicle in reverse move forward


The question is a little vague but I think I know what your referring to. All modern automatic transmissions have torque converters. This is the device that connects the engine to the transmission. All vehicle manufacturers like the trans to be nice and smooth shifting. That's great but it does come with some minor drawbacks. If you are facing slightly down hill and you put your car in reverse but do not step on the gas slightly I can guarantee that you will indeed roll forward. You can eliminate that issue by holding your left foot on the brake while you shift into reverse. Then, as soon as you feel the trans engage, gently depress the gas pedal with your right foot and it will eliminate that forward roll problem.

Sep 25, 2014 | Cars & Trucks

1 Answer

I have a 1991 automatic, 190e, 2.3 engine Mercedes Benz. My issue is the reverse everything else is still working fine but if i change the gear into reverse you can hear it change and you slowly roll...


Hi, this may be one of a multitude of failed components but it does sound like one of the internal clutches of the auto box as worn out. The best way to have this diagnosed is to take it to an automatic specialist, unfortunately if it is a failed internal clutch or brake within the box it is not a cheap repair

May 05, 2011 | Mercedes-Benz 190-Class Cars & Trucks

1 Answer

I have an automatic gas 2006 hyundai tucson. recently i noticed that when i engage the drive or reverse gear the vehicle lurches forward or backward accompanied by a banging noise. i have had both engine...


idle air control valve or iac same thing it controls idle speed yours is to high or you have a bad cv joint but i dnt think its that to new of car i would say your idle is to high

Apr 04, 2010 | 2006 Hyundai Tucson

1 Answer

Wont go in reverse but will go forward...


That is the way automatic transmissions usually die when they go slowly :( The reverse idler gear lets go, but the rest of the transmission is not very far behind. I've seen them go a while after reverse gave way, but not very long, usually the whole transmission will pile up pretty soon after. I'd look into getting that tranny rebuilt/replaced before it leaves you stranded and the tow call adds to the bill. The one thing i hate about automatics is the fact that, unlike manuals, they work just great one minute, and the next minute, they just quit working all together. Before anything else, just check your transmission fluid level with the motor running, transmission in neutral, parking brake set, but in your case, because it goes forward, the level is probably ok, the tranny probably has internal problems...

Sep 08, 2009 | 1995 Dodge Caravan

2 Answers

1993 190e 2.6 transmission problem


I have a 93 MB 2.6 190E . went to junkyard, got same tranny, spent 500 bucks to replace. Drives fine. No metal shavings on mine either but changed tranny, ok.

Aug 26, 2008 | 1993 Mercedes-Benz 190

1 Answer

Transmission problem 1993 190e 2.6 mercedes


Hi!
Base on the information gaven it seems that your forward clutch pack is worn,thats the reason you have seen that metal shaving in the transmission pan.So get your transmission repair.

Aug 26, 2008 | 1993 Mercedes-Benz 190

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76070 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...