Question about 1996 Mercury Mystique

1 Answer

Po171 mercury mastique po171

Replaced o2 front sencor gas milage came back to 30mpg but still runs rough and idle hard cant find leak any where

Posted by on

  • richard raffo Jan 01, 2014

    I have new gas filter and air filter also looked for leaks (none) would the other 2 02 sencers hav anything to do with it

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 110 Answers

Have you checked the egr valve

Posted on Dec 29, 2013

  • 3 more comments 
  • mike briner Jan 02, 2014

    it could have with that many sensors they may have told you to replace the wrong one, what you have is a lean condition i would check the codes again and confirm codeif no code i would look at fuel and emissions like egr throttle position sensor

  • richard raffo Jan 26, 2014

    I replaced the one one on the manfold not the ones below it on tail pipe

  • mike briner Jan 27, 2014

    still running bad?

  • richard raffo Feb 15, 2014

    Yes still runs rough but gas milage back to 30 driving me crazy light on

  • richard raffo Feb 15, 2014

    also egr would maybe give a differet code

×

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

carlsbiz
  • 1124 Answers

SOURCE: why is 99 mercury cougar getting bad gas milage

Try new plugs, wires, fuel filter, air filter, pcv valve, and if its still not too
good,, do the 02 sensors..

Have a good day !

Posted on Oct 24, 2009

drsinister69
  • 2317 Answers

SOURCE: 1989 Mercury Sable GS 3.0L runs rough and idles down and stalls

Sounds like you might have a stuck open EGR valve. Is the check engine light on. I would replace the fuel filter if it hasn't been replaced, also check the air filter.

Posted on May 31, 2010

  • 369 Answers

SOURCE: when warm runs rough sets

If the cat is cherry red as you say it is I would check the firing order or timing they may have crossed plug wires this will cause the exhaust manifolds to get red hot and glow let me know if this heled you and good luck.It definitely sound to be timing related or crossed wires.

Posted on Feb 09, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What symtoms of a bad o2 sencor


Poor idle rough. Poor exhilaration. Check engine light, sometimes bad exhaust smell

May 13, 2014 | 2001 Honda Odyssey

3 Answers

Nissan pathfinder 1998 code p0325 what sencor is it there are 4 Sencors ???


It is the knock sensor. But before you do anything first check the vacuum line which is on the front right tire on the rear side of the tire where small hose from charcoal canister up over the shock to the purge valve. That vacuum hose from the purge valve connected to a metal hose and then the metal hose connected back to a rubber hose on the purge valve. that metal hose because it gets rusted cause a leak causing Injector 2 to missfire.

Aug 18, 2012 | 1998 Nissan Pathfinder

2 Answers

2000 Lincoln Navigator - few days ago started idling very rough when truck is at a stop or in park. Service Engine Light came right around time I noticed that it was idling rough when stopped. Following...


P1131 Lack of HO2S-11 Switch ,Sensor Lean
P1151-Lack of HO2S-21 Switch ,Sensor Lean
PO171- System to Lean (Bank 1)
PO174-Systen to Lean (Bank 2)

Fuel Filter -Plugged
Low Fuel Pressure
Evap System -Leaks
Leaks - in ducting,air filter to throttle
PCV -Leaks
Exhaust System -Leaks
O2 Sensors-worn out

Apr 06, 2011 | 2003 Lincoln Navigator

2 Answers

Ford f150 2003 po171 always lean bank 1. replaced bank 1 o2 sensor smoked intake. replaced egr valve. still code po171 short term trim 0123 but long term trim is up bank 1 30 anb bank 2 is 27. idle is a...


Code Po171 indicates a lean condition on cylinder bank #1 of the engine. This is the drivers side of the engine. I would suggest replacing both front oxygen sensors as a pair to start. An oxygen sensor has a life span of about 5 years and yours are now 9 years old if they are original. When they get older they are slow to respond to changes in the oxygen content of the exhaust and can trigger a code Po171. If you continue to have the same code set after the replacement of both oxygen sensors then it is time to find out why your engine is running lean. Some of the most common causes are an ignition misfire and a vacuum leak. I have also seen Fords EGR flow sensor (known by Ford as Delta Pressure Feedback sensor) to cause problems like that as well. A good mechanic with a scan tool can usually spot a problem like that in a few minutes.

Mar 01, 2011 | Ford F-150 Cars & Trucks

1 Answer

I have a 2003 gmc yukon 5.3 the engine idles rough sometimes the idle will get so low the engine will shut off.(the engine runs good while driving) hooked to scaner po101 maf/vaf (dont know what vaf is),...


you have a vacume leak somewhere.check all of your vacume hoses for leaks.Injector seals can cause this too.Also intake gaskets could be leaking.Running to lean usually means the car is getting to much air coming in.To check leaks spray brake cleaner around the hoses and the bottom of your intake if the rpms change then you found a leak.

Feb 21, 2010 | 2003 GMC Yukon XL

2 Answers

1998 k1500 o2 sensor rattle, truck runs rough. would that cause it to run rough?


If O2 sensor is bad it can cause Rough running. Are you sure it is the O2 sensor ratteling? Have you taken it out to hear Rattle? Is it loose? I have not Hears an O2 Sensor rattle. I have heard Converters Rattle. over time Inner Material of converter will Not have a tight fit due to heating and cooling. expanding and contracting. carses some of the material to wear away. Causing the it to rattle. and can cause rough running also.

Oct 09, 2009 | Chevrolet 1500 Cars & Trucks

1 Answer

Lack of fuel when accelerating


This might help. It looks like you O2 sencor had gone bad or the signal has and causing multiple mis fire. according to your codes. 
PO171 System too Lean (Bank 1

PO174 System too Lean (Bank 2)

PO300 Random/Multiple Cylinder Misfire Detected

Causes of PO300
Fuel injectors, related wiring, sensors and computer issues
Running out of gas, or poor fuel quality
Evaporative emissions system (EVAP) concerns: fuel vapors leaking into engine
Incorrect Fuel Pressure
EGR system concerns

I'ld start with chaning the O2 sensors first but sheck for bad wire connection. Hope this helps and good luck

Apr 08, 2009 | 2004 Ford F150

1 Answer

2005 silverado..5.3...motor idle rough.. getting 3 codes


p0171 and o0174 is lean replace intake gasket they will be a teal color,the old ones are red. i work for chevrolet.this is a common problem

Feb 11, 2009 | 2005 Chevrolet Silverado

1 Answer

1998 Toyota Corolla poor gas milage


first i would change the fuel filter. this is the number one reason for poor gas milage. the engine tries to compansate for the lack of fuel and in the long run this weakens your fuel pump and it will fail sooner rather than later. i als would check the air filter. if the engine can't breath properly it will lose power. if you have not had a tune up I would suggest getting one. this most certainly help boost the performance of your vehicle. i would try and use an additive in your fuel to clean the injectors clogged injectors will make the engine run rough and cause hard starting and rough idle.. the last thing i would have you check is the throttle positon sensor and the O2 sensor. take it to a shop and have them hook a diagnostic scan tool to it this will show if either of these sensors are bad or if they threw a code and the computer is trying to overcompensate for the lack of fuel. hope these options help you. please rate this solution thanks

Sep 01, 2008 | 1998 Toyota Corolla

Not finding what you are looking for?
1996 Mercury Mystique Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

fordexpert

Level 3 Expert

5474 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...