Question about 2004 GMC Sierra 1500 Crew Cab

2 Answers

ABS creaking They have been coming on at low speeds for some time now. I replaced n both front hubs, to no avail. So I took it to the dealer and he told me "the only way I know is to change the hubs?" In fairness, it was some kid and I needed to get out of there. I almost crashed the other day so its becoming a major problem. I have checked the voltage on the front two, but that's it thus far. Any suggestions?

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • GMC Master
  • 1,727 Answers

Whats been coming on... abs cant creak and you didnt mention the part about C1500 or K1500. big difference

Posted on Dec 28, 2013

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Have you changed the wheel speed sensors? For the most pard the abs will engage at low speed due to a cracked tone wheel in the hub or cv.shaft

Posted on Dec 28, 2013

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

66 chrgr
  • 1011 Answers

SOURCE: recurring problem with recall 05V379000

hello dirt gets between the abs sensor and the MOUNTING SURFACE . in order to find which sensor it is .on the front abs sensor has to be unhooked wheels jacked up ,spin wheel clockwise by hand while check ac voltage .if the ac voltage is less than 200millamps this is the sensor that the surface needs to be cleaned,TURN WHEEL 3 TIMES AROUND PER SECOND! I HOPE THIS HELPS

Posted on Feb 01, 2009

badealer888
  • 414 Answers

SOURCE: Both brake and abs lights are on. I've replaced

you have an ABS code in the ABS computer. You most likely damaged an ABS sensor. even after myouo fix this you will need to get the code cleared
NOTE: autozone wont be able to access the ABS computer.

Posted on Aug 03, 2009

  • 2 Answers

SOURCE: 01 Denali XL, Drivers heated seat doesn't work.

Same problem on my 01', what fuse is it?? I can't find any blown fuses in the hood block or the one under the seat.

Posted on Mar 13, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

A HAVE CHANGED BOTH AXLE BEARING AND HUB ASSEMBLY FOR A SUBURBAN 20011500 2WD AND AFTER THAT THE ABS AND THE BRAKE LIGTHS GO ON. A TOOK THE SUBURBAN FOR CHECKING THE ABS MODULE AND THEY SAID THAT THE ABS...


The front two wheels is where the ABS sensors are located. Inside the hub assy. If you replaced the hubs you should have seen and un-hooked the wires to the ABS senors. I think this is why you have a light on, maybe a wire got cut in the process of repairing your hubs and bearings. Or the maybe a plug has come un-plugged. Check the wiring to the hubs for these problems.

Sep 25, 2011 | Chevrolet Suburban 1500 Cars & Trucks

1 Answer

My traction control light and ABS lights are on. They are off when i first start the vehicle and then come on right away as i use my breaks or sometimes after a couple minutes. My ABS in the mean time...


first off i had the same problem, i took it to the dealer, and they have a reader that told them it was my left front hub assembly, they replaced it and it was ok for a week, we called and told them that iot was doing it again, brought it back, they said it was in the contacts the wiring harness had, we brought it back home, and it was ok for a week , took it back in and dealer said they could not find problem, abs system, workes off of the hub assemblys, so if one is replaced, the others could be going bad also, so mif you replace them you should do all four of them.

Feb 02, 2011 | 2005 Chevrolet Equinox

2 Answers

I have taken my 2003 GMC Envoy in to a GM dealer more than 6 times to be repaired for a very loud creaking noise in the front end. When I brake, the creaking noise starts. Or if I go over a bump, the...


My wife drives a 2003 GMC Envoy and has been complaining about this same creaking noise upon breaking or going over speed humps. I researched this topic on the internet high and low and tried everything I read to no avail. I was about to give up and then realized it could be the motor mounts since when you break or go over bumps the engine does have some movement. Sprayed the most interesting looking motor mounts I've ever seen with silicone spray and the noise was gone! My wife has been complaining for years about this noise and now looking back what a simple solution!. By the way my motor mounts where not worn out, the rubber portion of the mount just needed a little lube.

Dec 31, 2010 | 2003 GMC Envoy Xl

1 Answer

Anti lock brakes working all the time and brakes not working properly


Faulty ABS sensor in the front wheel hub. Inspect the ABS sensor in the front wheel hub, your going to have one in each side so inspect both of them. Common for the sensors to pick up dirt giving faulty signal or no signal at all giving the impression that the wheels are not moving.
Start with the simple and inspect the ABS sensor and wire leads. Replace any worn or damaged parts.
Thank you for using fixya and be safe, you can for the time being. Remove your ABS fuse to keep the ABS from working so you have 100% brake control.
Common to have build up of rust on the sensor, which once removed should fixed the issue.
#PIT3707: Information on the Upcoming Safety Recall 05068 Front Wheel Speed Sensor Corrosion - keywords ABS activation brake campaign sensor speed unwanted - (Sep 1, 2005)
1999-2002 Chevrolet Avalanche, Silverado, Suburban and Tahoe
The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in this PI.
Condition/Concern:

These vehicles may experience unwanted antilock brake system (ABS) activation and increased stopping distances during low-speed brake applications (greater than 3.7 mph but less than 10 mph). This condition does not set any ABS codes nor does it illuminate the ABS warning lamp. This condition is more likely to occur in environmentally corrosive areas, based on field report data from the U. S. and Canada.
To correct this condition, dealers are to remove the wheel speed sensor and thoroughly clean the wheel speed sensor mounting surface on the bearing, apply Zinc-X (rust inhibitor) to the cleaned surface, grease the mounting surface, reinstall the wheel speed sensor, and check the peak-to-peak output voltage to ensure the wheel speed signal is within specifications. These repairs will be made at no charge to the customer.
Approximately 804,000 vehicles are involved. GM is working with its suppliers to obtain the required parts as quickly as possible. Based on the anticipated schedule, we plan to begin notifying customers about this recall in November 2005.
GMVIS information for this recall will not be available until the recall bulletin is released to dealers in November 2005.
Recommendation/Instructions:
Do not attempt any repairs until Campaign 05068 is released.

May 13, 2010 | 1999 GMC Yukon

1 Answer

I have a 2004 Pontiac Aztek. The ABS brake light


hello i have a similar problem with my 2002 aztek the ABS light comes on only after my ABS system kick on when it is not suppose to (like normal braking conditions) i took it to be looked at at my local shop who also said it was a front hub having a bad wheel speed censor less than a week after having the work done the problem returned i took it back and they ran diagnostics on it for somewhere around 5 hr and could find nothing so they replaces the hub again.... no shocker here the problem isnt fixed still most recent time i had it in the tech said the problem is the cars computer is "loosing the wheel" he showed me where the main wiring harness runs right next to the oil pan along the bottom of the engine. the wires that go to the ABS control for that side are very swollen and the wires inside are loosing contact. they told me that i would have to replace the harness or live with the problem. after doing research the harness is no longer made and cost around $900 just for the part then u have to pay for the labor of someone putting it in
Hope this sheds some light on your problem

Apr 26, 2010 | 2004 Pontiac Aztek

1 Answer

ABS is tripping for the past 2 years


Check your ABS sensor on your wheel hub. The ABS sensor may be going bad or needs to be re gaped. You can do the work your self to save you some money, Take the front wheel off and look for your ABS sensor, There is going to be a wire harness along your upper A arms, just follow it to the wheel hub. Give it a good spray with brake parts cleaner and re gap it closer to the speed ring on the wheel hub. If you don't have a feeler gap, you can use a dime as the gap reference. After your have done all that and you still have the problem, you can go to the dealer and have them look up if there was a recall campaign for the ABS activating during low speed stops. Good luck and keep me posted Be glad to help.

Jun 30, 2009 | 2000 GMC Jimmy

2 Answers

Abs lights keep coming on? 2006 Monte Carlo. 44,000 miles. Started car this morning, antilock brake yellow light and ABS yellow light both came on. No change in braking performance I can feel. Is it under...


yes it would be under warenty go to the dealer and have them look at it if you need help after that contact me for more help. It could get expensive to fix yourself and it takes special tools to work on abs, it could be as simple as a bad wheel sensor and has to be fixed and the light reset, the dealer has a computer to test and fix it and it would be no cost to you, the only thing they would not cover is if the brakes needed replaced but the ABS would be covered, and hurry time is short for Gm.

May 28, 2009 | 2006 Chevrolet Monte Carlo

1 Answer

2001 silverado 4x4 abs brake keeps coming on


in these trucks if the front abs activates at low speeds it is normally because of the wheel speed sensors in the front hubs. easy fix is to remove wheel speed sensor from wheel bearing. clean and file cast surface of bearing to allow sensor to move closer to internal reluctor ring. what happens is over time the casting rusts and creates a larger gap. please rate if this works.

Dec 04, 2008 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
Cars & Trucks Logo

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...