Question about 1996 Chevrolet K1500

1 Answer

Blowing transmission fuse on a 1996 chev 1500

Keep having the fuse fail on my 1996 chev 1500. just had the trans rebuilt and a few days ago had the spedo, tach, check gauges, and check engine light came on,. the tach and spedo stopped working. and the trans wasn't shifting right. plugged in a new fuse after realizing there was one linked to all of those. and it worked good for a few more days. went to start is this morning and after being on the road for a few minutes. I lost my tach and stuff again. looked at the fuse and it wasn't any marks of being blown. put it back in and it worked for a few minutes and stopped again. put a new fuse in ad it did it again. but again. never actually looked like it blew the fuse. just pulled it out. put it back. it worked for a minute and shut off again. any suggestions?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Chevrolet Expert
  • 180 Answers

Pinched wire between engine and trans due to mechanic fault during installation.

Posted on Dec 27, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: I have an 04 Silverado with the 4L60E. The

I would be interested to know why you kept pulling the tranny. Its possible you lost the prgram in the PCM. You may need a reflash. Where there codes. Or you may have a bad torque converter or trans oil pump.

Posted on Jul 15, 2009

  • 95 Answers

SOURCE: 2003 chevy s10 - keeps blowing out AC fuse. Will

you have a short somewhere problably bad ground , or interferrance from alternaot overloading the circuit... check all ground securlely...if you cant locate it its not going to be cheap for a mech to locate the issue.. good luc kthough ( also check for loose wire behind the fuse box in car.

Posted on May 19, 2009

  • 218 Answers

SOURCE: Fuse for tach

THERE IS A 10 AMP IGNITION 1 FUSE UNDER THE HOOD IN THE PDC.THERE IS NOT A FUSE FOR THE TACH.IF THAT FUSE WAS BLOW NONE OF THE GAUGES WOULD WORK.U COULD USE A SCAN TOOL AND CK FOR TROULE CODES.

Posted on Apr 29, 2009

  • 2 Answers

SOURCE: I have a 1995 Chevy

i have a 95 k2500 350 just put in a new tranny and less than 90days later there is little to no pressure. Thinking it is a bad pump but could be the ecu thing as well since the previous tranny went out the same way. If you know where to locate it any help would be great! c = 2wd k = 4wd

Posted on Sep 29, 2008

  • 468 Answers

SOURCE: tach and speedometer don't work transmission won't

The speed sensor is necessary to tell your transmission when and if to shift. The PCM uses the information from it, plus the way your vehicle is accelerating to determine shifting, and if the sensor went out, or the PCM went bad, then you'll lose your transmission shifting. You can shift it manually though. There is also a fuse under the hood that provides the transmission with power, and of course, if any wiring or connections are bad, will cause the same problem. Hope this is was you're looking for.

Posted on Mar 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

All gauges working except tachometer on 2003 Chevy Avalanche


Chev dashboard of this vintage are aweful for needing rebuilt. The tach quits and then the fuel guage and then the speedo......

Feb 20, 2015 | 2003 Chevrolet Avalanche

1 Answer

Automatic transmission not shifting gears


Replacing any fuse after it has blown ,your almost
guaranteed it will blow again

At least you know the circuit with the problem

Now you go to factory wiring diagrams, to see what that
fuse controls & do some testing

Have to have wiring diagrams,be able to read them & know
basic electricity & be able to test your vehicle,then you have
to be able to continue on with professional tools, once the fuse
issue is resolved, if the fuse keeps blowing every few days

You could have wiring issues,more likely inside the trans in the oily
environment ,you could have solenoid or module failure or mechanical trans issues

I would say you can't resolve at home,need professional help

Mar 14, 2014 | Ford Expedition Cars & Trucks

1 Answer

My gauges are not working.tach,speed nothing


Have you checked the fuse for the instrument cluster ?
What are the trouble codes in the computer for the check engine light ?

Jan 27, 2013 | 2003 Chevrolet Silverado 1500

1 Answer

'99 Ford Crown Vic LX: #12 30A Maxi fuse blows seconds after starting or ignition turned on.


i had this problem with my 1999 jeep grand cherokee laredo with the brake lights it kept popping fuses right after the ignition was turned on try putting a higher amp fuse in place of the old one that keeps blowing then check for shorts to the starter and check grounds and wires and also the transmission issue check the fluid and then if the fluid is fine change the transmission filter the filter may have not gotten replaced when the transmission was rebuilt and may be clogged or dirty

Oct 04, 2012 | 2002 Ford Crown Victoria

1 Answer

My transmission fuse keeps blowing out on my 93 suburban 4x4 after i ha d it rebuilt, how can i fix this?


unplug the harness on the side of the trans and try it this will show if the problem is inside or on the truck side if it doesn't blow the the harness unplugged then drop the pan and see if the internal harness is pinched if not test the actuators with a ohm meter

Aug 08, 2012 | Cars & Trucks

1 Answer

1999 chev 1500 4x4 new rebuilt trans won't move after 5 minutes


Well see whats wrong with it or cheak on google see what comes up he answer if my information aint helping you or go to a shop like morrisons

Jun 18, 2012 | 1999 Chevrolet Silverado 1500

2 Answers

95 chev 1500 z71 4x4 wont go reverse or forward in D,1,2,3. Automatic trans.,full of oil.


check tip stick if black and smell it it it smells burnt most likey transmission problem acheck that you trans. cable shifter cable is attached first

Dec 05, 2010 | 1995 Chevrolet K1500

1 Answer

Hi, 1996 Chev SUburban 1500, never any problems till a few months ago. Drove thru U.S. and filled up with gas, after a few hours, engine light came on. Now, a few months passed, and truck having rough...


where did you go? if you went through really high altitudes the oxygen levels change and could have fouled your plugs. sometimes the auto makers tune the vehicles different in different geographical locations.

Sep 29, 2010 | 1996 Chevrolet Suburban

Not finding what you are looking for?
1996 Chevrolet K1500 Logo

304 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...