Question about 2007 Mercury Mountaineer

1 Answer

Truck would not excellerate pas ten miles now it wont start. when i play with the fuel restart button it starts rough and dies

Relays pump egr IAC all new

Posted by on

  • gerald
    gerald Dec 27, 2013

    yes i have disconnected the fuel reset switch not sure of the fuel pressure or injectors the maf sensor is new fuel pump new and filter what can cause fuel not to flow ?? at first the truck wouldnt eccelerate past 20 or 15 after changing parts it got worst to a no start

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 5,537 Answers

See there were several postings. Was internal fuel tank screen good when pump was changed? Was disposable fuel filter changed? I had similar problems and it turned out that the internal filter screen broke apart and clogged the fuel lines.

The crankshaft sensor was also bad as fuel pump was tested during internal tank filter work.

Also check your injector wires. Even having fuel pressure is nothing if the injectors are not opening to let fuel into the cylinders.

Posted on Dec 27, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
elshaddai159
  • 1016 Answers

SOURCE: 2000 cougar 2.5 won't start

Hi,

Could you tell me if you have check the following:
1. MAF sensor
2. Fuel pressure sensor
3. Fuel temperature sensor
4. Inertia shut off switch
5. Throttle Position sensor.

Let me know if all the components are fitted and working correctly, I can then give you more information.

Thanks

Jason

Posted on Oct 19, 2010

wilsodfarm
  • 986 Answers

SOURCE: new fuel pump and still wont start

your fuse maybe blown or your fuel relay may be bad,

Posted on Aug 26, 2009

  • 120 Answers

SOURCE: 98 Grand Marquis intermittent no start/stalling

crank sencer

Posted on Feb 18, 2009

  • 196 Answers

SOURCE: 1993 mercury tracer has me stumped

Well when you turn the keys on the pump will only run for a few seconds A test light works ok but i would use a volt meeter at th efuel pump power and groung wires and measure the voltage while cranking the car

Posted on Jan 18, 2009

  • 8 Answers

SOURCE: no start.

it does have arelayt anfeuse,start with control module,and ifyou have a wireing diagram check for output at prosessor

Posted on Jan 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 firebird 3.8 series 2. New o2 sensors,egr valve,fuel filter.starts ok cold, 2-3 min.,idles rough and dies.o2, egr,the,Eva codes


Vacuum leak , IAC valve - idle air control , Go to your tube an check out videos on checking for vacuum leaks an how to test IAC valve an cleaning throttle plate an IAC - air passages ! Eva codes ? what code # ?

Jan 18, 2016 | Cars & Trucks

1 Answer

2000 Mercury Mountaineer 5.0L dumping gas into intake manifold and detonation in exhaust manifold on exhaust firing cycle


Fuel pressure regulator bad. Vacuum operated , pull the vacuum line. Smells like fuel. It's bad .Electronic could a fuel pressure sensor on the fuel rail or the fuel pump control module.

Jul 28, 2015 | Mercury Cars & Trucks

2 Answers

Starts and idles rough then dies


Check for vacuum leaks eg. PVC hose power booster and hoses around manifold area.

Jul 28, 2014 | 1989 Ford F 150

1 Answer

1989 300 SE mercedes benz dies after driving for 5 to 10 miles and will restart after it cools down. start easy and idles ok.


Could be the egr valve is sticking open. I would try diabling the valve by pulling the vacuum line off the egr valve vacuum port. You can plug the hose with a golf tee or bolt to run the test. Then drive the car on the highway where it would normally act up. If it still acts up, put the vacuum line back on the valve and check for other leaks, such as vacuum leaks--maybe the intake manifold gaskets.

Sep 23, 2017 | Cars & Trucks

3 Answers

2000 blazer runs rough and dies when gas pedal pushed to floor.


sounds like you need to change your fuel filter or you may need a new fuel pump relay

Jan 23, 2013 | 2000 Chevrolet Blazer

1 Answer

Does a 1993 k1500 have a fuse for the injectors?


when engine stalls if you try to restart it check the tachometer. If the tach isn't moving then you proboubly have a bad crank senser which is killing the power to your fuel pump and your coil making you lose fuel and fire.

Nov 11, 2011 | Cars & Trucks

1 Answer

1996 intrepid was hard to start over the last week or two like it needed fuel . then today it just stopped turns over and tried a different crankshaft censer any help will be appreciated


More info would be helpful. Any codes popping up? Start from there and if codes, then that will point the direction you need to take. I have a 1996 Intrepid 3.5 and a quick guess is that you have a fuel delivery problem. Either faulty fuel pump, fuel pressure regulator or fuel line issues. Sounds like maybe an EGR valve problem too? All cars with over 100K miles have carbon and sludge in the EGR system which includes the pipe, passage from the egr valve to the intake and intake manifold. You might have a simple carbon issue. So, remove the IAC and clean the **** out of it with carb cleaner. You will be surprised how dirty it is. This is a 15 minute job. The IAC controls airflow and if the pintle is not moving per the ECM due to carbon, then it will start and run rough. Could be that your IAC needs to be replaced. Need more info here from you.

Aug 10, 2011 | 1996 Dodge Intrepid

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

1 Answer

2001 Blazer Ignition or fuel Problem?


try checking your fuel tank for sediment it may be clogging the fuel pump and when it dies it falls away then when you start up again it gets sucked up

Jun 11, 2009 | 2001 Chevrolet Blazer

2 Answers

Stalls / Dies / dead


this engine fuel pump prassurae low. it fuel pump celan. Your problem sovel

Jul 13, 2008 | 2003 Ford E150

Not finding what you are looking for?
2007 Mercury Mountaineer Logo

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

fordexpert

Level 3 Expert

5530 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...