Question about Mazda 626

1 Answer

Will not start

My daughters car will start and run fine cold. when she cuts it off after it gets hot it wont restart until it gets cool again, usually about 30 min I am at a loss to the problem, replaced coolant sender and coolant sensor under local auto parts store advice without change in condition, no engine lights codes to check I thinking the coil may be fouling when it gets hot or something any help or suggestions out there

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Mazda Master
  • 42,818 Answers

Have a fuel pressure test done to check the pump, pressure regulator and filter. It may be getting a vapour lock from low fuel pressure.

Posted on Dec 27, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 13 Answers

SOURCE: 2002 malibu runs hot.

Sounds like you have a faulty head gasket or maybe a cracked head.This can cause overheating and the check engine light to come on.The code for the o2 sensor is probably caused by coolant getting into the exhaust system and coating the sensor.The coolant fan may work but it cannot remove enough heat from the rad to make the engine cool off.Try some engine coolant stop leak to see if it will help.This maybe only a temperary fix.Let me know if you need more.MOE

Posted on Jun 22, 2010

alicantecoli
  • 22156 Answers

SOURCE: My Hyundai Elantra 1999 crankshaft position sensor A circuit

could be ??the windings in the sensor have the insulation on the way out

Posted on Jun 28, 2009

  • 2 Answers

SOURCE: 1994 Buick Lesabre service engine soon light. Can't read code.

I found several shops in my area, Albany, NY that had the older code readers. It worked fine, and cost me $30.00. It showed a bad O2 sensor that I replaced myself. I suggest you go to a reliable shop. Auto Zone/Advance etc.. do not have the right code readers. Joe

Posted on Feb 17, 2009

SOURCE: 1999 pontiac grand prix . will not run

If wiggling the wires cured the code, then one of the wires is broken inside the insulation. Pull on each wire one at a time. look for the colored insulation to stretch, this will be the broken wire. For the other car that wont rev up, this is a common when the catalytic concverter is plugged up. This will also cause MAF codes, and in turn, TRAC OFF light.
See http://www.greatautohelp.com

Posted on Oct 17, 2008

Molson02536
  • 3854 Answers

SOURCE: Check engine light

A multi misfire may mean that one or more of the following has happened:
Faulty spark plug or wires, Faulty coil (pack), Faulty oxygen sensor(s), Faulty fuel injector(s), Stuck/blocked EGR valve / passages, Faulty camshaft position sensor, Defective computer.

The engine is stumbling or hesitating, check all wiring and connectors that lead to the cylinders (i.e. spark plugs). Depending on how long the ignition components have been in the car, it may be a good idea to replace them as part of your regular maintenance schedule. I would suggest spark plugs, spark plug wire, distributor cap, and rotor (if applicable). Otherwise, check the coils (a.k.a. coil packs). In some cases, the the problems were faulty fuel injectors. 

Random misfires that jump around from one cylinder to another (read: P030x codes) also will set a P0300 code. The underlying cause is often a lean fuel condition, which may be due to a vacuum leak in the intake manifold or unmetered air getting past the airflow sensor, or an EGR valve that is stuck open.

Good luck and hope this information helps, keep me posted, be glad to help you get the truck running 100% again. Not sure if your running a K&N air filter, and if you are there may be a flim of oil on the MAF sensor that is making you run lean. You may want to spray down the MAF sensor with a can of MAF cleaner. 

Posted on Jul 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 1999 taurus will run but when it gets to operating temp it cuts off, after it cools down it will start and run fine until it warms up again, and then it cuts off again. I can repeat the process as many...


A lot of the time when that happens it is crank sensor it starts to get hot and stuffs up how I check and it work sometimes is poor cold water all around the sensor area after it stops and if she starts up after you cooled it down you found the problem then just replace it

Dec 19, 2014 | 1999 Ford Taurus

1 Answer

1994 intrepid starts runs until warm then cuts off wont start until cools off


Chances are its something electrical, but thats a big list.
You'll have to rule out a few things and check for spark and fuel pressure when it won't start.

Jan 24, 2013 | 1994 Dodge Intrepid

1 Answer

1989 supra will start and run fine untill it is warm, then it will cut off and wont start back untill it is cold again. WHATS WRONG???


dont no about that but check coil pack when it wont start and see if you have spark if it doesnt check for power to coil if you have spark its on the fuel side

Jan 10, 2013 | Toyota Supra Cars & Trucks

1 Answer

Car star when is cold but if I stop the engine after is hot it will not start until cool of again


If you mean that it starts fine when cold, but if you stop & turn off the engine (to to pop into a shop for example) then try to restart and get absolutely no turning over, then you need to replace your battery. It has a short or crack which is expanding when hot creating your problem.

Jul 31, 2012 | 1997 Ford Explorer AWD

1 Answer

On my 1991 3.1 chev lumina when it get warm you step on the gas and it die's what the heck? can anyone help


some common problem in the summer when car get hot over and over the ignition (coil) is affected it will make your car cold run fine but cuts off when hot if occurred look for the coil
if you let car cools down for an hour then it started and work fine until cut off when hot again sure it is coil .

Jun 08, 2011 | 1991 Chevrolet Lumina

1 Answer

Car wont start in cold idles funny for a moment, then is fine .The heat dont act right gets hot going down the road cools off when sitting at idle.


i hate to be the bearer of bad news but it sounds like a head gasket failure.usually occurs in cyl 2 ond or 3 in these engines (1.8L).car sits and engine cools coolant leaks into cylinder and when started runs with amiss until coolant burns out of cylinder and conversely air gets in cooling system,system gets low and you have poor heat esp at idle.have your mechanic confirm but these engines are becoming notorious for this.

Feb 02, 2011 | 2002 Nissan Sentra

1 Answer

I have a 97 grand am 3100 v6. when engine is cold it starts and runs fine until i shut it off then it wont start until it cools off. the fuel pump wont work until engine cools off. then it will start and...


I know this sounds silly but Replace the crankshaft position sensor. My guess is it will start shutting itself off soon and restarting when it cools off. I think its just giving you a warning lol.

Mar 19, 2010 | 1997 Pontiac Grand Am

1 Answer

2000 silvarado 5.3 vortech runs good for awhile after it gets hot it shuts off and wont crank until it cools off


do you mean wont crank over and start till it cools off? if thats the case it sounds like you got a bad crankshaft position sensor,,thge sensor is fine when its cold and warm but when it gets hot it goes open and the cars computer cant see the rpm and shuts the engine off,and then when it cools off the sensor works again and the car starts and is ok till it gets hot again,if thats the case thats what it is,,,hope this helps,,,about $100 for the part

Oct 07, 2009 | 1985 Chevrolet Chevy

1 Answer

Runs fine for approx 15 mins,then stalls out and wont start again


sounds like coil problem, coils will start cold then get hot and stop. when coil cools will crank up and run till it gets hot, try to replace the ignition coil,dont think it would be a crank sensor, try a coil,thanks robert b.

Jun 19, 2009 | 1993 Jeep Cherokee Country

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...