Question about 1995 Chevrolet Blazer

1 Answer

1996 chevy 305 vortec,stops after it rains,no fire,just installed new plugs,wires,cap and rotor,and crank position sensor,still no fire,and no codes

It used to fire after a day or 2...then i replaced these parts to try and stop it from happening again...no such luck...no fire and no codes...hard turning over now,occasional backfire,sounds bad when you crank it

Posted by on

  • 5 more comments 
  • Bill
    Bill Dec 26, 2013

    forgot to mention....it has spark at the plug...and fuel at the schrader valve

  • Bill
    Bill Dec 28, 2013

    i dont know if you're serious,but im a little further along than "snug ur plug boots,

  • Bill
    Bill Dec 29, 2013

    i've been waiting 5 days for a serious answer to my problem,its not the plug wires(is this the only thing you people know???)i should have just swapped the parts out 4 days ago and be done with itand if i find someone dwn the road who needs to know absolutly nothing about vehicles...i'll send them here it

  • Daniel Mc Entee
    Daniel Mc Entee Dec 29, 2013

    you need codes to break this down, to say what is wrong.if no codes then you go back to basics ,first check the coil for a spark,if no spark .test the coil. if coil is ok. check the wires from the ignition switch at the coil do you have power to the wires key in and key off.if that is ok then your ignition module can be the trouble ,but it can also be a failed ECU..or a break in the wiring .that is why you do checks on the wiring ..the trouble is you replaced parts it is not know if you did this right.you would have been better to have got the codes first.as it my just have been a vacuum leak you had in the first place.or water getting on to the wires of the ECU.and shorting it out .fixya can not rebuild your car for you .they can only help if you tell them what was wrong before you changed the parts.and what tests you did to check the parts ,you thought needed changed.

  • Bill
    Bill Dec 30, 2013

    there were never any codes...plz re-read original post

  • Bill
    Bill Dec 30, 2013

    and it turned out to be the ICM...but thx....

  • Bill
    Bill Dec 30, 2013

    correction...faulty NEW CPS...swapped again...fired in one turn

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Chevrolet Master
  • 1,449 Answers

Try push the rubber spark plugs covers down over your plugs.

Posted on Dec 26, 2013

  • Daniel Mc Entee
    Daniel Mc Entee Dec 28, 2013

    you have rubber covers that go over the spark plugs if not pushed fully down .the spark can jump .so it can arc .

×

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 120 Answers

SOURCE: I have 1996 chevy 1500 2wd 5.7 vortec tbi. When I

the car needs to be reset with the reset button located in the engine conpartment.hope this helps?

Posted on Aug 24, 2009

  • 1857 Answers

SOURCE: 2000 chevy C2500 wont start. No spark. Replaced

Did you check for codes. It won't matter what you change if your computer failed. You should of payed the diag fee. You would of saved alot of money.

Posted on Mar 18, 2010

bromech
  • 322 Answers

SOURCE: 1998 chevy k1500 vortec 305, high idle, surges a

TPS probably not cause surging idle. Could be IAC motor, could be MAF sensor. If you dont have a check engine light I would be thinking IAC motor.

Posted on Jan 21, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

New spark plugs new wires old distributor timing changed wen nee plugs were put on, clockwise or counterclockwise, don't know, besides the battery what firing order V8 305?


I don't know your year--make--model? You should be able to remove dist cap, crank the engine, watch which way the rotor turns, then you know the direction of rotation. Most chevy rwd v8, firing order, 18436572. The driver side bank is odd numbered, 1357.
The passenger side bank is even numbered, 2468 from front to back. Put your number one piston on tdc of compression stroke. Then whichever spark plug tower the rotor is leading into, should be number one, then you follow the firing order around the cap.

Mar 26, 2016 | Cars & Trucks

1 Answer

1998 chevy 1500 with 305 vortec, poor fuel milage approx 20kms/ $20.00


I averaged 9-10 MPG in my 98 w/5.7 l vortec.
cap, rotor, plugs, wires, O2 sensors, fuel filter, and fresh air filter are the best way to peak MPG's

Sep 06, 2013 | 1998 Chevrolet C1500

1 Answer

Will a throttle position sensor cause my 96 model Chevy blazer 4.3L vortec get bad gas mileage I'm only getting 225 miles to a full tank


I would replace both o2 sensors and take the mass air flow sensor off and clean it with a non-chlroated brake cleaner.Also a tune-up sure won't hurt sparkplugs,plug wires,distributor cap and rotor.Your fuel milage should increase.

Jan 13, 2012 | 1996 Chevrolet Blazer

2 Answers

I have 1996 chevy tahoe 350 vortec i have spark , fuel, and new throtle position sensor still only crank over no start though


unplug your mass air flow sensor i havd the same problem with my 97 tahoe unplug it and it should run

Jan 06, 2011 | 1996 Chevrolet Tahoe

1 Answer

98 chevy s-10 wont start


real comon starting problem for these is moisture in the cap and rotor and plug wires. replace cap, rotor, and wires. while you have the cap and rotor off check the two vent holles in the base of the distributer to see if the screens are plugged. be careful with the srews that hold the cap on the distibuters are plastic and will break.

Nov 14, 2008 | 1998 Chevrolet S-10 Pickup

1 Answer

No spark from plugs. changed plugs, rotor and distributor, cables, and primary coil.


i would start with the basics- did you make sure you followed the correct firing order when you installed your new plug wires? when you changed the cap/rotor did you notice any track marks inside the old cap? was the old rotor burnt/corroded? ive got a 97 ram and the cap is a b*tch to get to being buried in the back, could you have inadvertently moved the rotor off its timing mark? mis-aligned the crank sensor when installing your new cap? i would recheck how the cap was installed, just because you were able to position it proper and tightened down the screws doesnt mean that you didnt accidently pinch the wires on the crank sensor, or turned the rotor off its mark. also when pressing on the plug wires on the cap did you look for the "1" mark on the cap? this is your reference point for firing order. im not sure these are you problems, but rechecking your work to make sure something wasnt knocked off-kilter, or wrong plug wire placement would confirm the problem lies other than what was replaced. i hope this helps

Jul 25, 2008 | 1997 Dodge Ram 1500 Club Cab

Not finding what you are looking for?
Cars & Trucks Logo

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...