Question about 1987 Mercedes-Benz Mercedes Benz 190 Class

1 Answer

STALLING PROBLEM TURNED INTO NO START 1990 MB 300 SL

RUNS GREAT WHEN WARM, AFTER NUMEROUS TRIPS, STALLING ISSUE BEGINS!NEW FUEL PUMPS&FILTER RECENTLY, THREW PARTS AT CAR, OVER VOLTAGE PROTECTER RELAY, IGN. COIL, CAP & ROTOR, CRANK POSITION SENSOR,NOW CAR WON"T START. CHECKED FUEL PUMPS, WORK WELL WHEN POWERED UP WITH 12V'S, WHEN STARTING CAR, NO VOLTAGE @ PUMPS. HAD CAR IN SHOP, TECH SAID VOLTAGE @ PUMPS WERE ALL OVER THE PLACE(HIGH & LOW) DROVE CAR HOME AND KEPT STALLING, MADE IT HOME EVENTUALY.TECH SAID FUEL PUMP BAD. IT WAS NEW! QUIET @ TIMES THEN GETS VERY NOISY(BUZZY)POWERED UP AT CONS. VERY QUIET(BOTH PUMPS)CAR RUNS PERFECT MOST OF TIME!

Posted by on

  • 2 more comments 
  • pearl5000 May 19, 2009

    1990 MB 300SL ROADSTER W/ 3.0 6 CYL

  • pearl5000 May 20, 2009

    I THINK PROBLEM SOLVED? IT NEEDED A NEW ECU/MAS UNIT. I INSTALLED A NEW ONE AND IT STARTED RIGHT UP! DROVE IT FOR A WHILE , ALL SEEMS OK, I PRAY!

  • manuel domingo
    manuel domingo May 11, 2010

    hello,good day,i'm interested to your problem,i have some material to help you,but i'm confuse your model,1990 mb 300 sl or 1987 190 c class,pls. post your vin or engine number,ty

  • Anonymous Mar 24, 2014

    my car had a lag on starting the other day, now it won't start and it says 'low voltage" what could it be?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 408 Answers

Hello,good day,first we are in fuel side,better to install a fuel gauge,to determine the right pressure, is not mention your fuel pump relay,this should also check,some occasion the power supply is missing,now if all is in order (fuel side) then your switching unit(transistor box) need tobe check,assuming your engine is 103 engine,ty

Posted on May 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 v70 new fuel pump starts runs 10 mins. dies won't start again for a few hours


sounds like a fuel filter issue is there an inline filter

Mar 19, 2017 | Cars & Trucks

1 Answer

D50 starts cold but not when warmed up


Check fuel pump and filter,is it a camry or a truck..

Aug 21, 2015 | 1990 Toyota Camry

1 Answer

Car runs great and has about 200k on it. I have had it since it was new but about 100k ago the car started stalling after extended trips on the freeway. At the base of the offramp one out of 10 times the...


it sounds like the vehicle is starving itself for fuel... if it runs fine in town, or on close trips... sounds like when your on the freeway, and got the gas down its demanding fuel, and not getting what it needs to run, thats why it will start right back up.. if i were you i think i would start with the cheapest thing first and replace the fuel filter.. hope this helps.

Dec 14, 2010 | Lexus LS 400 Cars & Trucks

1 Answer

02 gmc sonoma 4.3 engine starts and runs great for 30 minutes and then stalls like its flooded, if it sets after stalling for 30 minutes and cools able to drive home before starting to stall again. After...


Smell of the oil,to see if the fuel injector(spider)is leaking into the crank case,if so,the intake will have to be removed to repair the problem,oh,and change the oil.

Jul 11, 2010 | 2002 GMC Sonoma Extended Cab

1 Answer

My car runs fine when it is first started, but after a while it starts stalling and stopping when I am driving.. I changed the oil filter and the fuel filter, but it still does it.


it's possible that the fuel pump is failing and begins to have problems once it gets hot. i would have someone check fuel pressure once it is warmed up and having the stalling issue.

Feb 04, 2010 | 1986 Volkswagen Jetta

2 Answers

97 sl1 started stalling when 1/4 tank of gas now stalls at 3/4 tank replaced fuel pump and filter/regulator twice runs great when full


It seems that cap of the tank is not letting in air to replace the volume consumed by the engine. Earlier, when it used to stall when1/4 full, there must been less blockage of air but now the air inlet must be really clogged-up,so much so that after being emptied 1/4 of fuel, the negative pressure built up inside the tank is enough to negate the fuel pumps capacity & without gas it will stall the engine which is being deprived of fuel.
One way to make sure that this IS the problem, fill the tank half, do not put the cap try a drive at least for 5 miles & if the engine does not stall, then one can be sure that he cap of the gas tank has to be replaced............sodeep

Oct 19, 2009 | 1997 Saturn SL

1 Answer

Runs great first thing. After warmed up, runs very


Could be fuel pressure regulator, fuel injector, sensor, or gasket leak.

Jul 07, 2009 | 1996 Saturn SL

1 Answer

Boging


hello there

Sounds like the MAF (Mass Air Flow) sensor which also gives similar problems.


Hope this helps, please don't forget to rate me.

May 20, 2009 | 1991 Mercedes-Benz Mercedes Benz Sl Class

1 Answer

2002 Saturn SC1 - Starts fine and runs well until the engine gets warm. Then I will step on the gas peddle and the engine will die. Sometimes it won't die it will just have no power to move. Fuel Pump?...


Most Likely Coolant temp sensor & connector.Located in cyclinder head under upper radiatior hose.Two wires to connector yellow & black.Replacement sensor is brass (from saturn) Original is ceramic & cracks cause poor performance,stalling,idle issues.Also check plugs & wires for carbon tracking.Replace plugs & wires as a set all at once.Hope this helps

May 12, 2009 | 2002 Saturn Sl

3 Answers

89 regal won,t start but after 5 or 10 min. runs great


sounds like your fuel pump is going out. One thought might be that the fuel filter is causing enough resistance to over heat the pump. I would check the fule pressure to determine a free flow of fuel.

May 01, 2009 | 1990 Buick Reatta

Not finding what you are looking for?
Cars & Trucks Logo

452 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...