Question about 1990 Ford F150

1 Answer

My 1990 f150 4.9L 6cyl hard starting and engine gets rough after a long run. When trying to keep constant speed seems to be missing.

Posted by on

  • davecheno May 18, 2009


    no, it seems to improve if i push down on the pedal

  • davecheno May 18, 2009


    no it seems to improve when i put my foot down

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Coil packs or leads probably, does it get worse is you put your foot down?

Posted on May 17, 2009

  • haydnm0 May 18, 2009

    Is the pick up carb or fuel injected, I pressume injected. If so has the Engine Management Warning light come on at all.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Runs rough when driving constant speeds


need to find out what codes are causing the engine light to come on and then start diagnosis from there

Dec 03, 2012 | 1999 Ford Expedition

1 Answer

2001 chevy cavalier, 2.2 auto, 140, 000 miles. Very rough idle, definite miss at a higher rpm (repetitive and identical spacing on the miss), and very hard shifts. Replaced plugs, wires, fuel filter, both...


check for a vacumn leak around the cyl head by spraying carb cleaner near head (caution do not spray flamable fluids on hot exhaust) listen for engine speed changes or smooth running/ engine faultering / stall, ....... could be broken vacumn line also......

Jul 19, 2011 | 2001 Chevrolet Cavalier

2 Answers

W/cruise engaged, engine seems to miss and run roughly


Its probably a problem with the cruise vacuum hose.......maybe blocked a little or the vacuum seal leaking a little. Trace the vacuum hose through to the engine area.

Jul 20, 2010 | 2001 Dodge Ram 1500 Truck 2WD

1 Answer

Check engine light came on the computer said misfire on number 2 and number 7. I installed new plugs and wires. The check engine light went off but it still seems to be missing and idling rough. When you...


missing at idle and good at highway speeds typically means either leaking injectors, vacuum leak and/or base engine concerns

I'd start with the injectors

May 14, 2010 | 1999 Dodge Ram

1 Answer

1999 3L S Type Jaguar Rough Running


WITH MOTOR RUNNING REMOVE ONE PLUG LEAD AT A TIME (INSULATED PILERS) MOTOR SHOULD REACT IF GOOD , IF ENGINE SPEED DOES NOT DROP ITS A FAULT AT THAT CLY, TRY NEW SPARK PLUG 1ST THEN LEAD, ALSO CHECK FOR ANY FAULTS OR SHORTING OF THE PLUG LEADS, COIL PACKS. (MORE NOTACABLE IN DAMP CONDITIONS) THESE CARS NEED TOP QUALITY PLUGS, OR THEY WILL ALL FAIL UNDER LOAD,

Dec 05, 2009 | 2000 Jaguar S-Type

1 Answer

My 2006 tdi idling speed is constant but sometimes


when you turn on the a/c the ecm increases engine fuel to compensate for extra load could possibly be a vacuum leak

Oct 15, 2009 | 2005 Volkswagen Jetta

1 Answer

Running rough and buzzing at throttle body injectors


Sounds like the engine has a vacuum leak at the throttle body area.

Jul 18, 2009 | 1990 Chevrolet Astro Extended

1 Answer

1990 maxima intermitent starting and missing issue


Check your coolant for traces of oil and your oil for a hand-creme like substance; you could have a failing headgasket.
Depending on where the gasket fails, you can have coolant entering the cylinders when the engine cools and contaminating the plugs; check those for any signs of rust. This will of course, cause hard starting and missing until somewhat warmed.   You can also have oil enter the coolant system or leaks of either running down the side of the block. 
If it has progressed far enough, checking the compression may show the loss.

Sep 14, 2008 | 1990 Nissan Maxima

Not finding what you are looking for?
1990 Ford F150 Logo

Related Topics:

235 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5474 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...