Question about 1999 Oldsmobile Alero

1 Answer

Gas won't pump into tank on 99 Olds Alero

When I go to put gas into my 99 olds alero, the pump will kick off after a few cents of gas and I can see the gas backing out the tank opening as I am trying to pump in gas. It takes me over 20 minutes to pump in $10 of gas. The tank is not full and it does this every time I try to get gas.

Posted by on

  • bcbcegan May 16, 2009

    It runs on unleaded gas.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 160 Answers

Is it a diesel pump, they have different nozzles

Posted on May 16, 2009

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

HansPP
  • 2510 Answers

SOURCE: When I go to put

You have a problem with your tank vent system. Have that looked at, there might be a blocked or kinked pipe somewhere.

Posted on Feb 26, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Have a 99 olds alero that when parked it was running but it sat for 4 years i changed all the filters and fuses but cant get to stay running itwill crank and rev up a bit.and go right back dead??


If it's been sitting for that long, maybe it needs FRESH gas in the fuel system,, or maybe some critters chewed up some wires under the hood..... Could be a few things

Jul 11, 2016 | 1999 Oldsmobile Alero

1 Answer

I have a 99 olds alero. I can drive awhile park the car try to start it and it won't crank. Newer battery and alternator. Mechanic is thinking manifold sensor. plz help


IF CAR TURN OVER NOT CRANKING AFTER A SHORT DRIVE WHEN ENGINE HOT.DIRTY CLOGGED FUEL INJECTORS FLOODING ENGINE OUT.CLEAN FUEL INJECTORS.FILL GAS TANK UP.PUT A CAN OF SEAFOAM IN FUEL TANK.DRIVE CAR AROUND TO HELP FLUSH OUT CARBON ON THE INJECTORS SEATS TO STOP GAS DRIPPING CAUSING FLOODING.IF CAR WONT TURN OVER.BAD BATTERY CABLES OR STARTER.SCAN IT FOR THEFT SECURITY PROBLEMS. IF STARTER TURNS OVER NO CRANK ENGINE FLOODING DUE TO DIRTY FUEL INJECTORS.

Sep 26, 2010 | 1999 Oldsmobile Alero

1 Answer

Fuel filler won't not accepting gas. takes only a


HAVE FUEL EVAPORATIVE SYSTEM CHECK OUT.SOUND LIKE PROBLEM IS IN THE EVAP CANISTER PURGE VALVE OR VENT VALVE.YOUR FUEL TANK BUILDING UP WITH GAS VAPORS KEEPING YOU FROM PUMPING GAS IN TANK.

Feb 07, 2010 | 1999 Oldsmobile Alero

2 Answers

1999 olds alero where is my fuel filter


The fuel filter is located under the car right in front of the fuel tank.You need to have up on jackstands to get to the filter.
Mine is located BEHIND the gas tank, between the tank and the rear (axel) support ('99 Olds Alero 3.4l v6 2 door coupe)

Oct 21, 2009 | 1999 Oldsmobile Alero

1 Answer

99 olds alero; fuel pump and inst. panel isn't getting power


fuel shutoff switch is actually a fuel pump relay in the relay box under the hood, but it is not unusual for a fuel pump to work on and off before it finally dies. but it is a good idea to check the relay first.

try swapping it with the horn relay (if the horn works). pay attention to the direction the relay is in. on GM's, it's possible to put them in backward or even miss the connectors completely.

you also want to check for proper power and ground in the relay socket.

Oct 03, 2009 | 1999 Oldsmobile Alero

1 Answer

2003 OLDS ALERO WONT START


find the buzzing noise...likely its the fuel pump relay.

May 28, 2009 | 2003 Oldsmobile Alero

1 Answer

1999 Olds Alero, unleaded gas. Am having problem with gas tank


have your evaporative purge valve solenoid check. because its controls the gas vapors going to canister purge or vent valve.take it to dealers have the evap system scan because its not venting or controling gas vapor.it suppose vent gas vapor to intake to be burn.if it dont work it causes excess gas vapor pressure built up in tank. make it hard to pump gas into it.

May 17, 2009 | 1999 Oldsmobile Alero

2 Answers

Where is the fuel pump located in a 2000 olds alero 3.4 automatic


it is in the tank, you will have to drop the tank to get to it. No other way around it.

Feb 20, 2009 | 2000 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

Related Topics:

628 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...