Question about 2000 Chevrolet Astro

1 Answer

I have a 93 astro. It needs starting fluid to start it, Then it runs fine. This happens at any time, most of the time it starts fine. I have done about everything i can think of,fuel pump,cap,rotor,filter,,,,,,,, cant seem to fix it.

Posted by on

  • billie ramos
    billie ramos May 11, 2010

    have you tryed a fuel injector cleaner..?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 54 Answers

Id say your coil is getting weak, if you havent already tried it, it has trouble producing the excessive amounts of spark required to start the vehicle.

Posted on May 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1992 Chevy Astro won't run, will start up great with starting fluid, or let it sit overnight.


You need to check the fuel pump pressure and I would change the fuel filter in the process. Sounds like you may have a bad fuel pump.

Sep 25, 2015 | Cars & Trucks

1 Answer

1996 Chevy Astro V6 67K wont start when cold, needs engine starter fluid, ok when warmed up. Runs smooth. What is wrong?


I would say that the choke sensor (or whatever it is called) went bad & isn't telling the computer that it's cold & requires more fuel. Instead of starter fluid, did you try to push the foot feed 1 or 2 times?

Mar 07, 2015 | 1996 Chevrolet Astro

1 Answer

95 Astro van is taking many times to start. Had the fuel filter changed, tried cleaner, oil changed, oil cleaner. Any advice?


hook up fuel pressure gauge see what it reads,could be low,or u can try spraying starting fluid in it take off air cleaner make sure starting fluid is getting in intake,if it starts quicker id say low fuel pressure is problem

Feb 02, 2013 | 1995 Chevrolet Astro

1 Answer

Have a1998 astro van that wont start until I spray starting fluid in the throttle body, then starts up and runs fine until about two hours later I go to start it back up and it wont start again.PLEASE HELP...


The first thing you need to check is fuel pressure. This type of fuel system requires a minimum fuel pressure of 56 psi to start. Anything less, even as little as 1psi. And it will not start. It starts and runs when you add the starting fluid because the poppets (the mechanical injectors located at each cylinders intake runner) require less fuel pressure to operate when the intake is under vacuum.

This is a classic symptom of low fuel pressure. A new fuel pump is the typical fix for this problem. Don't skimp on quality if you do need a new fuel pump. They are not all the same.

May 24, 2011 | 1998 Chevrolet Astro

2 Answers

93 chevy astro will not start


You need to check fuel pressure. Fuel pump may be working but weak.

Mar 14, 2010 | 1993 Chevrolet Astro

3 Answers

92 astro runs rough


have mass airflow sensor cked.

May 28, 2009 | 1993 Chevrolet Astro

2 Answers

Won't start


I would think you have a faulty coil

May 19, 2009 | 1997 Chevrolet Astro

2 Answers

Trouble code 42 ignition module failure


Also check all of your grounds, a little corrosion caused the same problem on mine. Just had to find the right ground. Mine was on front under pass headlight causing mine. Good Luck

Apr 20, 2009 | 1993 Chevrolet Astro

Not finding what you are looking for?
2000 Chevrolet Astro Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6918 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...