Question about 1999 Chevrolet Silverado 1500

1 Answer

Blower working on and off minimally

Fan blower blowing minimal not even low speed for a 1999 chevrolet silverado 1500 series (old body style)

Posted by on

  • Carl Rimmer May 11, 2010

    Does it do this on all blower speeds? First i would check the connection plug at the resistor(the blower harness plug is connected to the resistor) Try wiggling the plug back and forth, if nothing changes try tapping on the blower motor itself, if the speed picks up its bad brushes in the motor. All of this is below the glove box, just remove the plastic cover near where the passengers feet would be.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 426 Answers

Either the blower motor is about to go out or the wires to it are shorting.check the wire going to the motor from the blower resister.It is possible the plug itself has gotten hot and is burnt. passenger side under dash

Posted on Jul 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Blower motor only workson high speed


most likely your blower motor resistor pack. It allows you to have low medium and high speeds. If a winding is broke in the resistor pack, then it could only work on high

Jan 03, 2011 | 1999 Chevrolet Silverado 1500

1 Answer

1999 siverado 1500. heater fan works on all five speeds but i have low air flow.having trobble keeping windows defrosted. could i be a blendgate.


It sure could be a blend gate. I have had some problems with the blower motor fans rubbing on the inside of the hvac housing too. When this happens the air will not flow to the hvac housing and then out to the vents. It is an easy check. Just pull out your blower motor and check the housing for any rubbing marks on the housing or the fan. Past that then you need to further check the blend doors or possible blockage of the heater core or A/C evaporator. Hope this helps.

Dec 31, 2010 | 1999 Chevrolet Silverado 1500

1 Answer

Why does my blower motor for my 97 silverado does not work?


Check for a blown fuse,
Check for faulty blower motor speed control resistor pack - (usually located in the air flow in the blower ducting),
Check the blower motor is ok; ensure it runs if power directly applied to it.
Check blower motor fan control switch is ok.

Oct 07, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

2005 silverado heater fan not working


unplug the blower motor and test it for power and ground, find out which isnt working, if there is a failier at the socket you may have a bad blower speed control. If that socket passes you testes then it should be your blower motor.

Apr 30, 2009 | 1999 Chevrolet Silverado 1500

2 Answers

Heater blower only blows on low


This could be a few different things:

1.Check the power and ground connections on your blower motor, corrosion can cause high resistance and a slow blower speed.

2. Check your available voltage at the blower motor on the different settings. it should vary with high supplying 12volts, make sure to do this check with the blower motor still plugged in.

3. Connect the blower to a 12v power source and see if it runs at high speed.

If all else fails i would check your resistor pack, i would not suspect this because when it fails you usually just loose all speeds except for high, but it could happen.

Feb 25, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...