Question about 1994 Ford Tempo

2 Answers

My '94 Tempo just started sputtering, with loss of power. If I floor it from a take off it'll get up to speed then, I can take my foot out of it and it runs ok unless I have my foot into the gas pedal at all then, it misses and falls on it's face. So, floor it from a stop and foot barely on the gas pedal it runs ok. gas pedal between barely idling and wide open it runs poorly. any one have a suggestion? Thanks.

Posted by on

  • hotrodtempo May 24, 2009

    Thanks, it was the MAF.

  • gerry bissi May 11, 2010

    clean the mass air flow sensor with spray carb cleaner and a toothbrush. may be too lean running.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 4,369 Answers

Your welcome. Please rate as problem solved for me, thanks.

Posted on May 24, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,055 Answers

Maf sensor or fuel pressure regulator

Posted on May 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Tahoe power loss


If the exhaust note sounds like a jet engine ,loud hissing,the catalitic converter has plugged. Makes the symtom you are speaking of.

Nov 25, 2013 | Cars & Trucks

1 Answer

Loss of power at low speeds, car doesn't stall but will have my foot to the floor and car won't rev up. Once I come to a complete stop car will work fine again. Recently had my catalytic converter replaced...


Yes, many things. First do you have any trouble codes? Loss of power at any speed almost always pertains to air (vacuum) either leaking or blocked. That's an inexpensive place to start. Test all intake vacuum including egr and pcv with a inexpensive vacuum gauge.
Other possible things to look at is dirty fuel injectors or a small stone in the fuel line between the filter and the injector but these possibilities are more labor intensive and not as common.

Nov 20, 2017 | 1988 Nissan 300ZX

1 Answer

Sputters at cruising speeds, but not when floored


have you had you fuel system cleaned? meaning had your injector cleaned?

Dec 18, 2009 | 2001 Saturn S-Series

1 Answer

99 silverado sputtering & loss of power(low rpms)


Have you performed a tune up? If not, it's time for one. spark plugs, wires, distributor cap and rotor.

Oct 06, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Power to car but won't turn over or start when


try hiting the starter with a hammer if it stakts then yes it is rooted

Jul 16, 2009 | 1994 Ford Tempo

1 Answer

Golf SDI 2.0,cannot go faster than 80mph even with my foot to the floor!! I have just had a whole new clutch this week. any ideas why the loss of power.


possibly the speed governor is broken? you should definately take this to a volkswagen repair shop, you don't sound like a mechanic to me! :)

Jun 14, 2009 | 2001 Volkswagen Golf

1 Answer

Engine Floods after brief start and run when cold -then shut off


Local mechanic determined engine was flooded and started it by holding throttle to the floor and cranking 5-7 seconds - then the engine sputtered to life. It has run perfectly before and since and I'm at a bit of loss to understand why this occurred this one time - so far. It's been driven now 5 days with no problems.

Nov 19, 2008 | 1996 Honda Odyssey

Not finding what you are looking for?
1994 Ford Tempo Logo

Related Topics:

262 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

79186 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

fordexpert

Level 3 Expert

5677 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...