Question about 1997 Ford Ranger SuperCab

1 Answer

A/c will blow but isn't cold, checked the freon level it is fine what else could be the problem?

Posted by on

  • yadayada
    yadayada May 11, 2010

    does the AC compressor run? does the large AC line gets cold that comes from the compressor under the hood?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 4,369 Answers

Check temp blend door. may not be rotating from heater core to a/c evaporator.
vacuum or electric motor controls roatation. Also, check temp dial on control head. It may not be telling belnd door motor to rotate if it's bad.

Posted on May 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rear a/c not blowing cold, front works fine.


If the front blows cold it would suggest that the freon level is ok. However, if the freon is low, it still may blow somewhat cold in the front and less adequate in the back. Have you had the pressures checked to verify the charge is ok? Does the rear fan motor work? There also may be a restriction or defective expansion valve in the rear causing little/no freon circulation. Another problem could be a defective/stuck blend door in the rear causing the cold air to not circulate

Sep 12, 2015 | Cars & Trucks

1 Answer

I HAVE A 2001 CHEVY TAHOE FRONT AC BLOWS COLD REAR DOESNT


I would agree it might be the valve.
One line should be cold and the other warm or hot.

Oct 02, 2012 | 2001 Chevrolet Tahoe

1 Answer

On my 2004 gmc sierra 1500 the compressor cycles on and off. i tried to add more freon but it would not take the freon so i changed the low pressure switch but still doing the same thing. could the orfice...


When the compressor kicks on, is the air from the vents blowing cold? If the air isn't blowing cold, then your problem could be that you may have water in the system. I had a '93 Chevy Z71 that wouldn't blow cold and thats what my problem was. System needs to be evacuated and refilled. Good luck bro.

Aug 14, 2012 | 2004 GMC Sierra

1 Answer

Only blows hot air


Sorry, your question does not contain enough information for anyone to accurately help you with your problem. For anyone to provide specific information for you, they will first need to know the YEAR, MAKE, MODEL, and ENGINE SIZE of the vehicle that you want the information for.

With that said, if the freon levels have been checked properly, then it would be safe to assume that somebody would know what the pressure readings were when it was checked...what were they? High side? Low side?
Can you hear the blend-air door moving when you switch from COLD to HOT and back to COLD?

May 25, 2012 | 2003 Chevrolet Monte Carlo

1 Answer

Describe your 2005 explorer ac wont blow cold air Problem


the problem is probably low freon there should be a place on one of the hoses to check the freon level. you can usually get a gage when you buy the freon. if the freon isn't the problem than the problem is probably with the compressor. I would check the freon first.

May 12, 2011 | Ford Explorer Cars & Trucks

1 Answer

Hello everyone I have a 2004 nissan titan and when I am travelling down the highway the ac blows warm I have checked the freon level and it has the proper amount of refrigerent in it and the clutch fan...


Hey Wb, You say you checked the pressure and its ok. Have you checked to see if the pressure is actually freon or just hot air..(this is from a personal experience with the same symptoms) Let some of the pressure off the system while it is running..(the low pressure valve) and if freon does not immediately come out.- Just hot air..let it bleed until freon comes out .. (mine was overcharged and I had to let out A LOT of air out of the system until freon started coming out).. try this and see if it helps.. ...mine is working fine..blowing cold air 24/7 after this .. with no other steps,,,

Jun 24, 2017 | 2004 Nissan Titan

1 Answer

Air condition won't blow cold


Clogged ORFICE TUBE and or Low Freon Level.

Jun 04, 2010 | 1998 Plymouth Breeze

1 Answer

Ac blows inconsistant ford 3.8l mustang 1995


have you had the freon level checked? Sounds like it is low on freon. My lincoln did that and it was just low on freon.

Jun 24, 2009 | 1995 Ford Mustang

Not finding what you are looking for?
1997 Ford Ranger SuperCab Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

79847 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

fordexpert

Level 3 Expert

5685 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...